Package Details: nemo-compare 5.4.1-1

Git Clone URL: https://aur.archlinux.org/nemo-compare.git (read-only, click to copy)
Package Base: nemo-compare
Description: Context menu comparison extension for Nemo file manager
Upstream URL: https://github.com/linuxmint/nemo-extensions
Licenses: GPL3
Submitter: arnok
Maintainer: twa022
Last Packager: twa022
Votes: 25
Popularity: 0.33
First Submitted: 2015-02-04 22:46 (UTC)
Last Updated: 2022-07-20 01:44 (UTC)

Dependencies (7)

Required by (0)

Sources (1)

Latest Comments

1 2 Next › Last »

MarsSeed commented on 2022-06-18 18:52 (UTC)

Hi,

Please add a version constraint for the python-xdg dependency.

If you need the module named xdg, define depends=(python-xdg>=5) for example, or at least >=1.

If the package needs the official freefesktop.org library, which is called pyxdg, define the depends as python-pyxdg as that is the current name of it in the repo.

(The problem is, that one virtually provides python-xdg as well, because earlier Arch had used that name wrongly for the pyxdg package.)

The official python-pyxdg, virtually named python-xdg in Arch, is only at version 0.28 so it is below 1. Whereas the PyPI module name xdg never had a version below 1. Therefore the version number is the only way for you to enforce using xdg, if that is the actually needed package.

sebalis commented on 2020-05-30 11:13 (UTC) (edited on 2020-06-02 07:39 (UTC) by sebalis)

I just installed upstream version 4.6.0 by manually changing the PGKBUILD. I changed all version numbers in the dependencies from >=4.0 to >=4.6 (and also followed the suggestion from yochananmarqos to change python2-xdg to python-xdg but as I have both these packages, I can’t test whether that made a difference). This worked, but only with another intervention: The file /usr/share/nemo-compare/nemo-compare.py needs to be copied or linked to the /usr/share/nemo-python/extensions folder, which the current version of this build file does not do. I opted to create a symbolic link and added this to the package function. Would love to provide my working PKGBUILD but I don’t know how – does the AUR do pull requests? I did save my local clone of the git repo so I could still submit one.)

yochananmarqos commented on 2019-01-04 21:08 (UTC)

Shouldn't the dependency be python-xdg instead of python2-xdg since it's using Python3 now?

yochananmarqos commented on 2018-11-06 14:31 (UTC)

Thanks for adding the other diff tools. By the way, you forgot remove diffuse from depends.

yochananmarqos commented on 2018-11-05 21:49 (UTC)

The diff tools should all be optional. Could you add the others as well? See the Debian control file:

Depends: ${misc:Depends},
         nemo (>= 3.8),
         python3,
         python-nemo (>= 3.9.0),
         meld | kdiff3 | kdiff3-qt | diffuse | kompare | fldiff | tkdiff | bcompare

nullptr_t commented on 2017-09-11 08:24 (UTC) (edited on 2017-09-11 08:36 (UTC) by nullptr_t)

I've got similar problems with meld and kdiff3. At least specifying the diff extension (the others work for me) when executing `nemo-compare-preferences` helps to successfully start the diff viewer. If the problem still persists afterwards, you can start nemo from command line and post the output of what happens when trying to compare two files.

GFdevelop commented on 2017-09-10 10:42 (UTC)

not working with nemo 3.4.7 I have tried meld and diffuse.

valsaven commented on 2016-11-08 09:23 (UTC)

There is a conflict with the latest nemo version. Please, change nemo<3.1 to nemo>3.1 or simular. It works well.

nullptr_t commented on 2015-12-04 11:26 (UTC)

Sorry, forgot git push here