Package Details: nvidia-beta-dkms 525.60.11-1

Git Clone URL: https://aur.archlinux.org/nvidia-beta-dkms.git (read-only, click to copy)
Package Base: nvidia-beta-dkms
Description: NVIDIA driver sources for linux (beta version)
Upstream URL: https://www.nvidia.com/
Licenses: custom
Conflicts: nvidia, nvidia-dkms
Provides: nvidia, nvidia-beta, nvidia-dkms, NVIDIA-MODULE
Submitter: alucryd
Maintainer: dbermond
Last Packager: dbermond
Votes: 51
Popularity: 0.001190
First Submitted: 2013-03-12 11:21 (UTC)
Last Updated: 2022-11-29 17:03 (UTC)

Required by (44)

Sources (3)

Latest Comments

1 2 3 4 5 6 .. 21 Next › Last »

tukusejssirs commented on 2022-11-28 11:12 (UTC) (edited on 2022-11-28 11:33 (UTC) by tukusejssirs)

525.53 causes me (I presume) some big issues with cursor state: the cursor is either not visible at all (which happens especially under GNOME 43.1 after some time) or the image is stuck in one state (arrow [the usual state] or hand [to drag something] or I [text selector]) across all apps. It is always in arrow state when I move the cursor over the Waybar panel, but it changes to the previous stacked state when moved over a (Wayland) window. The cursor state works in alacritty, portmaster-bin, slack-electron, electron-mail, telegram-deskop. It does not work in mailspring, firefox-nightly (heftig repo), sublime-text, Discord (flatpak: com.discordapp.Discord), todoist-appimage.

As for the glitches, 525.53 solves most of my glitches exept for one: electro-mail which is an Electron app, however, I have run it under XWayland before upgrading to 525.53, and after I upgraded to 525.53 I run it with --ozone-platform=wayland --enable-features=UseOzonePlatform --enable-features=WaylandWindowDecorations (thus in Wayland). That said, even glitches in electron-mail are mostly removed, however, when I launch electron-mail, I get mostly grey (only the divider between the message list and the reading pane is visible) until I move the cursor of the 3-4 grey areas.

Also, I have issues with screen-sharing (in Firefox using WebRTC + xdg-desktop-portal and both xdg-desktop-portal-gnome and xdg-desktop-portal-wlr), even under GNOME 43.1. Note that I use sway-git as my default WM.

Just to provide more information, I use the following env vars (/etc/environment), maybe I have something incorrectly configured:

__GL_GSYNC_ALLOWED=0
__GL_VRR_ALLOWED=0
__GLX_VENDOR_LIBRARY_NAME='nvidia'
BROWSER='firefox-nightly'
CLUTTER_BACKEND='wayland'
EDITOR='nano'
GBM_BACKEND='nvidia-drm'
GTK_THEME='Adwaita:dark'
MOZ_ENABLE_WAYLAND=1
MOZ_USE_XINPUT2=1
MOZ_WEBRENDER=1
QT_ACCESSIBILITY=1
QT_IM_MODULE='ibus'
QT_QPA_PLATFORM='wayland'
QT_QPA_PLATFORMTHEME='qt5ct'
QT_WAYLAND_DISABLE_WINDOWDECORATION=1
SDL_VIDEODRIVER='wayland'
WLR_NO_HARDWARE_CURSORS=1
WLR_RENDERER_ALLOW_SOFTWARE=1
XDG_CURRENT_DESKTOP='Unity'
XDG_SESSION_TYPE='wayland'

tnujaka commented on 2022-11-26 19:08 (UTC)

525.53 is definitely a problematic driver. It breaks a lot of things.

Fazzi commented on 2022-11-25 21:18 (UTC)

Having a lot of issues with this build. Just me?

Launching firefox with video hardware acceleration setup, I get this error: [GFX1-]: glxtest: VA-API test failed: process crashed. Please check your VA-API drivers.

Discord doesn't launch, gives me these errors: [19563:1125/211656.118164:ERROR:gpu_process_host.cc(991)] GPU process exited unexpectedly: exit_code=256 (electron) 'gpu-process-crashed event' is deprecated and will be removed. Please use 'child-process-gone event' instead.

tomilov commented on 2022-10-12 18:10 (UTC)

Is there a package with developers version of the drivers? The latest version is 515.49.19 for this.

tnujaka commented on 2022-10-12 14:09 (UTC)

New version released. It would be great if you update it to 520.56.06

tomilov commented on 2022-10-11 21:34 (UTC) (edited on 2022-10-11 21:34 (UTC) by tomilov)

When I tried to install either of beta drivers (nvidia-beta or nvidia-beta-dkms) I get an error:

==> dkms install --no-depmod nvidia/515.76 -k 5.10.147-1-MANJARO
==> dkms install --no-depmod nvidia/515.76 -k 5.9.16-1-MANJARO
Error! Bad return status for module build on kernel: 5.9.16-1-MANJARO (x86_64)
Consult /var/lib/dkms/nvidia/515.76/build/make.log for more information.
==> WARNING: `dkms install --no-depmod nvidia/515.76 -k 5.9.16-1-MANJARO' exited 10
==> depmod 5.10.147-1-MANJARO
==> ERROR: Missing 5.10.135-1-MANJARO kernel modules tree for module nvidia/515.76.

Is there way to avoid the error?

tukusejssirs commented on 2022-06-08 15:49 (UTC) (edited on 2022-07-05 10:22 (UTC) by tukusejssirs)

@dbermond, do you mean like this? It does not work. Both paths exist and are built.

sudo pacman -U ~/.cache/yay/nvidia-utils-beta/ ~/.cache/yay/nvidia-beta-dkms
loading packages...
error: could not open file ~/.cache/yay/nvidia-utils-beta/: Error reading fd 7
error: '~/.cache/yay/nvidia-utils-beta/': cannot open package file
error: could not open file ~/.cache/yay/nvidia-beta-dkms: Error reading fd 7
error: '~/.cache/yay/nvidia-beta-dkms': cannot open package file

If it is not obvious, I get exactly the ~~same~~ similar error as @ChrisK.

Update

Running yay -Syu while it contains updates of nvidia-utils-beta nvidia-beta-dkms (both packages should be clean-built) actually fails with this error:

looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils-beta (515.57-1) breaks dependency 'nvidia-utils-beta=515.48.07' required by nvidia-beta-dkms
 -> exit status 1

The only way I found to ~~fix~~ work around this error is to reinstall it like this:

# Fix by removing and reinstalling the packages
yay -R nvidia-utils-beta nvidia-beta-dkms
yay -S nvidia-utils-beta nvidia-beta-dkms

# Just to make sure everything is updated
yay -Syu

dbermond commented on 2022-06-06 20:54 (UTC)

@ChrisK The package already depends on "nvidia-utils-beta=${pkgver}" (see the PKGBUILD). You need to separately build nvidia-utils-beta and nvidia-beta-dkms, and then install both together with 'pacman -U path/to/nivida-utils-beta path/to/nvidia-beta-dkms'.

ChrisK commented on 2022-06-06 10:14 (UTC) (edited on 2022-06-06 10:15 (UTC) by ChrisK)

need to update nvidia-utils-beta version dependency:

error: failed to prepare transaction (could not satisfy dependencies)
:: installing nvidia-utils-beta (515.48.07-1) breaks dependency 'nvidia-utils-beta=515.43.04' required by nvidia-beta-dkms

dbermond commented on 2022-05-12 04:49 (UTC)

I have prepared nvidia-open-beta and nvidia-open-beta-dkms for those who are interested. VCS (-git) packages are also available. Notice that open source modules currently has limitations in comparison to proprietary modules.