Package Details: nvidia-beta-dkms 535.113.01-1

Git Clone URL: (read-only, click to copy)
Package Base: nvidia-beta-dkms
Description: NVIDIA driver sources for linux (beta version)
Upstream URL:
Licenses: custom
Conflicts: nvidia, nvidia-dkms
Provides: nvidia, nvidia-beta, nvidia-dkms, NVIDIA-MODULE
Submitter: alucryd
Maintainer: dbermond
Last Packager: dbermond
Votes: 54
Popularity: 0.23
First Submitted: 2013-03-12 11:21 (UTC)
Last Updated: 2023-09-22 18:55 (UTC)

Required by (43)

Sources (3)

Latest Comments

1 2 3 4 5 6 .. 21 Next › Last »

Mithras commented on 2023-06-06 20:33 (UTC)

It would be great if -beta packages update quicker. It's probably less of a concern for non-beta packages but not having -beta updated defies the purpose of having -beta in the first place. Instead of testing -beta and reporting bugs, all the bugs will go into release.

bittin commented on 2023-03-14 15:56 (UTC)

Works good on my system @dbermond and @milkii your comments helped me so thanks for that

Dequa commented on 2023-02-13 20:00 (UTC)

I'm sorry but I don't get the purpose of this package. Why not offer the Vulkan beta driver instead?

@@ -9,7 +9,7 @@
 # Contributor: sl1pkn07 <sl1pkn07 at gmail dot com>

 pkgdesc='NVIDIA driver sources for linux (beta version)'
@@ -19,11 +19,11 @@
 conflicts=('nvidia' 'nvidia-dkms')

dbermond commented on 2023-01-14 14:06 (UTC)

@milkii You need to install all related packages at the same time.

milkii commented on 2023-01-06 22:28 (UTC) (edited on 2023-01-06 22:33 (UTC) by milkii)

:: installing nvidia-utils-beta (525.78.01-1) breaks dependency 'nvidia-utils-beta=525.60.11' required by nvidia-beta-dkms

edit: ah i see they've all gone up to .78, i'll go back to the regular package. hopefully the horiffic external monitor bug(s) are fixed now..

tukusejssirs commented on 2022-11-28 11:12 (UTC) (edited on 2022-11-28 11:33 (UTC) by tukusejssirs)

525.53 causes me (I presume) some big issues with cursor state: the cursor is either not visible at all (which happens especially under GNOME 43.1 after some time) or the image is stuck in one state (arrow [the usual state] or hand [to drag something] or I [text selector]) across all apps. It is always in arrow state when I move the cursor over the Waybar panel, but it changes to the previous stacked state when moved over a (Wayland) window. The cursor state works in alacritty, portmaster-bin, slack-electron, electron-mail, telegram-deskop. It does not work in mailspring, firefox-nightly (heftig repo), sublime-text, Discord (flatpak: com.discordapp.Discord), todoist-appimage.

As for the glitches, 525.53 solves most of my glitches exept for one: electro-mail which is an Electron app, however, I have run it under XWayland before upgrading to 525.53, and after I upgraded to 525.53 I run it with --ozone-platform=wayland --enable-features=UseOzonePlatform --enable-features=WaylandWindowDecorations (thus in Wayland). That said, even glitches in electron-mail are mostly removed, however, when I launch electron-mail, I get mostly grey (only the divider between the message list and the reading pane is visible) until I move the cursor of the 3-4 grey areas.

Also, I have issues with screen-sharing (in Firefox using WebRTC + xdg-desktop-portal and both xdg-desktop-portal-gnome and xdg-desktop-portal-wlr), even under GNOME 43.1. Note that I use sway-git as my default WM.

Just to provide more information, I use the following env vars (/etc/environment), maybe I have something incorrectly configured:


tnujaka commented on 2022-11-26 19:08 (UTC)

525.53 is definitely a problematic driver. It breaks a lot of things.

Fazzi commented on 2022-11-25 21:18 (UTC)

Having a lot of issues with this build. Just me?

Launching firefox with video hardware acceleration setup, I get this error: [GFX1-]: glxtest: VA-API test failed: process crashed. Please check your VA-API drivers.

Discord doesn't launch, gives me these errors: [19563:1125/] GPU process exited unexpectedly: exit_code=256 (electron) 'gpu-process-crashed event' is deprecated and will be removed. Please use 'child-process-gone event' instead.

tomilov commented on 2022-10-12 18:10 (UTC)

Is there a package with developers version of the drivers? The latest version is 515.49.19 for this.

tnujaka commented on 2022-10-12 14:09 (UTC)

New version released. It would be great if you update it to 520.56.06