Package Details: nyan-lang-git r124.92657c7-1

Git Clone URL: https://aur.archlinux.org/nyan-lang-git.git (read-only, click to copy)
Package Base: nyan-lang-git
Description: A data description language designed for openage
Upstream URL: https://github.com/SFTtech/nyan
Licenses: LGPL3
Conflicts: nyan-lang
Provides: nyan-lang
Submitter: nerflad
Maintainer: nerflad
Last Packager: nerflad
Votes: 3
Popularity: 0.35
First Submitted: 2017-12-31 03:20
Last Updated: 2018-01-11 03:51

Required by (1)

Sources (1)

Latest Comments

FabioLolix commented on 2020-02-07 05:40

@aconsolelogger base-devel group is assumed to be installed and there is no need to add those

aconsolelogger commented on 2020-02-06 22:29

unmentioned build dependencies: flex make

edit: @FabioLolix Thanks. Didn't know about the assumption that base-devel is installed. Still new here. unflagged

nerflad commented on 2018-01-11 04:01

@FabioLolix Done, thanks. Much like any package having to do with the Go programming language, nyan-lang should be a fine name for these packages. The developers should have known that the name, being a reference to a meme, was bound to have a collision. As long as we stay consistent with the -lang naming convention, it should be okay.

FabioLolix commented on 2018-01-10 00:09

@nerflad can you add conflicts=('nyan-lang') to the pkgbuild, for future use. Thanks

@TheJJ I was carried away by other things in the last days I even forgot to git push the latest pkgbuilds commits to gituhb, updated pkgbuild will be uploaded in minutes.

For the nyan package, it is actually in use by this https://github.com/shibumi/nyan and can't be claimed, you can claim 'nyan-lang', previously created by @nerflad, when there is a stable release of nyan. Claimimg a now deleted pkgbuild have the same procedure as creating a new one I guess. cheers

TheJJ commented on 2018-01-09 14:57

@FabioLolix nyan is a hard dependency of openage. I'd have called the package nyan-git, but i see that the non-git name is occupied already. Not sure what the usual procedure in the AUR is to "claim" a package name.

FabioLolix commented on 2017-12-31 00:42

Hello, how I should add this, as depends or optdepends?

I looked at this pkgbuild and it can be improved

First, you have made a development package and called it like a stable package, since there aren't stable version out you should create a nyan-lang-git package and ask to merge nyan-lang to it.

A version with several fixes is here https://github.com/FabioLolix/PKGBUILD/blob/master/00_AUR_fix/nyan-lang-git/PKGBUILD

adding the version to depends is usualy not needed, there is already ggc 7.2 in the repo for example, other fixes are really due instead

I've enabled notifications for this package if you have any question nyan-lang-git