Package Details: ocaml-xmlm 1.2.0-1

Git Clone URL: https://aur.archlinux.org/ocaml-xmlm.git (read-only)
Package Base: ocaml-xmlm
Description: OCaml xml manipulation module
Upstream URL: http://erratique.ch/software/xmlm/
Licenses: BSD
Submitter: thatch45
Maintainer: J5lx
Last Packager: J5lx
Votes: 31
Popularity: 0.204671
First Submitted: 2011-01-15 05:02
Last Updated: 2015-07-03 14:38

Latest Comments

J5lx commented on 2016-11-18 18:18

As much I'd like to do that, it's probably not going to happen in the near future, sorry. I've got a lot of school work to do atm and if I'd increase the release numbers for all of my 109 OCaml packages whenever some dependency receives an update I'd drown in work (plus, I'd probably go crazy sooner or later). At some point I'd like to make myself some script which assists me in detecting these incompatibilities and rolling out updates accordingly, but right now I just don't have the time for that. So for the time being you'll just have to remake these packages by yourself.
That being said, I'll take care of ocaml-alsa today.

M0Rf30 commented on 2016-11-17 19:18

please update your release number in order to recompile with latest version of ocaml, otherwise liquidsoap says:

Error: /usr/lib/ocaml/xmlm/xmlm.cmi
is not a compiled interface for this version of OCaml.
It seems to be for an older version of OCaml.

archmylinux commented on 2014-10-28 16:39

In the PKGBUILD file

I think the line:
- makedepends=('ocaml ocaml-findlib')
should be:
+ makedepends=(ocaml ocaml-findlib)

I suppose packer interpreted this as ['ocaml', 'ocaml-findlib'] while makepkg as ['ocaml ocaml-findlib'] witch he could not find hence the "unmet dependency" error.

leonardder commented on 2014-07-03 07:23

Added staticlibs to options array. Haven't made the switch to the new version due to the new build system though.

Myshkin commented on 2014-04-29 18:20

The new version has a new build system. It may be simple enough but I don't feel like installing or trying to figure out yet another one so I'm putting this up for adoption.

sebleblanc commented on 2013-11-08 22:09

You should write either this:
makedepends('ocaml' 'ocaml-findlib')
or
makedepends(ocaml ocaml-findlib)

mlq commented on 2013-10-14 21:26

Please fix the makedepends.