Package Details: oolite 1.90-3

Git Clone URL: (read-only, click to copy)
Package Base: oolite
Description: A space-sim based on the classic Elite
Upstream URL:
Keywords: elite game role-playing space trading
Licenses: GPL2
Submitter: Barthalion
Maintainer: SanskritFritz
Last Packager: SanskritFritz
Votes: 11
Popularity: 0.034029
First Submitted: 2018-01-16 18:40 (UTC)
Last Updated: 2020-11-02 09:34 (UTC)

Latest Comments

simona commented on 2022-04-04 09:53 (UTC)

oolite depends on espeak (obsolete) instead of espeak-ng...

SanskritFritz commented on 2021-12-11 21:28 (UTC)

Thanks Wolf, I revived the espeak package in the AUR for the time being.

Lone_Wolf commented on 2021-12-05 15:52 (UTC)

found it,

It does still build ok.

Lone_Wolf commented on 2021-12-05 14:44 (UTC)

Adding both espeak-ng and espeak-ng-espeak is not enough, it does seem like espeak-ng is not compatible enough with espeak.

I looked at build options and atm it seems there are 2 possible solutions:

  • revive espeak as an aur package

  • use deps-release as build target so oolite will use the libraries they provide under src/deps/Linux-deps instead of systemwide installed libraries.

There doesn't appear to be a way to do this only for espeak, and I kinda doubt these older precompiled libraries will work well on archlinux.

(It failed miserably at runtime every time I tried it out of curiosity)

I'm currently trying to find the last PKGBUILD for espeak

SanskritFritz commented on 2021-12-05 13:13 (UTC)

but it doesn't provide espeak. So should I simply change the dependency?

Lone_Wolf commented on 2021-12-05 11:06 (UTC)

Looks like espeak-ng-espeak from community takes care of that.

SanskritFritz commented on 2021-12-05 08:50 (UTC)

In this case shouldn't espeak-ng provide espeak?

dimich commented on 2021-12-05 08:19 (UTC) (edited on 2021-12-05 08:20 (UTC) by dimich)

'espeak' is no longer available in AUR. Oolite can be built and works with 'espeak-ng' from community repo, just create symlink pointing to in /usr/lib/.

charlie5 commented on 2020-11-10 18:21 (UTC) (edited on 2020-11-10 18:22 (UTC) by charlie5)

A truly excellent game. Highly recommend installing the 'Beginners' expansion pack !

Cheers to SanskritFritz for making it available.

charlie5 commented on 2020-11-04 12:59 (UTC)

Heya again fellas,

I played this game back in 1982 (on a commodore64) and loved it.

Heh, it took 30+ minutes to load off the tape but worth the wait.

Can anyone recommend an arch/linux joystick ? I am hopeless using the k/b arrow keys :P ... Cheers.

SanskritFritz commented on 2020-11-02 09:35 (UTC)

Thanks guys for all the help!

charlie5 commented on 2020-11-02 06:40 (UTC)

Thanks @Lone_Wolf ... works for me now also.

Lone_Wolf commented on 2020-11-01 23:36 (UTC)

Found a workaround at .

deleting the png header files in prepare() works, but there may be a cleaner solution.

prepare() {
    cd "oolite-source-$pkgver"
    rm deps/Linux-deps/include/png.h
    rm deps/Linux-deps/include/pngconf.h

Lone_Wolf commented on 2020-11-01 23:22 (UTC)

snippet from $HOME/.Oolite/Logs/Latest.log

23:44:48.785 [texture.load.png.warning]: ----- A PNG loading warning occurred for (null): Application built with libpng-1.4.7 but running with 1.6.37.
23:44:48.785 [texture.load.png.setup.failed]: ***** Error preparing to read /usr/share/oolite/Resources/Textures/oolite-particle-blur.png.

It looks like oolite uses its own dependencies from oolite-source-1.90/deps/Linux-deps/README.TXT for building

Having libpng14 installed doesn't help.

Daxot commented on 2020-11-01 21:35 (UTC)

Nope, still no fonts and textures

SanskritFritz commented on 2020-11-01 19:47 (UTC)

Hmm, could you try to install libpng12 and rebuild? If that solves the problem I'll include libpng12 into the dependencies array.

charlie5 commented on 2020-11-01 19:12 (UTC)

I've installed all font packages in the arch formal repos. Unfortunately the problem persists.

Daxot commented on 2020-11-01 19:00 (UTC)

Hello, i have the same problem with the latest version of the Oolite in AUR. No textures and no font. Logs attached.

SanskritFritz commented on 2020-11-01 11:39 (UTC)

Hmm, maybe a font is missing? Can you find out somehow?

charlie5 commented on 2020-11-01 09:30 (UTC)

Sorry for the delay.

I used pacaur to build from the latest PKGBUILD.

pkgver=1.90 pkgrel=2

depends=('espeak' 'gnustep-base' 'sdl_mixer' 'sdl_image' 'glu' 'nspr' 'openal')

makedepends=('gnustep-make' 'curl' 'zip' 'mesa' 'gcc-objc')

source=("oolite" "$pkgver/oolite-source-$pkgver.tar.bz2")

SanskritFritz commented on 2020-10-06 13:01 (UTC)

Did you build the 1.90-2 version with all the new dependencies?

charlie5 commented on 2020-10-06 12:58 (UTC)

After rebuild, same problem occurred.

SanskritFritz commented on 2020-10-06 07:04 (UTC)

There were some dependencies missing, try again please.

charlie5 commented on 2020-10-06 04:15 (UTC)

Hi. When I run oolite none of the buttons show any text.

SanskritFritz commented on 2020-09-24 07:50 (UTC) (edited on 2020-09-24 07:50 (UTC) by SanskritFritz)

Thanks! Help me to improve my packaging skills: how did you come upon that?

lightdot commented on 2020-09-24 01:10 (UTC) (edited on 2020-09-24 01:11 (UTC) by lightdot)

Package builds with the following packages added to makedepend: git, nspr, glu, openal, libpng.

stas-t commented on 2019-12-29 13:53 (UTC)

After some years I've built oolite again and the build was successful for me. However I've discovered that it depends on espeak (unmaintained by original author) instead of espeak-ng (active fork).

Here is a simple patch that makes oolite build against espeak-ng:

diff --git a/.SRCINFO b/.SRCINFO
index [`80402d0`]( 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -13,7 +13,7 @@ pkgbase = oolite
        depends = gnustep-gui
        depends = sdl_mixer
        depends = glu
-       depends = espeak
+       depends = espeak-ng
        depends = nspr
        depends = python2
        depends = icu
diff --git a/PKGBUILD b/PKGBUILD
index [`b4b4eef`]( 100644
@@ -9,7 +9,7 @@ pkgdesc="A space-sim based on the classic Elite"
-depends=('gnustep-gui' 'sdl_mixer' 'glu' 'espeak' 'nspr' 'python2' 'icu' 'gnustep-base' 'openal')
+depends=('gnustep-gui' 'sdl_mixer' 'glu' 'espeak-ng' 'nspr' 'python2' 'icu' 'gnustep-base' 'openal')
 makedepends=('gnustep-make' 'curl' 'zip' 'mesa' 'gcc-objc')
@@ -22,6 +22,7 @@ build() {
   unset CPPFLAGS
   #sed -i '/void png_error/d' src/Core/Materials/OOPNGTextureLoader.m
   sed -i "/ADDITIONAL_OBJCFLAGS/s/=/= -fobjc-exceptions/" GNUmakefile
+  sed -i "/ADDITIONAL_OBJC_LIBS/s/+= -lespeak/+= -lespeak-ng/" GNUmakefile
   source /usr/share/GNUstep/Makefiles/
   make -f Makefile release-deployment

SanskritFritz commented on 2019-05-19 19:59 (UTC) (edited on 2019-05-24 14:34 (UTC) by SanskritFritz) This package does not build at the moment. You can however use the binary package from

kcallis commented on 2019-05-18 19:49 (UTC)

@evorster I am suffering with the exact same error. I know that I have installed on another machine and had no issues.

evorster commented on 2019-05-12 08:05 (UTC)

I get the following error when trying to build OOlite:

-------------snip--------------- ./methodjit/MethodJIT.cpp:78:9: note: in expansion of macro ‘JS_STATIC_ASSERT’ JS_STATIC_ASSERT(offsetof(JSStackFrame, ncode_) == 0x28); ^~~~~~~~~~~~~~~~ ../methodjit/MethodJIT.cpp: At global scope: ../methodjit/MethodJIT.cpp:192:5: error: expected ‘(’ before ‘volatile’ asm volatile ( ^~~~~~~~ ( ../methodjit/MethodJIT.cpp:193:1: error: expected unqualified-id before string constant ".text\n" ^~~~~~~~~ ../methodjit/MethodJIT.cpp:192:15: error: expected ‘)’ before string constant asm volatile ( ~^ ) ".text\n" ~~~~~~~~~
../methodjit/MethodJIT.cpp:239:5: error: expected ‘(’ before ‘volatile’ asm volatile ( ^~~~~~~~ ( ../methodjit/MethodJIT.cpp:240:1: error: expected unqualified-id before string constant ".text\n" ^~~~~~~~~ ../methodjit/MethodJIT.cpp:239:15: error: expected ‘)’ before string constant asm volatile ( ~^ ) ".text\n" ~~~~~~~~~
../methodjit/MethodJIT.cpp:259:5: error: expected ‘(’ before ‘volatile’ asm volatile ( ^~~~~~~~ ( ../methodjit/MethodJIT.cpp:260:1: error: expected unqualified-id before string constant ".text\n" ^~~~~~~~~ ../methodjit/MethodJIT.cpp:259:15: error: expected ‘)’ before string constant asm volatile ( ~^ ) ".text\n" ~~~~~~~~~
../methodjit/MethodJIT.cpp:284:5: error: expected ‘(’ before ‘volatile’ asm volatile ( ^~~~~~~~ ( ../methodjit/MethodJIT.cpp:285:1: error: expected unqualified-id before string constant ".text\n" ^~~~~~~~~ ../methodjit/MethodJIT.cpp:284:15: error: expected ‘)’ before string constant asm volatile ( ~^ ) ".text\n" ~~~~~~~~~
In file included from ../jsval.h:48, from ../jspubtd.h:47, from ../jsprvtd.h:57, from ../jscntxt.h:55, from ../methodjit/MethodJIT.h:42, from ../methodjit/MethodJIT.cpp:39: ../jsutil.h: In instantiation of ‘void js::PodZero(T) [with T = js::analyze::Bytecode]’: ../jsanalyze.h:87:21: required from here ../jsutil.h:422:11: warning: ‘void memset(void*, int, size_t)’ clearing an object of non-trivial type ‘struct js::analyze::Bytecode’; use assignment or value-initialization instead [-Wclass-memaccess] memset(t, 0, sizeof(T)); ~~~~~~^~~~~~~~~~~~~~~~~ In file included from ../methodjit/Compiler.h:43, from ../methodjit/MethodJIT.cpp:44: ../jsanalyze.h:56:8: note: ‘struct js::analyze::Bytecode’ declared here struct Bytecode ^~~~~~~~ make[3]: [../config/ MethodJIT.o] Error 1 make[3]: Leaving directory '/data/OS/aur/yaourt-tmp-evert/aur-oolite/src/oolite-source-1.88/deps/mozilla/js/src/build-release' make[2]: [../config/ default] Error 2 make[2]: Leaving directory '/data/OS/aur/yaourt-tmp-evert/aur-oolite/src/oolite-source-1.88/deps/mozilla/js/src/build-release' make[1]: [libjs.make:45: deps/mozilla/js/src/build-release/build_stamp] Error 2 make[1]: Leaving directory '/data/OS/aur/yaourt-tmp-evert/aur-oolite/src/oolite-source-1.88' make: [Makefile:117: LIBJS] Error 2 ==> ERROR: A failure occurred in build().

SanskritFritz commented on 2018-12-17 08:43 (UTC)

I don't know what could be the problem, oolite builds fine here. Sorry.

Markus.N commented on 2018-12-16 21:22 (UTC)

Unfortunately, I can not build the package on my system: Error message: "checking for Python version >= 2.5 but not 3.x... configure: error: Python 2.5 or higher (but not Python 3.x) is required." I have python2 (2.7.15) and python3 (3.7.1) installed, and python3 seems to be the default. Patching "#!/usr/bin/env python" (and similar) to "#!/usr/bin/env python2" in all python files did not help.