Package Details: open-fpga-loader-git r391.4ed01ae-1

Git Clone URL: https://aur.archlinux.org/open-fpga-loader-git.git (read-only, click to copy)
Package Base: open-fpga-loader-git
Description: Universal utility for programming FPGA
Upstream URL: https://github.com/trabucayre/openFPGALoader
Licenses: custom
Conflicts: open-fpga-loader
Provides: open-fpga-loader
Submitter: japm48
Maintainer: japm48
Last Packager: japm48
Votes: 0
Popularity: 0.000000
First Submitted: 2020-02-16 10:47
Last Updated: 2021-01-18 01:48

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

xiretza commented on 2021-01-18 11:55

Works now, thanks for the quick fix!

japm48 commented on 2021-01-18 01:54

It should compile now (please confirm), I will report the underlying issue when I have time. I cannot test with real hardware right now.

Edit: it was already reported here: https://bugs.archlinux.org/task/69115

japm48 commented on 2021-01-18 01:30

@xiretza Looks like there's a bug in libftdi (possibly from upstream). I will try to add a temporary workaround.

xiretza commented on 2021-01-17 17:53

Compilation fails:

In file included from /build/open-fpga-loader-git/src/openFPGALoader/src/device.hpp:6,
                 from /build/open-fpga-loader-git/src/openFPGALoader/src/efinix.hpp:23,
                 from /build/open-fpga-loader-git/src/openFPGALoader/src/efinix.cpp:18:
/build/open-fpga-loader-git/src/openFPGALoader/src/jtag.hpp:20:10: fatal error: ftdi.h: No such file or directory
   20 | #include <ftdi.h>
      |          ^~~~~~~~
compilation terminated.