Package Details: opentracker 2021.05.09-1

Git Clone URL: (read-only, click to copy)
Package Base: opentracker
Description: A free and open torrent tracker
Upstream URL:
Licenses: beerware
Submitter: Strit
Maintainer: Strit
Last Packager: Strit
Votes: 8
Popularity: 0.000000
First Submitted: 2015-12-21 17:54 (UTC)
Last Updated: 2021-05-09 19:27 (UTC)

Latest Comments

1 2 3 Next › Last »

Breizh commented on 2023-07-12 14:31 (UTC)

I successfully built it with libowfat 0.33 (still not the one from the AUR).

When it fails the first time with this error:

==> Starting build()...
mkdir libowfat
rm -f iopause.h
if  gcc -pipe -W -Wall -Wextra  -D_REENTRANT -O2 -I. -o t trypoll.c >/dev/null 2>&1; then cp iopause.h2 iopause.h; else cp iopause.h1 iopause.h; fi
rm -f havealloca.h
echo "#include <stdlib.h>" > havealloca.h
rm -f haveuint128.h
if  gcc -pipe -W -Wall -Wextra  -D_REENTRANT -O2 -I. -c tryuint128.c >/dev/null 2>&1; then echo "#define HAVE_UINT128"; fi > haveuint128.h
gcc -c byte/byte_chr.c -pipe -W -Wall -Wextra  -D_REENTRANT -O3  -I.
if  gcc -pipe -W -Wall -Wextra  -D_REENTRANT -O2 -I. -c tryalloca.c -DA >/dev/null 2>&1; then echo "#include <alloca.h>"; fi >> havealloca.h
rm -f tryuint128.o
gcc -c byte/byte_copy.c -pipe -W -Wall -Wextra  -D_REENTRANT -O3  -I.
In file included from byte/byte_chr.c:1:
./byte.h:14:10: fatal error: libowfat/compiler.h: No such file or directory
   14 | #include <libowfat/compiler.h>
      |          ^~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make: *** [GNUmakefile:184: byte_chr.o] Error 1
make: *** Waiting for unfinished jobs....
if  gcc -pipe -W -Wall -Wextra  -D_REENTRANT -O2 -I. -c tryalloca.c -DB >/dev/null 2>&1; then echo "#include <malloc.h>"; fi >> havealloca.h
In file included from byte/byte_copy.c:2:
./byte.h:14:10: fatal error: libowfat/compiler.h: No such file or directory
   14 | #include <libowfat/compiler.h>
      |          ^~~~~~~~~~~~~~~~~~~~~
compilation terminated.
make: *** [GNUmakefile:184: byte_copy.o] Error 1
rm -f tryalloca.o
rm -f t
==> ERROR: A failure occurred in build().

I just keep the building dir, and retry, and now it works. But I don’t know exactly what to change to make it works at the first try.

The same method work for the -ipv6 version too.

moonman commented on 2022-06-10 06:21 (UTC) (edited on 2022-06-10 06:22 (UTC) by moonman)

It looks like libowfat is the cause of the error. If you download the PKGBUILD and replace the line ln -sf libowfat-$_libowfat libowfat with cvs -d -z9 co libowfat it will build. Apparantly libowfat cvs repository has this bug fixed, while the official release does not. Obviously cvs now becomes a makedepend.

Calimero commented on 2022-03-31 14:00 (UTC)

The build currently fails (in a clean chroot), with: /usr/include/sys/cdefs.h:307:60: error: macro "__has_attribute" requires an identifier

abouvier commented on 2021-12-22 01:07 (UTC)

This package should be named opentracker-git.

acerix commented on 2021-05-06 00:30 (UTC)

@Breizh I got the IPv6 version to build and added a package for it:

Breizh commented on 2021-03-09 19:59 (UTC) (edited on 2021-03-09 20:00 (UTC) by Breizh)

Can you offer an IPv6 version? opentracker support it, but it’s v4-only or v6-only during the compilation. Maybe creating a second package with separate config file and binary is the best option (to run each version side-by-side for a full-stack setup)?

I’m trying to do it from your current PKGBUILD, but without success at this time.


gman4455 commented on 2020-12-09 19:28 (UTC)

Can't figure out why, but the build fails for me the first time I run it after cloning. Here's the output:

Immediately after that, I can run makepkg again (without cleaning the src directory) and it successfully builds the package.

acerix commented on 2020-06-09 21:42 (UTC)

@steve1234 Thanks for the tip, really helped me out!

The "first_deferred" error seems to come from newer libowfat, that went away after switching to 0.31.

The "__you_tried_to_link_a_dietlibc_object_against_glibc" errors went away by uninstalling dietlibc then rebuilding libowfat without it.

steve1234 commented on 2020-06-09 03:04 (UTC)

I was able to get it to compile. I think I uninstalled dietlibc or got the package to not use this compiler. If you can't get it, I can look closer in the morning.