Package Details: pakku-git 1:0.14.r19.gf2a93be-1

Git Clone URL: https://aur.archlinux.org/pakku-git.git (read-only, click to copy)
Package Base: pakku-git
Description: Pacman wrapper with AUR support with latest changes from github repo
Upstream URL: https://github.com/zqqw/pakku
Keywords: aur aur-helper helper nim pacman pakku wrapper
Licenses: GPL3
Conflicts: pakku
Provides: pakku
Submitter: haawda
Maintainer: IOAOI (j-james)
Last Packager: haawda
Votes: 8
Popularity: 0.056811
First Submitted: 2018-04-07 22:05 (UTC)
Last Updated: 2020-09-26 16:04 (UTC)

Latest Comments

IOAOI commented on 2022-01-20 14:52 (UTC)

BTW, with the latest commit, -Sn and -Sz options work again to build binary repo packages from source and obtain binary package PKGBUILD's and related files. It's also possible to specify the version now. See updated pakku man page - and no, these changes were not the problem with asciidoc!

IOAOI commented on 2022-01-20 14:47 (UTC)

Sorry, it was due to the recent asciidoc update, a workaround was detailed on the issues. https://github.com/zqqw/pakku/issues/20 That workaround has been pushed to the Pakku repo now so it should build with both the current and previous versions of asciidoc.

j0hannes commented on 2022-01-20 07:50 (UTC)

The package currently won't build:

Man page: asciidoc --help manpage Syntax: asciidoc --help syntax make: *** [Makefile:98: doc/pakku.8.in] Error 1

IOAOI commented on 2021-11-03 01:55 (UTC) (edited on 2021-11-03 02:01 (UTC) by IOAOI)

// cd ${pkgname%-git} // + echo "make "${addargs[@]}" NIM_CACHE_DIR='../nimcache' PREFIX='/usr'" // make "${addargs[@]}" NIM_CACHE_DIR='../nimcache' PREFIX='/usr' //

PKGBUILD is a BASH script... :) This is an AUR helper - makepkg will always be available to build - using make directly is pointless anyhow!

abd commented on 2021-11-03 01:25 (UTC) (edited on 2021-11-03 01:25 (UTC) by abd)

" passes various arguments to make"
apologize, as still don't get it what those are
Would you please determine these to answer clearly but very briefly in github pakku make issue
https://github.com/kitsunyan/pakku/issues/61

So every single thing is complete and transparent

IOAOI commented on 2021-11-02 20:03 (UTC)

The PKGBUILD passes various arguments to make, the Makefile isn't autogenerated by GNU autotools, it's a custom written one, there's no configure script which usually handles that separately. Probably it's easier to use makepkg: https://github.com/zqqw/pakku/wiki/Building-and-modifying-pakku

abd commented on 2021-11-02 15:36 (UTC) (edited on 2021-11-02 16:11 (UTC) by abd)

So sorry IOAOI
Yours' works great
Error just meant if i type on $ prompt 'make' on pakku being cloned from github, all by my own
Any Idea why so greatly differ: directly fails and your Aur works

IOAOI commented on 2021-11-02 13:23 (UTC) (edited on 2021-11-02 13:38 (UTC) by IOAOI)

https://wiki.archlinux.org/title/Arch_User_Repository#Installing_and_upgrading_packages Have you checked here? You need build-devel installed for a start. Not sure how that part can fail as I think it's just 2 patches (zsh-git.patch and zsh.patch) being applied using 'patch' to the 'zsh' file also located in pakku/completion. Possibly starting a fresh build might help if there had been some failure in the past which led to the completion/zsh file being altered so the patches didn't apply? Or perhaps you are trying to modify the zsh completions?

abd commented on 2021-11-02 08:38 (UTC)

Any idea why it fails in:

$ make GEN: completion/zsh 2 out of 8 hunks FAILED make: *** [Makefile:94: completion/zsh] Error 1

Please help

Argenet commented on 2020-09-25 20:31 (UTC)

I was able to successfully build and install pakku-git on aarch64 today. Feel free to add it as a supported architecture.

(Looking at the 'pakku' (non-git) AUR package, it supports a whole bunch of architectures, I guess they all are supported by pakku-git as well).

haawda commented on 2020-07-20 08:01 (UTC)

Indeed! Great news!

IOAOI commented on 2020-07-19 15:05 (UTC)

Today's commit lets it build with the current Nim 1.2.4.

haawda commented on 2020-07-18 10:50 (UTC) (edited on 2020-07-18 10:51 (UTC) by haawda)

Currently nim 1.0.6 is needed to build this. The nim-legacy package in AUR provides this.

IOAOI commented on 2020-05-02 02:36 (UTC)

https://github.com/zqqw/pakku The lc_useVersion branch builds with the current Nim version, it adds the missing lc module and uses useVersion to emulate Nim 1.0.

pychuang commented on 2019-12-10 10:32 (UTC)

Thanks @haawda! Also, recently I reinstall pakku-git, and I found the current version of nim fails to compile pakku. I had to downgrade nim to 0.18.0 in order to compile the code. Just to let you know.

I have zero knowledge of nim, but it looks like to me the nim language changes a lot from v0.18 to the current version.

haawda commented on 2019-10-26 11:15 (UTC)

I switched to brunomiguels fork.

haawda commented on 2019-10-24 14:25 (UTC)

Yes, I saw that, too. I hope the fix will be merged into the main repo soon.

pychuang commented on 2019-10-24 12:36 (UTC) (edited on 2019-10-24 12:43 (UTC) by pychuang)

Thanks for fixing the bash completion issue this fast!

There's a pull request that claims to resolve the problem of bash completion. https://github.com/kitsunyan/pakku/pull/49

I haven't tested the PR. But if the PR works, maybe it's better than removing bash completion?

cbowman57 commented on 2018-11-06 11:49 (UTC) (edited on 2018-11-06 11:49 (UTC) by cbowman57)

Doesn't build with nim-0.19.0-1 (Currently in community-testing) Builds fine after downgrading nim to 0.18.0-1

Posted new issue to author's git

kitsunyan commented on 2018-04-08 00:46 (UTC)

Please, add asciidoc to makedepends. It's necessary for git builds.