Package Details: pamac-classic 7.3.0-2

Git Clone URL: https://aur.archlinux.org/pamac-classic.git (read-only, click to copy)
Package Base: pamac-classic
Description: A Gtk3 frontend for libalpm - classic version
Upstream URL: https://git.cromer.cl/cromer/pamac-classic
Keywords: aur gui installer pacman
Licenses: GPL3
Conflicts: pamac, pamac-aur
Provides: pamac, pamac-aur
Submitter: sudobash418
Maintainer: sudobash418
Last Packager: sudobash418
Votes: 16
Popularity: 0.000008
First Submitted: 2017-10-04 21:54 (UTC)
Last Updated: 2021-07-10 20:28 (UTC)

Pinned Comments

Cromer commented on 2022-07-12 00:28 (UTC)

Probably related to this: https://git.cromer.cl/cromer/pamac-classic/issues/12

AUR has been broken in pamac-classic for a while now due to changes on Arch Linux's side of things. If anyone can fix and do a pull request, I will merge it. But right now I don't have time to investigate myself and is at the bottom of my priority list.

Latest Comments

1 2 3 4 5 6 7 Next › Last »

Cromer commented on 2022-07-12 00:28 (UTC)

Probably related to this: https://git.cromer.cl/cromer/pamac-classic/issues/12

AUR has been broken in pamac-classic for a while now due to changes on Arch Linux's side of things. If anyone can fix and do a pull request, I will merge it. But right now I don't have time to investigate myself and is at the bottom of my priority list.

rado84 commented on 2022-07-12 00:18 (UTC)

Why it doesn't display packages from AUR whenever there are such packages waiting to be updated? For instance, earlier today it displayed linux and linux-headers as waiting to be updated. When I ran the update command in terminal (I do the updates manually through CLI), the terminal showed that two AUR packages were also waiting to be updated: audacious-gtk3 and audacious-plugins-gtk3.

I have enabled search and check for updates from AUR, as well as AUR support and yet it never shows which AUR packages need to be updated, it only shows packages from the official repo.

glitsj16 commented on 2022-03-23 10:44 (UTC)

@Bitts311 You should have a 'Preferences' item in the menu that opens when you click the icon in the title bar on the left with the current version. Settings are stored in dconf, not in a file. If you don't see that icon, try changing GTK theme.

Bitts311 commented on 2022-03-23 10:11 (UTC)

Hi, which version of the program has a settings menu? In the latest version 7.3.0 I have no settings at all (maybe it should be like this?). Or do I need to create a config of settings and put it somewhere?

rado84 commented on 2021-07-11 15:21 (UTC)

That worked! Thanks, sudobash418! :D

P.S. I've set checking for updates to happen every 3 hours, so I always have fully updated system. :)

sudobash418 commented on 2021-07-11 14:10 (UTC) (edited on 2021-07-11 14:11 (UTC) by sudobash418)

@rado84 That's because the new version requires pacman >= 6.0, but the old version requires pacman < 6.0

makepkg doesn't quite know how to handle this situation properly, so you'll have to follow this procedure:

  1. Update pacman from 5.x to 6.x, ignoring the fact that this breaks pamac-classic: pacman -Sd pacman
  2. Update pamac-classic to 7.3.0 with makepkg/<your preferred AUR helper other than pamac-classic>.

As with any major version bump of a package manager, I would advise a full system update (-Syu) afterwards and a reboot to verify everything is working correctly.

rado84 commented on 2021-07-11 10:58 (UTC)

Pamac-classic apears to have a new update: 7.3.0-2 but when I try to update it, I get this error:

[sudo] password for rado: :: pacman is in IgnorePkg / IgnoreGroup. To install? [Y / n] y solving dependencies ... search for conflicting packages ... error: failure to prepare the transaction (dependencies not resolved) :: installing pacman (6.0.0-3) breaks the 'pacman <6.0.0' dependency required by pamac-classic ==> ERROR: 'pacman' failed to install missing dependencies. ==> Missing dependencies: -> pacman> = 6.0.0 ==> Checking buildtime dependencies ... ==> ERROR: Not all dependencies can be solved. :: Unable to build pamac-classic - makepkg exited with code: 8 = >> Try again? [y / N]:

What is "makepkg code 8"?

sudobash418 commented on 2021-07-10 20:27 (UTC)

Yeah that is a good idea, thanks.

Cromer commented on 2021-07-10 20:25 (UTC)

You should add pacman < 7.0.0 to the depends. Next time pacman has a big update it would obviously break pamac again.

Cromer commented on 2021-07-10 17:35 (UTC)

@rado84, pamac and pamac-classic are not the same thing. Anything written about pamac does not apply to pamac-classic.

A new version should be coming soon which will fix pamac-classic with the new libalpm, just waiting on merging a pull request which adds a new feature that lets you store the packages built from the AUR in a directory of your choosing. Once that can be merged I will release the new version.