Package Details: pamac-classic 7.3.0-2

Git Clone URL: (read-only, click to copy)
Package Base: pamac-classic
Description: A Gtk3 frontend for libalpm - classic version
Upstream URL:
Keywords: aur gui installer pacman
Licenses: GPL3
Conflicts: pamac, pamac-aur
Provides: pamac, pamac-aur
Submitter: sudobash418
Maintainer: sudobash418
Last Packager: sudobash418
Votes: 17
Popularity: 0.014302
First Submitted: 2017-10-04 21:54
Last Updated: 2021-07-10 20:28

Latest Comments

1 2 3 4 5 6 ... Next › Last »

rado84 commented on 2021-07-11 15:21

That worked! Thanks, sudobash418! :D

P.S. I've set checking for updates to happen every 3 hours, so I always have fully updated system. :)

sudobash418 commented on 2021-07-11 14:10

@rado84 That's because the new version requires pacman >= 6.0, but the old version requires pacman < 6.0

makepkg doesn't quite know how to handle this situation properly, so you'll have to follow this procedure:

  1. Update pacman from 5.x to 6.x, ignoring the fact that this breaks pamac-classic: pacman -Sd pacman
  2. Update pamac-classic to 7.3.0 with makepkg/<your preferred AUR helper other than pamac-classic>.

As with any major version bump of a package manager, I would advise a full system update (-Syu) afterwards and a reboot to verify everything is working correctly.

rado84 commented on 2021-07-11 10:58

Pamac-classic apears to have a new update: 7.3.0-2 but when I try to update it, I get this error:

[sudo] password for rado: :: pacman is in IgnorePkg / IgnoreGroup. To install? [Y / n] y solving dependencies ... search for conflicting packages ... error: failure to prepare the transaction (dependencies not resolved) :: installing pacman (6.0.0-3) breaks the 'pacman <6.0.0' dependency required by pamac-classic ==> ERROR: 'pacman' failed to install missing dependencies. ==> Missing dependencies: -> pacman> = 6.0.0 ==> Checking buildtime dependencies ... ==> ERROR: Not all dependencies can be solved. :: Unable to build pamac-classic - makepkg exited with code: 8 = >> Try again? [y / N]:

What is "makepkg code 8"?

sudobash418 commented on 2021-07-10 20:27

Yeah that is a good idea, thanks.

Cromer commented on 2021-07-10 20:25

You should add pacman < 7.0.0 to the depends. Next time pacman has a big update it would obviously break pamac again.

Cromer commented on 2021-07-10 17:35

@rado84, pamac and pamac-classic are not the same thing. Anything written about pamac does not apply to pamac-classic.

A new version should be coming soon which will fix pamac-classic with the new libalpm, just waiting on merging a pull request which adds a new feature that lets you store the packages built from the AUR in a directory of your choosing. Once that can be merged I will release the new version.

rado84 commented on 2021-07-06 21:09

3 weeks ago Adrian Pereira said "pamac is now working on Arch" but he doesn't say if that means pamac can be compiled against pacman 6.0 (libalpm 13). Can anyone test it and see if it really works?

Vedun commented on 2021-06-07 11:22

cromer commented 2 days ago

"Libalpm has many breaking changes in the new version, especially now that paralel downloads are available. It requires a lot of modification to pamac, and at the moment I don't have time to do it.

If anyone wants to do it, pull requests are welcome and I would be happy to merge it."

sudobash418 commented on 2021-06-02 13:43

@rado84 If you're referring to the 7.2.1-1 to 7.2.1-2 pkgrel bump, then no - the only difference is that I added a restriction on the pacman version to the PKGBUILD.

As far as I am aware, upstream still needs to fix the incompatibility with pacman >= 6.0

edit: I've opened #9 upstream to report the issue.

rado84 commented on 2021-06-02 08:32

I can see pamac-classic has an update waiting. Has it been updated for compatibilty with libalpm 13 which caused a lot of problems yesterday when pacman 6 arrived?