Package Details: pantheon-code-git 3.4.1.r54.gf2286b1f-2

Git Clone URL: https://aur.archlinux.org/pantheon-code-git.git (read-only, click to copy)
Package Base: pantheon-code-git
Description: The Pantheon Code Editor
Upstream URL: https://github.com/elementary/code
Licenses: GPL3
Groups: pantheon-unstable
Conflicts: elementary-code, pantheon-code, scratch-text-editor
Provides: pantheon-code
Replaces: elementary-code, scratch-text-editor, scratch-text-editor-git
Submitter: ademayo
Maintainer: FabioLolix
Last Packager: FabioLolix
Votes: 15
Popularity: 0.27
First Submitted: 2018-01-18 23:01
Last Updated: 2020-08-18 16:50

Latest Comments

1 2 3 4 Next › Last »

FabioLolix commented on 2020-08-18 16:54

fixed now

SolarAquarion commented on 2020-08-18 16:27

gtksourceview4 is now a depend

flipflop97 commented on 2018-10-18 11:28

I checked and added multiple runtime dependencies including those you mentioned, those should be complete now afaik, but let me know if the're not.

lukemontalvo commented on 2018-10-18 04:07

After installing gobject-introspection it was able to continue since that's a make dependency for libpeas but wasn't being installed since I already have libpeas installed.

Additionally I had to install libgee, granite, gtksourceview3, libgit2-glib, and zeitgeist as normal dependencies instead of make dependencies in order to be able to run it.

flipflop97 commented on 2018-10-17 08:12

I extended the makedepends list. Not sure why libpeas isn't being detected for you, let me know if you think I can do anything about that in the PKGBUILD.

lukemontalvo commented on 2018-10-16 22:54

I had to manually install libgee, granite, and gtksourceview3 but even after that the build gets stuck on finding libpeas even though I have it installed.

brainblasted commented on 2018-05-17 22:15

Requires editorconfig-core-c

alucryd commented on 2015-01-16 11:21

Same here. I'll file a bug upstream when I find some time, unless you want to do it. BTW, please use an external pastebin service for error logs next time.

Xiaoming94 commented on 2015-01-15 16:18

Got this: /tmp/yaourt-tmp-xiaoming/aur-scratch-text-editor-bzr/src/scratch-text-editor/plugins/word-completion/engine.vala:38.27-38.31: warning: GLib.Mutex has been deprecated since glib-2.32. Use Mutex (with --target-glib=2.32)
/tmp/yaourt-tmp-xiaoming/aur-scratch-text-editor-bzr/src/scratch-text-editor/plugins/word-completion/completion-provider.vala:78.46-78.54: warning: Gtk.Stock has been deprecated since 3.10
/tmp/yaourt-tmp-xiaoming/aur-scratch-text-editor-bzr/src/scratch-text-editor/plugins/word-completion/completion-provider.vala:122.5-122.30: error: overriding method `Scratch.Plugins.CompletionProvider.get_start_iter' is incompatible with base method `Gtk.SourceCompletionProvider.get_start_iter': incompatible direction of parameter 3.
public bool get_start_iter (Gtk.SourceCompletionContext context,
^^^^^^^^^^^^^^^^^^^^^^^^^^
/tmp/yaourt-tmp-xiaoming/aur-scratch-text-editor-bzr/src/scratch-text-editor/plugins/word-completion/plugin.vala:110.13-110.37: warning: GLib.Thread.create has been deprecated since 2.32. Use new Thread<T> ()
Compilation failed: 1 error(s), 3 warning(s)
plugins/word-completion/CMakeFiles/word-completion.dir/build.make:55: recipe for target 'plugins/word-completion/plugin.c' failed
make[2]: *** [plugins/word-completion/plugin.c] Error 1
CMakeFiles/Makefile2:715: recipe for target 'plugins/word-completion/CMakeFiles/word-completion.dir/all' failed
make[1]: *** [plugins/word-completion/CMakeFiles/word-completion.dir/all] Error 2
Makefile:147: recipe for target 'all' failed
make: *** [all] Error 2

alucryd commented on 2013-05-09 11:46

Ner0: Thx, I've chmod +x the scripts. There's no need to add granite-bzr however, it is already implied by pantheon-files-bzr.