Package Details: pcb-git 20160425-1

Git Clone URL: (read-only)
Package Base: pcb-git
Description: Interactive printed circuit board editor
Upstream URL:
Licenses: GPL
Conflicts: pcb
Provides: pcb
Submitter: veox
Maintainer: veox
Last Packager: veox
Votes: 1
Popularity: 0.000000
First Submitted: 2016-03-10 16:36
Last Updated: 2016-04-25 14:28

Dependencies (14)

Required by (0)

Sources (2)

Latest Comments

veox commented on 2016-08-21 18:06

See upstream bug reporting:

northbear commented on 2016-08-21 17:22

veox, sorry. I miss your response. Now all things are going well...
I have some problem with pcb itself. I cannot configure project's layers at File -> Preferences -> Layers.
On tab "Change" i do not see list of layers to manage. Only arrows buttons (up/down) and a delete button are displayed. And button 'Add' is placed below.
Does anybody have any idea how to solve it? or where may i ask a question on this problem?

veox commented on 2016-04-25 14:36

Well, I disabled building docs for now, but please tell me if this is backward, I'll add `texlive-core` to `makedepends` instead.

northbear commented on 2016-04-23 00:21

Hi! In my case, building the package faults with message:

checking If your TeX installation contains epsf.tex... warning: kpathsea: configuration file texmf.cnf not found in these directories: /usr/bin:/usr/bin/share/texmf-local/web2c:/usr/bin/share/texmf-dist/web2c:/usr/bin/share/texmf/web2c:/usr/bin/texmf-local/web2c:/usr/bin/texmf-dist/web2c:/usr/bin/texmf/web2c:/usr:/usr/share/texmf-local/web2c:/usr/share/texmf-dist/web2c:/usr/share/texmf/web2c:/usr/texmf-local/web2c:/usr/texmf-dist/web2c:/usr/texmf/web2c://texmf-local/web2c:/://share/texmf-local/web2c://share/texmf-dist/web2c://share/texmf/web2c://texmf-local/web2c://texmf-dist/web2c://texmf/web2c.
configure: error: You have requested a build
of the documentation. For this to work, you must have a functional install of
TeX and LaTeX that includes epsf.tex. On some linux distributions this is
part of the texlive-generic-recommended package.
Alternatively, you can disable building the documentation with

So. It would be good idea to add "texlive-core" package to required dependency or to add the option --disable-doc by default.

Thanks in advance...

veox commented on 2016-03-10 16:46

I've taken the liberty to disable GL (it's only used for faux-3D rendering AFAIK). If you need it, please provide a tested patch.

If you prefer github: