Package Details: perl-plack 1.0051-1

Git Clone URL: https://aur.archlinux.org/perl-plack.git (read-only, click to copy)
Package Base: perl-plack
Description: Perl Superglue for Web frameworks and Web Servers
Upstream URL: https://metacpan.org/release/Plack
Licenses: GPL, PerlArtistic
Submitter: Athaba
Maintainer: None
Last Packager: jthvai
Votes: 13
Popularity: 0.000000
First Submitted: 2010-04-15 10:04 (UTC)
Last Updated: 2024-02-05 10:33 (UTC)

Sources (1)

Latest Comments

1 2 3 Next › Last »

nachfuellbar commented on 2023-01-08 20:12 (UTC)

Sry just saw these errors but i looked into my log file again and it's kinda curious - makepkg says

installing perl-www-form-urlencoded...
installing perl-http-entity-parser...

But there are these errors later on where it says it can't locate the modules - i'll look into my system again to see if i can locate the cause of this

micwoj92 commented on 2023-01-08 19:57 (UTC)

What are you using? when I build it using makepkg or makechrootpkg it also pulls normal dependencies alongside makedepends.

nachfuellbar commented on 2023-01-08 18:22 (UTC)

perl-http-entity-parser and perl-www-form-urlencoded should be listed in makedeps, too. got quite a lot of errors when using makepkg to build it - see following. this won't happen if you have the package and/or the dependencies already installed so it's quick to work around it - but it's better to really fix it.

Can't locate WWW/Form/UrlEncoded.pm in @INC (you may need to install the WWW::Form::UrlEncoded module) (@INC contains: /tmp/tmp.z7mUWMMouN/src/Plack-1.0050/blib/lib /tmp/tmp.z7mUWMMouN/src/Plack-1.0050/blib/arch /usr/lib/perl5/5.36/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.36/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.36/core_perl /usr/share/perl5/core_perl .) at /usr/share/perl5/vendor_perl/HTTP/Entity/Parser/UrlEncoded.pm line 5.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/HTTP/Entity/Parser/UrlEncoded.pm line 5.
Compilation failed in require at /usr/share/perl5/core_perl/Module/Load.pm line 78.
Can't locate HTTP/Entity/Parser/UrlEncoded in @INC (@INC contains: /tmp/tmp.z7mUWMMouN/src/Plack-1.0050/blib/lib /tmp/tmp.z7mUWMMouN/src/Plack-1.0050/blib/arch /usr/lib/perl5/5.36/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.36/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.36/core_perl /usr/share/perl5/core_perl .) at /usr/share/perl5/core_perl/Module/Load.pm line 78.
Compilation failed in require at /tmp/tmp.z7mUWMMouN/src/Plack-1.0050/blib/lib/Plack/Request.pm line 17.
BEGIN failed--compilation aborted at /tmp/tmp.z7mUWMMouN/src/Plack-1.0050/blib/lib/Plack/Request.pm line 17.
Compilation failed in require at /tmp/tmp.z7mUWMMouN/src/Plack-1.0050/blib/lib/Plack/Test/Suite.pm line 13.
BEGIN failed--compilation aborted at /tmp/tmp.z7mUWMMouN/src/Plack-1.0050/blib/lib/Plack/Test/Suite.pm line 13.
Compilation failed in require at t/Plack-Handler/apache1.t line 10.

MarsSeed commented on 2022-06-03 03:47 (UTC)

Needed checkdepends: perl-cgi-compile, perl-log-log4perl, perl-module-refresh, perl-cgi-emulate-psgi

Evidence: check() log.

sl1pkn07 commented on 2018-10-18 14:46 (UTC) (edited on 2018-10-18 14:50 (UTC) by sl1pkn07)

checkdepends() is ok @bunder

also:

t/Plack-Request/cookie.t ............................. 1/? 
#   Failed test at t/Plack-Request/cookie.t line 16.
#          got: '"spaced out"'
#     expected: 'spaced out'

#   Failed test at t/Plack-Request/cookie.t line 18.
#          got: '""internal quotes""'
#     expected: '"internal quotes"'

#   Failed test at t/Plack-Request/cookie.t line 19.
#          got: '""'
#     expected: ''
# Looks like you failed 3 tests of 13.
t/Plack-Request/cookie.t ............................. Dubious, test returned 3 (wstat 768, 0x300)

apetresc commented on 2018-10-13 16:21 (UTC)

The most recent update broke this build - it depends on perl-cookie-baker>=0.07, but that doesn't exist on the AUR yet.

Pauligrinder commented on 2015-12-21 08:58 (UTC) (edited on 2015-12-21 09:01 (UTC) by Pauligrinder)

Some dependencies are missing, I had to install them manually to make this package build (otherwise yaourt would've built and installed those automatically). error: target not found: perl-http-request-ascgi error: target not found: perl-fcgi-procmanager error: target not found: perl-http-server-simple-psgi error: target not found: perl-authen-simple-passwd error: target not found: perl-io-handle-util error: target not found: perl-log-dispatch-array error: target not found: perl-lwp-protocol-http10 error: target not found: perl-module-refresh error: target not found: perl-test-tcp>=2.00

bunder commented on 2015-02-14 20:11 (UTC)

sl1pkn07, these are not errors. Dependencies are optional. Do not want to require everything to be installed at build time. Can add then to optdepends. Reasonable?

sl1pkn07 commented on 2015-02-14 12:35 (UTC)

t/Plack-Middleware/cgibin.t .......................... skipped: Test requires module 'CGI::Emulate::PSGI' but it's not found t/Plack-Middleware/cgibin_exec.t ..................... skipped: Test requires module 'CGI::Emulate::PSGI' but it's not found t/Plack-Middleware/wrapcgi.t ......................... skipped: Test requires module 'CGI::Emulate::PSGI' but it's not found t/Plack-Middleware/wrapcgi_exec.t .................... skipped: Test requires module 'CGI::Emulate::PSGI' but it's not found needs 'perl-cgi-emulate-psgi' chackdepend and after install t/Plack-Middleware/cgibin.t .......................... skipped: Test requires module 'CGI::Compile' but it's not found t/Plack-Middleware/cgibin_exec.t ..................... skipped: Test requires module 'CGI::Compile' but it's not found t/Plack-Middleware/wrapcgi.t ......................... skipped: Test requires module 'CGI::Compile' but it's not found t/Plack-Middleware/wrapcgi_exec.t .................... skipped: Test requires module 'CGI::Compile' but it's not found missing 'perl-cgi-compile' (http://search.cpan.org/dist/CGI-Compile/lib/CGI/Compile.pm) greetings