Package Details: php56 5.6.33-1

Git Clone URL: (read-only)
Package Base: php56
Description: An HTML-embedded scripting language
Upstream URL:
Keywords: php
Licenses: PHP
Provides: php=5.6.33
Submitter: mickael9
Maintainer: mickael9 (foxxx0)
Last Packager: foxxx0
Votes: 45
Popularity: 0.050875
First Submitted: 2016-01-03 21:26
Last Updated: 2018-01-12 13:53

Required by (454)

Sources (8)

Pinned Comments

mickael9 commented on 2016-04-06 11:51

PLEASE READ : For those who are getting "unknown public key" errors, this is NOT caused by this package. It means GPG is not configured to fetch public keys automatically (which is normal by default)

Please read the instructions at

The easiest way to overcome this is to manually import the keys from a keyserver :
$ gpg --keyserver hkp:// --recv-keys C2BF0BC433CFC8B3 FE857D9A90D90EC1

mickael9 commented on 2016-01-14 01:53

foxxx and I have been working together and this package can now be installed along PHP 7 from the official repos.

Everything has been moved into separate directories :

Config : /etc/php56
Extensions : /usr/lib/php56/modules
Binaries : /usr/bin/php56, /usr/bin/php56-cgi, /usr/bin/phar56, etc.

If you were previously using this as a replacement for php7, you'll have to adjust the new configuration files in /etc/php56/ to reflect the current ones in /etc/php/.

Apache module (provided by php56-apache) also has a specific configuration and CAN NOT cohabit with php7_module. Use php-fpm, fcgi or cgi if you need both versions.

The apache module is installed as, so you should use the following lines your httpd.conf :

# Load php 5.6 module
LoadModule php5_module modules/

# Use it for .php extensions
Include conf/extra/php56_module.conf

Please let me know if you encounter any problem or have a suggestion.

Latest Comments

foxxx0 commented on 2018-01-17 09:18


To me it looks like php71 is causing this as it explicitly conflicts with "php". Due to the fact that the php56 packages have a provide="php" in order to be used as deps for packages that require "php", there is no way to fix this from within php56.

You can either rebuild the php71 packages yourself so that they do not conflict with "php" in order to install php71 and php56 alongside each other or simply wait until all your php 7 applications are compatible with php 7.2 and then leave out the php71 packages.

Please also note that php 5.6 support will end this year (31st December 2018) and there are no security updates after that. I strongly encourage everyone using php 5.6 to start looking for application updates or alternatives over the course of this year.

marlemion commented on 2018-01-17 09:08

I have nextcloud running alongside with web service in need of php56. Until recently, I managed this with two parallel php installations (plain php from pacman and php56 via AUR). Now, nextcloud needs php71, while the main version alrady went up to 7.2. Apparently, a php71 package was created to deal with this requirement. However, it breaks parallel installation with php56:

pacman -Suy :: Synchronizing package databases... core is up to date extra is up to date community is up to date multilib is up to date repo-ck is up to date :: Starting full system upgrade... resolving dependencies... looking for conflicting packages... warning: removing 'php' from target list because it conflicts with 'php71' warning: removing 'php-gd' from target list because it conflicts with 'php71-gd' :: php71 and php are in conflict. Remove php? [y/N] y :: php71 and php56 are in conflict (php). Remove php56? [y/N] y :: php71-gd and php-gd are in conflict. Remove php-gd? [y/N] y :: php71-gd and php56-gd are in conflict (php-gd). Remove php56-gd? [y/N] y error: failed to prepare transaction (could not satisfy dependencies) :: php56-apache: removing php56 breaks dependency 'php56' :: php56-cgi: removing php56 breaks dependency 'php56' :: php56-dblib: removing php56 breaks dependency 'php56' :: php56-embed: removing php56 breaks dependency 'php56' :: php56-enchant: removing php56 breaks dependency 'php56' :: php56-fpm: removing php56 breaks dependency 'php56' :: php56-imap: removing php56 breaks dependency 'php56' :: php56-intl: removing php56 breaks dependency 'php56' :: php56-ldap: removing php56 breaks dependency 'php56' :: php56-mcrypt: removing php56 breaks dependency 'php56' :: php56-mssql: removing php56 breaks dependency 'php56' :: php56-odbc: removing php56 breaks dependency 'php56' :: php56-pear: removing php56 breaks dependency 'php56' :: php56-pgsql: removing php56 breaks dependency 'php56' :: php56-phpdbg: removing php56 breaks dependency 'php56' :: php56-pspell: removing php56 breaks dependency 'php56' :: php56-snmp: removing php56 breaks dependency 'php56' :: php56-sqlite: removing php56 breaks dependency 'php56' :: php56-tidy: removing php56 breaks dependency 'php56' :: php56-xsl: removing php56 breaks dependency 'php56'

Additional info: package version(s) config and/or log files etc.

Maybe you are already aware of this. For now, this is a showstopper for me. I have to wait for nextcloud 13. Before release, I will not be able to update the system anymore... :/

foxxx0 commented on 2018-01-12 13:54

Updated to 5.6.33:

The PHP development team announces the immediate availability of PHP 5.6.33. This is a security release. Several security bugs were fixed in this release. All PHP 5.6 users are encouraged to upgrade to this version.

drankinatty commented on 2017-12-06 20:52

update to 5.32 (and Pierre finally making the pkgrel bump to -2 in php 7.2.0-2) allowed php 7.2 to install without php56-mcrypt removal conflict, httpd now runs again (and virtualbox drivers now build again after Linux 4.14 install -- with forced update to vbox 5.2.2, 5.1.30 modules do not build) 4.14 was not a smooth jump...

foxxx0 commented on 2017-12-06 14:46

@drankinatty: you do need to rebuild from time to time.

Update your system to the latest using: pacman -Syyu (including the kernel if you want)

And then rebuild the php56 package.

That should solve any issues you described.

drankinatty commented on 2017-12-06 14:19

Downgraded to 4.13, httpd still wouldn't start with 5.31, built 5.32 and all is good again. Thank you. Sorry for the noise.

drankinatty commented on 2017-12-06 13:44

Update to kernel 4.14 breaks php56. Apache will not start and the error is:

Dec 06 07:34:16 phoinix systemd[1]: Started Apache Web Server. Dec 06 07:34:16 phoinix httpd[17169]: httpd: Syntax error on line 180 of /etc/httpd/conf/httpd.conf: Cannot load modules/ into server: cannot open shared object file: No such file or directory Dec 06 07:34:16 phoinix systemd[1]: httpd.service: Main process exited, code=exited, status=1/FAILURE Dec 06 07:34:16 phoinix systemd[1]: httpd.service: Failed with result 'exit-code'.

(this was with 5.31 - hopefully 5.32 has a fix, otherwise, I'll mark out of date so we can address it)

Addow commented on 2017-12-04 14:02

@jc-aur: is already taken care of, check this commit:

update: fixed a few hours ago in php 7.2.0-2

jc-aur commented on 2017-12-04 13:46

@mickael9 the latest php update from the main repo enters in conflict with php-mcrypt version of php56, can you check it out please?

icebal commented on 2017-11-14 18:53

why is this pulling apache as a dependancy? that should be put as an opt with nginx and the rest of the web servers.
edit: i see its for making php5-apache. which shouldn't be made unless apache is installed.

All comments