Package Details: php70-gd 7.0.27-1

Git Clone URL: (read-only)
Package Base: php70
Description: gd module for PHP
Upstream URL:
Licenses: PHP
Provides: php70-gd=7.0.27
Submitter: betrixed
Maintainer: betrixed
Last Packager: betrixed
Votes: 8
Popularity: 2.037553
First Submitted: 2017-02-05 08:12
Last Updated: 2018-01-19 11:46

Latest Comments

lilmike commented on 2018-03-12 08:28

Hi all, I've just created a php71 package that doesn't conflict with php 7.2 (or any other php version to my knowledge). It's called php71-noconflict (and php71-[...]-noconflict). Let me know if you have any feedback. Hope people find it useful! -Michael.

wget commented on 2018-03-09 10:51

Package upgraded to 7.0.28:

elimpfor commented on 2018-02-06 15:17

This is broken without the patch by @wget.

wget commented on 2018-02-01 11:54

Hello everyone. Could someone merge this commit in this package? Otherwise, without this enchant 2 fix, php 7.0 cannot be built on Arch Linux. Thanks a lot :)

broiniac commented on 2018-01-18 11:14

@Varakh: php7.1 for some reason is available in Community repo for 9 days now: Unfortunately it is in conflict with regular (up-to-date) php (v7.2).

+1 though to your request - having nice, non conflicting 7.1 version would be nice.

I did tried to compile it by myself using same pkbuild as this package doing proper source and checksum changes, but I've failed. Epicly.

Varakh commented on 2018-01-09 09:11

@betrixed: Thanks for maintaining the package, very useful as PHP 7.2 breaks several old applications. Do you plan to provide a PHP 7.1 package aswell? This would be very nice. I already tried building it myself using old PKGBUILD files of the official repository, but I didn't get it running.

rio commented on 2017-12-25 06:56

I guess in all packages we should just have provides directives with ${pkgbase} replaced by ${_pkgbase} since no package should have dependencies on php70-foo anyway. Note that the current PKGBUILD already does this for php-cgi.

Raansu commented on 2017-12-23 08:34

Manually applying the fix mentioned by @teekay fixes the issue for me and Nextcloud installs without issue.

Raansu commented on 2017-12-23 07:30

Even though I have this package installed I get an error trying to install Nextcloud, something needs to be fixed.

[kumo@kumo ~]$ sudo pacman -S nextcloud
resolving dependencies...
warning: cannot resolve "php-gd<7.2", a dependency of "nextcloud"
:: The following package cannot be upgraded due to unresolvable dependencies:

teekay commented on 2017-12-11 13:22

I second @aexoxea's and @z3ntu's comments regarding provides for the split packages.

For example php70-gd with

provides=("${pkgbase}-gd=$pkgver" "${_pkgbase}-gd=$pkgver")

would make nextcloud-12.x happy (which requires php-gd<7.2)

All comments