Package Details: pjproject 2.8-1

Git Clone URL: https://aur.archlinux.org/pjproject.git (read-only)
Package Base: pjproject
Description: Open source SIP stack and media stack
Upstream URL: http://www.pjsip.org/
Licenses: GPL
Submitter: None
Maintainer: caleb
Last Packager: caleb
Votes: 28
Popularity: 0.968170
First Submitted: 2007-09-07 12:14
Last Updated: 2018-12-05 09:14

Latest Comments

« First ‹ Previous 1 2 3 4 Next › Last »

PaterSiul commented on 2016-10-30 18:14

If you replaced
"install -D -m755 pjsip-apps/bin/pjsua-*gnu ${pkgdir}/usr/bin/pjsua"
with
"install -D -m755 pjsip-apps/bin/pjsua-`${srcdir}/${pkgname}-${pkgver}/config.guess` ${pkgdir}/usr/bin/pjsua"
that line should work on i686/x86_64 as well as on arm systems.

In that case, you could add armv6h to arch.

das-ich commented on 2016-08-24 08:03

please add arch='armv7h' to PKGBUILD

FixedWing commented on 2016-05-20 21:02

I see that with version 2.5, PJSIP now supports Opus. Any possibility that this could be enabled bby default in PKGBUILD? Thanx.

tuxce commented on 2016-05-09 07:54

To build this on Rpi (armv7l, armv7h), replace this line :

install -D -m755 pjsip-apps/bin/pjsua-*gnu ${pkgdir}/usr/bin/pjsua

by adding * after 'gnu' :

install -D -m755 pjsip-apps/bin/pjsua-*gnu* ${pkgdir}/usr/bin/pjsua

BakaKuna commented on 2015-12-26 15:10

pjsip is now at 2.4.5. Any reason not to use this?

Crazyachmed commented on 2015-04-08 13:45

Build failes on armv6h (Raspi):
install: cannot stat ‘pjsip-apps/bin/pjsua-*gnu’: No such file or directory

xdevla commented on 2014-07-17 09:26

Added, thanks

tohojo commented on 2014-07-15 16:31

The package produced by this lacks IPv6 support. To add it, the following line can be added after the ./configure line in build():

echo "#define PJ_HAS_IPV6 1" >> "${srcdir}/${pkgname}-${pkgver}/pjlib/include/pj/config_site.h"

xdevla commented on 2014-03-20 06:50

Now compiling with the '--with-external-srtp' option

pezzonovante commented on 2014-03-20 05:22

This package conflicts with libsrtp package. The /usr/lib/libsrtp.so file creates the conflict.