Package Details: pkgbrowser 0.22-2

Git Clone URL: https://aur.archlinux.org/pkgbrowser.git (read-only, click to copy)
Package Base: pkgbrowser
Description: A utility for browsing pacman databases and the AUR
Upstream URL: https://bitbucket.org/kachelaqa/pkgbrowser
Licenses: GPL2
Submitter: kachelaqa
Maintainer: kachelaqa
Last Packager: kachelaqa
Votes: 272
Popularity: 0.196493
First Submitted: 2011-04-20 18:18
Last Updated: 2019-11-14 22:19

Latest Comments

« First ‹ Previous ... 3 4 5 6 7 8 9 10 11 12 Next › Last »

blackhole commented on 2014-05-29 15:18

I have 2 pure archlinux systems.
The problem is only on the one with lxqt-desktop from aur.

Both are up to date (today!)

kachelaqa commented on 2014-05-29 15:13

@blackhole
I can't reproduce this. Are you using older versions of Qt/PyQt? Or maybe one of the derivative arch-linux distros?

blackhole commented on 2014-05-29 14:19

The bug is always there.

I have to start like this:
bash -c "rm -r /home/user/.config/pkgbrowser; pkgbrowser"

kachelaqa commented on 2014-05-23 00:53

@Dasonk
Please read the existing comments - the workaround for this has already been provided.

Dasonk commented on 2014-05-23 00:40

When trying to run pkgbrowser I get the following:

Traceback (most recent call last):
File "/usr/lib/pkgbrowser/main.py", line 9, in <module>
sys.exit(app.run())
File "/usr/lib/pkgbrowser/pkgbrowser/app.py", line 114, in run
app.window().setup()
File "/usr/lib/pkgbrowser/pkgbrowser/app.py", line 59, in window
self._window = Window()
File "/usr/lib/pkgbrowser/pkgbrowser/window.py", line 229, in __init__
strings[:self.searchBox.maxCount()])
TypeError: QStringListModel.setStringList(list-of-str): argument 1 has unexpected type 'list'

moething commented on 2014-03-28 06:46

The packet needs to be rebuilt against the latest alpm bindings from updated Python packages.
The package maintainer should increase the build number.

If you get the error message "alpm not found" simply reinstall (rebuild) the package.

tazee commented on 2013-10-30 00:17

@kachelaqa
Thanks. That was it.

kachelaqa commented on 2013-10-29 16:48

@tazee
This is probably caused by an old/incompatible config file.
Remove $HOME/.config/pkgbrowser/pkgbrowser.conf, and try again.

tazee commented on 2013-10-29 05:02

Something seems to have caused this package to break. When I run it now from the CLI, I get

Traceback (most recent call last):
File "/usr/lib/pkgbrowser/main.py", line 9, in <module>
sys.exit(app.run())
File "/usr/lib/pkgbrowser/pkgbrowser/app.py", line 114, in run
app.window().setup()
File "/usr/lib/pkgbrowser/pkgbrowser/app.py", line 59, in window
self._window = Window()
File "/usr/lib/pkgbrowser/pkgbrowser/window.py", line 229, in __init__
strings[:self.searchBox.maxCount()])
TypeError: QStringListModel.setStringList(list-of-str): argument 1 has unexpected type 'list'

kachelaqa commented on 2013-09-03 16:22

@Anima_hellsing
Thanks. This is the third time I've had to redo this, so hopefully it's permanently fixed now. (NB: the View PKGBUILD link on AUR still shows the wrong md5sum at the moment, but the tarball is correct).