Package Details: pkgbrowser 0.22-2

Git Clone URL: https://aur.archlinux.org/pkgbrowser.git (read-only, click to copy)
Package Base: pkgbrowser
Description: A utility for browsing pacman databases and the AUR
Upstream URL: https://bitbucket.org/kachelaqa/pkgbrowser
Licenses: GPL2
Submitter: kachelaqa
Maintainer: kachelaqa
Last Packager: kachelaqa
Votes: 273
Popularity: 0.34
First Submitted: 2011-04-20 18:18
Last Updated: 2019-11-14 22:19

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

Anonymous comment on 2015-11-27 03:26

@kachelaqa : superb! many thanks!

kachelaqa commented on 2015-11-26 16:55

@dokie80
You need to install libxkbcommon-x11 (due to bug FS#40468, which has still not been properly fixed).

Anonymous comment on 2015-11-26 07:43

fail to launch app
error msg when launched via terminal:

This application failed to start because it could not find or load the Qt platform plugin "xcb".

Available platform plugins are: eglfs, linuxfb, minimal, minimalegl, offscreen, xcb.

Reinstalling the application may fix this problem.
Aborted (core dumped)

wchouser3 commented on 2015-10-02 10:13

Fixed!

martynjy commented on 2015-10-02 09:30

@kirek
Thanks. That did the trick.

martynjy commented on 2015-10-01 23:30

Thanks kirek. That did the trick.

kirek commented on 2015-10-01 23:09

Change the build(){...} function to this:

build() {
cd "$srcdir/$pkgname-$pkgver"
sed -i 's/{c,o}/c/g' Makefile
sed -i 's/, HTMLParseError//g' pkgbrowser/backend.py
sed -i 's/HTMLParseError, //g' pkgbrowser/backend.py
make PREFIX='/usr'
}

wchouser3 commented on 2015-10-01 22:56

won't build:
install -m 755 -d /home/wchouser3/Downloads/pkgbrowser/pkg/pkgbrowser/usr/bin /home/wchouser3/Downloads/pkgbrowser/pkg/pkgbrowser/usr/lib/pkgbrowser/pkgbrowser/{,ui/}__pycache__
install -m 755 -d /home/wchouser3/Downloads/pkgbrowser/pkg/pkgbrowser/usr/share/applications /home/wchouser3/Downloads/pkgbrowser/pkg/pkgbrowser/usr/share/icons/hicolor/48x48/apps
install -m 644 main.py /home/wchouser3/Downloads/pkgbrowser/pkg/pkgbrowser/usr/lib/pkgbrowser
install -m 644 pkgbrowser/*.{py,so} /home/wchouser3/Downloads/pkgbrowser/pkg/pkgbrowser/usr/lib/pkgbrowser/pkgbrowser
install -m 644 pkgbrowser/__pycache__/*.py{c,o} /home/wchouser3/Downloads/pkgbrowser/pkg/pkgbrowser/usr/lib/pkgbrowser/pkgbrowser/__pycache__
install: cannot stat ‘pkgbrowser/__pycache__/*.pyo’: No such file or directory
Makefile:50: recipe for target 'install' failed
make: *** [install] Error 1

martynjy commented on 2015-10-01 22:56

Won't start after major python upgrade today:

Traceback (most recent call last):
File "/usr/lib/pkgbrowser/main.py", line 9, in <module>
sys.exit(app.run())
File "/usr/lib/pkgbrowser/pkgbrowser/app.py", line 112, in run
app.window().setup()
File "/usr/lib/pkgbrowser/pkgbrowser/app.py", line 56, in window
from pkgbrowser.window import Window
File "/usr/lib/pkgbrowser/pkgbrowser/window.py", line 18, in <module>
from pkgbrowser.backend import (
File "/usr/lib/pkgbrowser/pkgbrowser/backend.py", line 6, in <module>
from html.parser import HTMLParser, HTMLParseError
ImportError: cannot import name 'HTMLParseError'

and won't build either:

install: cannot stat ‘pkgbrowser/__pycache__/*.pyo’: No such file or directory
Makefile:50: recipe for target 'install' failed
make: *** [install] Error 1
==> ERROR: A failure occurred in package().

python (3.4.3-3 -> 3.5.0-2)
python-pyqt5 (5.5-1 -> 5.5-2)
pyqt5-common (5.5-1 -> 5.5-2)

majo commented on 2015-07-26 10:33

@kachelaqa
OK. You are right. Rebuilding pkgbrowser solved this problem.
yaourt -G pkgbrowser && cd pkgbrowser && makepkg -sirc