Package Details: plasma5-applets-redshift-control-git r67.f3ea169-1

Git Clone URL: https://aur.archlinux.org/plasma5-applets-redshift-control-git.git (read-only)
Package Base: plasma5-applets-redshift-control-git
Description: Plasmoid for Plasma 5 for controlling redshift.
Upstream URL: https://github.com/kotelnik/plasma-applet-redshift-control
Licenses: GPL
Conflicts: plasma5-applets-redshift-control
Provides: plasma5-applets-redshift-control
Submitter: clearmartin
Maintainer: clearmartin
Last Packager: clearmartin
Votes: 77
Popularity: 1.328097
First Submitted: 2015-07-26 19:52
Last Updated: 2017-11-13 14:03

Latest Comments

spider-mario commented on 2016-11-12 20:02

FWIW, I’m fine with the pkgver updates when it’s a package that’s quick to build (and this one definitely qualifies). I wouldn’t do that with rust-git, for example.

Note: you could update your pkgver() function to simply use `git describe`, this program has the necessary tags for that.

(Well, `git describe | tr - .`.)

clearmartin commented on 2016-03-24 19:32

@argymeg: Thank You very much for this useful intel and link to the discussion. I'm quite relieved now that I'm not the only one with this approach.

argymeg commented on 2016-03-24 15:21

AFAIK there is no clear guideline on the issue. It was discussed a while ago on the wiki but there was no consensus; you can read the discussion where OP has contributed, too.
https://wiki.archlinux.org/index.php/Talk:VCS_package_guidelines#Guidelines_on_updating_version_numbers.

I wouldn't really worry too much about it if I were you. For what it's worth, I personally prefer your approach, but the AUR comments are hardly the place to debate this, again as long as there is no official policy.

clearmartin commented on 2016-03-23 22:02

Hello again! Sorry, but I was expecting more constructive discussion about my wrongdoings. From these comments I understand that *-git PKGBUILD's version shouldn't be bumped when revision and sources change. Yet guidelines (https://wiki.archlinux.org/index.php/VCS_package_guidelines) state: "If the resulting package is different after changing the dependencies, URL, sources, etc. increasing the pkgrel is mandatory. Touching the pkgver is not.". So should I increase pkgrel instead? Or do I understand this completely wrong? Anyways I'm kindly asking for some directions to wiki or hints that should be added to the guidelines. Thank you and sorry for my ignorance.

kyb commented on 2016-03-23 20:41

Fine! Thank you very much.

clearmartin commented on 2016-03-12 23:24

Hi! Thanks! Good to share this information. I thought it is the right way to do it. Is there a better way to present a new version of *-git package without this "annoying version bumping"? I've made a new tag as well.

I also know of some *-git packages which didn't bump their version so yaourt wasn't notified about the update and I needed to occasionally reinstall them to get the new code. That I found annoying actually :). But maybe that's the right way. Please tell me, of course I don't want to annoy anybody.

Scimmia commented on 2016-03-12 23:15

You know, the constant useless pkgver bumps are pretty annoying. I'm uninstalling.

ochurlaud commented on 2015-07-27 20:05

Nice to find this back!