Package Details: platformio-git v5.0.1.r9.ga384411a-1

Git Clone URL: https://aur.archlinux.org/platformio-git.git (read-only, click to copy)
Package Base: platformio-git
Description: A cross-platform code builder and library manager
Upstream URL: http://platformio.org/
Keywords: arduino platformio
Licenses: GPL
Provides: platformio
Submitter: will.price94
Maintainer: sgar
Last Packager: sgar
Votes: 12
Popularity: 0.000000
First Submitted: 2014-09-13 22:16 (UTC)
Last Updated: 2020-09-19 08:36 (UTC)

Latest Comments

sarpik commented on 2019-12-06 17:20 (UTC)

I cannot install this:

$ yay -S platformio-git
==> Error: Could not find all required packages:
    python-semantic-version>=2.8.1 (Wanted by: platformio-git)

any updates anytime soon? Thanks

theaifam5 commented on 2019-11-23 16:43 (UTC) (edited on 2019-11-25 00:15 (UTC) by theaifam5)

@sl1pkn07 the issue with python-marshmallow with the platformio>=4.0.2 is, that the new version 4.1.0 requires marshmallow<3,>=2.20.5, which with ArchLinux does not work, because python-marshmallow got updated to >3.0.0 version. I made an issue about that case here https://github.com/platformio/platformio-core/issues/3283

Edit: Please look at https://aur.archlinux.org/packages/platformio/#comment-717511 for a workaround.

sl1pkn07 commented on 2019-10-20 16:44 (UTC) (edited on 2019-10-20 16:46 (UTC) by sl1pkn07)

please add python-marshmallow to dependencies, but need update it to version 2.20.5

sl1pkn07 commented on 2019-09-30 14:44 (UTC)

Hi. is possible add in the package the udev rules from PIO?

https://docs.platformio.org/en/latest/faq.html#platformio-udev-rules

greetings

sl1pkn07 commented on 2019-08-21 18:08 (UTC)

please add python-tabulate

> Executing task: platformio run --target clean --environment LPC1768 <

Traceback (most recent call last):
  File "/usr/bin/platformio", line 6, in <module>
    from pkg_resources import load_entry_point
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3250, in <module>
    @_call_aside
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3234, in _call_aside
    f(*args, **kwargs)
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 3263, in _initialize_master_working_set
    working_set = WorkingSet._build_master()
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 583, in _build_master
    ws.require(__requires__)
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 900, in require
    needed = self.resolve(parse_requirements(requirements))
  File "/usr/lib/python3.7/site-packages/pkg_resources/__init__.py", line 786, in resolve
    raise DistributionNotFound(req, requirers)
pkg_resources.DistributionNotFound: The 'tabulate>=0.8.3' distribution was not found and is required by platformio
The terminal process terminated with exit code: 1

req for pio 4.0.1-rc2

Jake commented on 2019-07-14 10:50 (UTC)

python-arrow is not required anymore since 3.5.1: https://github.com/platformio/platformio-core/blob/develop/HISTORY.rst#351-2018-01-18

sgar commented on 2019-02-02 16:39 (UTC)

hi, would be possible to update this package to compile with python 3 instead of python 2... upstream already added initial support for python 3..

pheki commented on 2018-04-14 16:33 (UTC)

Hello, It seems that python2-backports.functools_lru_cache is now a runtime dependency.

killermoehre commented on 2017-08-08 11:43 (UTC)

Hi, seems like python2-arrow is needed as runtime dependency $ platformio init --ide emacs --board nanoatmega328 Traceback (most recent call last): File "/usr/bin/platformio", line 6, in <module> from pkg_resources import load_entry_point File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3049, in <module> @_call_aside File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3033, in _call_aside f(*args, **kwargs) File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 3062, in _initialize_master_working_set working_set = WorkingSet._build_master() File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 658, in _build_master ws.require(__requires__) File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 972, in require needed = self.resolve(parse_requirements(requirements)) File "/usr/lib/python2.7/site-packages/pkg_resources/__init__.py", line 858, in resolve raise DistributionNotFound(req, requirers) pkg_resources.DistributionNotFound: The 'arrow<1' distribution was not found and is required by platformio

will.price94 commented on 2016-09-04 10:39 (UTC)

Hi Alex, I've taken over maintainer-ship of the python2-semantic-version package and have now updated it, and added it to the dependencies of this package. Thanks :)

will.price94 commented on 2016-09-04 10:20 (UTC)

Hi Alex, Thanks for the tip although python2-semantic-version is at 2.4.1 so doesn't solve this problem. I'll see what I can do and try and get a fix out later today.

alex4o commented on 2016-09-04 08:41 (UTC)

Add "python2-semantic-version" as dependency pkg_resources.DistributionNotFound: The 'semantic_version>=2.5.0' distribution was not found and is required by platformio

will.price94 commented on 2016-01-09 21:38 (UTC)

Updated.

will.price94 commented on 2016-01-09 21:33 (UTC)

@bricewge, many thanks for your contribution, I will update the package now.

bricewge commented on 2016-01-09 18:02 (UTC)

The package is missing several dependencies and not usable. Here is an updated and working PKGBUILD: https://gist.github.com/bricewge/9be843a9a902dcccf5cd

unhr commented on 2015-04-18 15:18 (UTC)

python2-pyserial should be listed as a dependency.

lz3060 commented on 2015-03-27 13:35 (UTC)

Please add python2-requests as dependency. Thanks!