Package Details: python-glyphslib 5.1.8-1

Git Clone URL: https://aur.archlinux.org/python-glyphslib.git (read-only, click to copy)
Package Base: python-glyphslib
Description: A bridge from Glyphs source files (.glyphs) to UFOs
Upstream URL: https://github.com/googlefonts/glyphsLib
Licenses: Apache
Submitter: thrasibule
Maintainer: thrasibule
Last Packager: thrasibule
Votes: 1
Popularity: 0.92
First Submitted: 2019-08-12 17:18
Last Updated: 2020-03-28 01:41

Latest Comments

caleb commented on 2020-03-27 11:48

Attached is a patch to apply with git am:

From 1518df71f392b8cae002bd4329431473927a81ad Mon Sep 17 00:00:00 2001
From: Caleb Maclennan <caleb@alerque.com>
Date: Fri, 27 Mar 2020 14:42:48 +0300
Subject: [PATCH] Relax unicodedata version dependency, split build() from
 package()

Signed-off-by: Caleb Maclennan <caleb@alerque.com>
---
 .SRCINFO |  4 ++--
 PKGBUILD | 33 ++++++++++++++++++++-------------
 2 files changed, 22 insertions(+), 15 deletions(-)

diff --git a/.SRCINFO b/.SRCINFO
index b6a62d3..9ed72e2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,13 +1,13 @@
 pkgbase = python-glyphslib
    pkgdesc = A bridge from Glyphs source files (.glyphs) to UFOs
    pkgver = 5.0.1
-   pkgrel = 1
+   pkgrel = 2
    url = https://github.com/googlefonts/glyphsLib
    arch = any
    license = Apache
    checkdepends = python-pytest
    checkdepends = python-ufonormalizer
-   checkdepends = python-unicodedata2=12.0.0
+   checkdepends = python-unicodedata2>=12.0.0
    checkdepends = python-xmldiff
    makedepends = python-setuptools
    depends = python
diff --git a/PKGBUILD b/PKGBUILD
index 3d61627..508bbe5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,32 @@
 # Maintainer: Guillaume Horel <guillaume.horel@gmail.com>
-pkgname=('python-glyphslib')
+# Contributor: Caleb Maclennan <caleb@alerque.com>
+
+pkgname=python-glyphslib
 _pkgname='glyphsLib'
-pkgver='5.0.1'
-pkgrel=1
+pkgver=5.0.1
+pkgrel=2
 pkgdesc="A bridge from Glyphs source files (.glyphs) to UFOs"
-url="https://github.com/googlefonts/glyphsLib"
-checkdepends=('python-pytest' 'python-ufonormalizer' 'python-unicodedata2=12.0.0' 'python-xmldiff')
+url="https://github.com/googlefonts/$_pkgname"
+arch=('any')
+checkdepends=('python-pytest' 'python-ufonormalizer' 'python-unicodedata2>=12.0.0' 'python-xmldiff')
+license=('Apache')
 depends=('python' 'python-defcon' 'python-fonttools')
 makedepends=('python-setuptools')
 optdepends=('python-ufonormalizer')
-license=('Apache')
-arch=('any')
-source=("https://pypi.org/packages/source/${_pkgname:0:1}/$_pkgname/$_pkgname-$pkgver.zip")
+source=("https://pypi.org/packages/source/${_pkgname::1}/$_pkgname/$_pkgname-$pkgver.zip")
 sha256sums=('424402e3e4405f5aa6f1b88699f12f636cad9225ddcfd05624cf4f55aaa62cd6')

-#check() {
-    #cd "$srcdir/$_pkgname-$pkgver"
+build() {
+    cd "$_pkgname-$pkgver"
+    python setup.py build
+}
+
+check() {
+    cd "$_pkgname-$pkgver"
     #python setup.py test
-#}
+}

 package() {
-    cd "${srcdir}/${_pkgname}-${pkgver}"
-    python setup.py install --root="${pkgdir}" --optimize=1
+    cd "$_pkgname-$pkgver"
+    python setup.py install --root="$pkgdir" --optimize=1 --skip-build
 }
-- 
2.26.0

caleb commented on 2020-03-27 11:07

I can't build python-fontmake right now because this package has requires python-unicode=12.0.0 and I have v13. Can you please relax that check to be greater-or-equal-to? It's probably too aggressive this way.