Package Details: python39 3.9.16-2

Git Clone URL: https://aur.archlinux.org/python39.git (read-only, click to copy)
Package Base: python39
Description: Major release 3.9 of the Python high-level programming language
Upstream URL: https://www.python.org/
Licenses: custom
Provides: python
Submitter: rixx
Maintainer: rixx
Last Packager: rixx
Votes: 17
Popularity: 0.49
First Submitted: 2021-12-13 11:56 (UTC)
Last Updated: 2022-12-07 01:43 (UTC)

Required by (11688)

Sources (2)

Latest Comments

1 2 Next › Last »

rixx commented on 2022-11-17 17:14 (UTC)

Done.

wint3rmute commented on 2022-11-17 16:51 (UTC)

After the recent update of the openssl package, ssl module in python3.9 stopped working and it's no longer possible to install libraries from pip due to the following error:

pip is configured with locations that require TLS/SSL, however the ssl module in Python is not available.

Reinstalling this AUR package has solved the problem for me. @rixx, please consider incrementing the pkgrel or epoch to force a rebuild for all users.

gchamon commented on 2022-08-02 19:16 (UTC)

cloning the AUR repo, removing --without-ensurepip and installing with makepkg -si worked fine to bring pip and setuptools back to python3.9 (without which I was unable to develop for AWS Lambda -- which supports python<=3.9 -- using pipenv and private packages).

I couldn't reproduce the conflict with system pip. Isn't make altinstall to take care of that? That is strange. In any case if there were steps to reproduce the conflict I could try taking a look at the installation process.

rixx commented on 2022-03-17 13:10 (UTC) (edited on 2022-03-17 13:12 (UTC) by rixx)

I don't see what's the problem

@lahwaacz I thought I had put that in my comment, but apparently not? Updates do not apply, complaining that /usr/bin/pip or /bin/pip exists in the filesystem (I swear I had intended to put that in my comment, sorry). Shipping a PKGBUILD that doesn't allow people to update isn't great, so I reverted the change for now.

you could just add something like rm -f "${pkgdir}/usr/bin/pip"

As I said: I do not have the time right now, so I chose to revert the change that breaks the package for people. Either I get around to tinkering with the PKGBUILD when I'm not working insane hours, or somebody sends in a patch.

lahwaacz commented on 2022-03-17 07:04 (UTC) (edited on 2022-03-17 07:07 (UTC) by lahwaacz)

@rixx I don't see what's the problem, the package contained only these files in /usr/bin (on version 3.9.11-2, i.e. before the last change):

$ pacman -Ql python39 | grep usr/bin
python39 /usr/bin/
python39 /usr/bin/2to3-3.9
python39 /usr/bin/idle3.9
python39 /usr/bin/pip3.9
python39 /usr/bin/pydoc3.9
python39 /usr/bin/python3.9
python39 /usr/bin/python3.9-config

So there is no conflict between python39 and python-pip. In any case, you could just add something like rm -f "${pkgdir}/usr/bin/pip" to the package() function, it's already done for some files in /usr/lib...

rixx commented on 2022-03-16 23:54 (UTC)

It turns out that --without-ensurepip is required for updates to apply cleanly. I've reintroduced the option so that people can get the latest update.

I don't have the time to figure out how to tell Python (or the pkgbuild) to only introduce a versioned pip executable, not the general one (which is what makes updates fail: /usr/bin/pip already exists). Anybody who has five minutes to fix this, feel free to send me a patch via mail or a PR.

rixx commented on 2022-03-11 22:38 (UTC)

Done, hope this doesn't break the build for other systems.

CyberShadow commented on 2022-03-11 21:03 (UTC)

Seeing the same issue as lahwaacz, would you mind adding the fix to the package please?

lahwaacz commented on 2022-03-02 21:57 (UTC)

I'm getting

configure: error:

Unknown float word ordering. You need to manually preset
ax_cv_c_float_words_bigendian=no (or yes) according to your system.

I've solved it by adding export ax_cv_c_float_words_bigendian=no before the configure command.