Package Details: qaac-wine 2.71-2

Git Clone URL: https://aur.archlinux.org/qaac-wine.git (read-only, click to copy)
Package Base: qaac-wine
Description: QuickTime AAC/ALAC encoder (wine version)
Upstream URL: https://sites.google.com/site/qaacpage/
Licenses: custom
Submitter: swordfeng
Maintainer: swordfeng
Last Packager: swordfeng
Votes: 2
Popularity: 0.014407
First Submitted: 2019-09-09 00:57
Last Updated: 2021-04-12 22:15

Latest Comments

swordfeng commented on 2021-04-12 22:20

@Inlifeuser Thanks for reporting. I fixed PKGBUILD but did not bump the version as the build is the same.

Inlifeuser commented on 2021-04-12 11:47

Build is failing on non-English (in my case ru_RU.UTF-8) locale:

==> Запускается package()...
install: не удалось выполнить stat для 'ASL.dll': Нет такого файла или каталога
==> ОШИБКА: Произошел сбой в package().
    Прерывание...
ошибка сборки: qaac-wine

The error translates as: install: failed stat for 'ASL.dll': No such file or directory

The problem was solved by entering command export LANG=C before building

NSQY commented on 2021-04-07 01:32

Build is failing under wine-6.5

00fc:fixme:file:NtLockFile I/O completion on lock not implemented yet
00fc:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
0120:fixme:wbemprox:client_security_SetBlanket 0000000062CA2D60, 000000000098ED00, 10, 0, (null), 3, 3, 0000000000000000, 0x00000000
0120:fixme:wbemprox:client_security_Release 0000000062CA2D60
0120:fixme:ntdll:NtQuerySystemInformation info_class SYSTEM_PERFORMANCE_INFORMATION
00fc:err:msi:ITERATE_Actions Execution halted, action L"LaunchConditions" returned 1603
==> ERROR: A failure occurred in build().
    Aborting...
error making: qaac-wine

Inlifeuser commented on 2020-10-12 08:55

Build and installation is successful. But when build the package useless iTunes.lnk file appears in the Desktop dir, also qaac command gives me the following:

/usr/bin/qaac: line 3: /usr/lib/qaac/qaac64.exe: cannot execute binary file: Exec format error

Problem for qaac command was solved for me by modifying wrapper.sh, changing line 3 from

"/usr/lib/qaac/${program}64.exe" "$@"
to
/usr/bin/wine "/usr/lib/qaac/${program}64.exe" "$@"

Also upstream released update 2.71

swordfeng commented on 2020-10-10 18:51

@Inlifeuser @aphirst Should be fixed now. Could you test it again? Thanks.

aphirst commented on 2020-10-08 10:22

I'm getting the same build failure as Inlifeuser.

Inlifeuser commented on 2020-10-05 09:37


:: (1/1) Parsing SRCINFO: qaac-wine
==> Making package: qaac-wine 2.70-1 (Mon Oct  5 12:27:50 2020)
==> Retrieving sources...
  -> Found qaac_2.70.zip
  -> Found iTunes64Setup.exe
  -> Found COPYING
  -> Found iTunesWindows.pdf
  -> Found wrapper.sh
==> Validating source files with sha256sums...
    qaac_2.70.zip ... Passed
    iTunes64Setup.exe ... Skipped
    COPYING ... Skipped
    iTunesWindows.pdf ... Skipped
    wrapper.sh ... Passed
==> Making package: qaac-wine 2.70-1 (Mon Oct  5 12:27:51 2020)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found qaac_2.70.zip
  -> Found iTunes64Setup.exe
  -> Found COPYING
  -> Found iTunesWindows.pdf
  -> Found wrapper.sh
==> Validating source files with sha256sums...
    qaac_2.70.zip ... Passed
    iTunes64Setup.exe ... Skipped
    COPYING ... Skipped
    iTunesWindows.pdf ... Skipped
    wrapper.sh ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting qaac_2.70.zip with bsdtar
  -> Extracting iTunes64Setup.exe with bsdtar
==> Sources are ready.
==> Making package: qaac-wine 2.70-1 (Mon Oct  5 12:27:55 2020)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Removing existing $pkgdir/ directory...
==> Starting build()...
==> ERROR: A failure occurred in build().
    Aborting...
error making: qaac-wine

SonicoXD commented on 2020-09-16 20:56

The latest iTunes64Setup doesn't seem to include AppleApplicationSupport64 anymore, so the package no longer builds. Using version 12.9.5.7 seems to work fine.

swordfeng commented on 2019-10-01 07:11

@SonicoXD Thank you for reporting the issue. It should be fixed now.

SonicoXD commented on 2019-10-01 01:43

Thanks for the package! However I can't use it. When trying to encode something, it shows "ERROR: CoreAudioToolbox.dll: Module not found."