Package Details: qadwaitadecorations-qt6-git 0.1.3.r0.g795bd8d-1

Git Clone URL: (read-only, click to copy)
Package Base: qadwaitadecorations-git
Description: Qt6 decoration plugin implementing Adwaita-like client-side decorations
Upstream URL:
Licenses: LGPL2.1
Conflicts: qadwaitadecorations-qt6, qgnomeplatform-qt6
Provides: qadwaitadecorations-qt6
Submitter: taoky
Maintainer: taoky
Last Packager: taoky
Votes: 2
Popularity: 0.37
First Submitted: 2023-08-27 06:23 (UTC)
Last Updated: 2023-10-27 15:59 (UTC)

Latest Comments

1 2 Next › Last »

xiota commented on 2023-10-27 16:07 (UTC) (edited on 2023-10-27 16:09 (UTC) by xiota)

it's still required for AUR users to install both qt5 and qt6 deps when building

That's normal. There are workarounds, but they make the PKGBUILD complicated, they don't work well with AUR helpers, and users have difficulty using them.

Also, you should test that your packages build in a clean chroot.

taoky commented on 2023-10-27 16:00 (UTC)

@yochananmarqos: Thank you for your explanation. I've fixed the PKGBUILD (though it's still required for AUR users to install both qt5 and qt6 deps when building).

yochananmarqos commented on 2023-10-27 14:16 (UTC) (edited on 2023-10-27 14:16 (UTC) by yochananmarqos)

@taoky: That's not what @xiota meant. Each package has they're own runtime dependencies. All you had to do was move the packages from the primary depends() array to makedepends() and leave the package depends() arrays alone.

diff --git a/PKGBUILD b/PKGBUILD
index 37555bb..808155a 100644
@@ -16,8 +16,7 @@ pkgdesc='Qt decoration plugin implementing Adwaita-like client-side decorations'
-makedepends=(cmake git)
-depends=(qt5-svg qt5-wayland qt6-svg qt6-wayland)
+makedepends=(cmake git qt5-svg qt5-wayland qt6-svg qt6-wayland)

@@ -40,6 +39,7 @@ build() {

 package_qadwaitadecorations-qt5-git() {
   pkgdesc='Qt5 decoration plugin implementing Adwaita-like client-side decorations'
+  depends=(qt5-svg qt5-wayland)
   conflicts=(qadwaitadecorations-qt5 qgnomeplatform-qt5)

@@ -48,6 +48,7 @@ package_qadwaitadecorations-qt5-git() {

 package_qadwaitadecorations-qt6-git() {
   pkgdesc='Qt6 decoration plugin implementing Adwaita-like client-side decorations'
+  depends=(qt6-svg qt6-wayland)
   conflicts=(qadwaitadecorations-qt6 qgnomeplatform-qt6)

taoky commented on 2023-10-27 08:35 (UTC)

@xiota: "Dependencies defined inside the package() function are only required to run the software." (

And that's bad, as I have to put qt5 deps in qt6 package, and vice versa. Though anyway I'll fix in this way until there's a better approach.

xiota commented on 2023-10-26 20:50 (UTC)

Clean chroot. All depends from inside package() need to also be in makedepends.

CMake Error at CMakeLists.txt:28 (find_package):
  Could not find a package configuration file provided by "QT" with any of
  the following names:


  Add the installation prefix of "QT" to CMAKE_PREFIX_PATH or set "QT_DIR" to
  a directory containing one of the above files.  If "QT" provides a separate
  development package or SDK, be sure it has been installed.

taoky commented on 2023-10-25 08:14 (UTC)

@yochananmarqos: OK, I'll just put qgnomeplatform-qt[56] in conflicts. And would you like to be included as contributor in this PKGBUILD file?

yochananmarqos commented on 2023-10-24 22:12 (UTC)

@taoky: Oh, you're right. It avoids a conflict with QGtkStyle from Qt upstream, not QAdwaitaDecorations. See PR 150

taoky commented on 2023-10-24 22:08 (UTC)

@yochananmarqos: As far as I could tell the release notes of 0.9.2 only suggests users to use QAdwaitaDecorations instead of QGnomePlatform, and it does not mention the compatibilities between them.

The changes saying "Do not use "gtk3" keyword to load QGnomePlatform plugin to avoid conflicts with QGtkStyle" seems not related to QAdwaitaDecorations.

yochananmarqos commented on 2023-10-24 22:02 (UTC)

@taoky: Because it only conflicts with versions older than 0.9.2. See the release notes.

taoky commented on 2023-10-24 21:57 (UTC)

@yochananmarqos I'll fix this. However, I'm confused about "qgnomeplatform-qt5<0.9.2": why not include 0.9.2 (the last released version of qgnomeplatform) here?