Package Details: qt-virt-manager 0.72.99-4

Git Clone URL: https://aur.archlinux.org/qt-virt-manager.git (read-only, click to copy)
Package Base: qt-virt-manager
Description: Qt5 Virtual Machine Manager provides a graphical tool for administering virtual machines for QEMU/KVM, Xen, and LXC and other Virtual Entities. Uses libvirt as the backend management API.
Upstream URL: https://github.com/F1ash/qt-virt-manager
Licenses: GPL2
Conflicts: virt-manager-qt5
Replaces: virt-manager-qt5
Submitter: ImNtReal
Maintainer: ImNtReal
Last Packager: ImNtReal
Votes: 31
Popularity: 0.035253
First Submitted: 2018-01-22 20:40 (UTC)
Last Updated: 2021-10-29 20:46 (UTC)

Latest Comments

gyurman commented on 2022-01-30 10:08 (UTC)

$ qt5-virt-manager                                                                                                                                              
qt5-virt-manager: error while loading shared libraries: libqtermwidget5.so.0: cannot open shared object file: No such file or directory
community/qtermwidget 1.0.0-2 (241.1 KiB 808.4 KiB) (Installed)

miss_barfin commented on 2021-10-06 22:23 (UTC)

update to 0.72.99 please

HiJack88 commented on 2021-05-21 09:30 (UTC)

Hello everybody, I keep getting a build error when trying to compile the package:

==> Making package: qt-virt-manager 0.72.97-4 (Fri 21 May 2021 11:22:37 AM CEST) ==> Checking runtime dependencies... ==> Checking buildtime dependencies... ==> Retrieving sources... -> Found 0.72.97.tar.gz ==> Validating source files with sha256sums... ==> Extracting sources... -> Extracting 0.72.97.tar.gz with bsdtar ==> Starting prepare()... ==> Removing existing $pkgdir/ directory... ==> Starting build()... ==> -G Ninja -- Build on system: Linux -- Build with QT version: 5 -- QT4 build: 0 -- QT5 build: 1 -- -- LIB_SUFFIX variable is not defined. It will be autodetected now. -- You can set it manually with -DLIB_SUFFIX=<value> (64 for example) -- LIB_SUFFIX is set to '64' -- -- Checking for module 'libkrdccore' -- Package 'libkrdccore', required by 'virtual:world', not found -- Found KRDC libraries: /usr/lib/libkrdccore.so -- Found KRDC includes : /usr/include/krdc -- Found GObject libraries: /usr/lib/libgobject-2.0.so;/usr/lib/libgmodule-2.0.so;/usr/lib/libgthread-2.0.so;/usr/lib/libglib-2.0.so -- Found GObject includes : /usr/include/glib-2.0/gobject -- Found Gio libraries: /usr/lib/libgio-2.0.so -- Found Gio includes : /usr/include/glib-2.0/gio -- Found includes : /usr/include/glib-2.0;/usr/lib/glib-2.0/include /usr/include/glib-2.0/gobject /usr/include/glib-2.0/gio

/usr/include/spice-1
/usr/include/spice-client-glib-2.0
/usr/include/libvirt
/usr/include/qtermwidget5;/usr/include/qt/QtWidgets;/usr/include/qt;/usr/include/qt/QtCore;/usr/include/qt/QtGui
/usr/include/rfb
/usr/include/krdc

-- Found BUILD_PROJECT_LIBRARIES: Qt5::Widgets;Qt5::Xml;Qt5::Svg;Qt5::Multimedia;Qt5::Network;/usr/lib/libvirt.so;qtermwidget5;Qt5Widgets;Qt5Gui;Qt5Core;/usr/lib/libglib-2.0.so;/usr/lib/libgobject-2.0.so;/usr/lib/libgmodule-2.0.so;/usr/lib/libgthread-2.0.so;/usr/lib/libglib-2.0.so;/usr/lib/libgio-2.0.so;/usr/lib/libspice-client-glib-2.0.so;/usr/lib/libvncclient.so;/usr/lib/libkrdccore.so -- Configuring done -- Generating done -- Build files have been written to: /home/user/.cache/yay/qt-virt-manager/src/qt-virt-manager-0.72.97/build [1/1170] Building CXX object CMakeFiles/qt5-remote-viewer.dir/src/vm_viewer/qspice_widgets/qspice-helper.cpp.o FAILED: CMakeFiles/qt5-remote-viewer.dir/src/vm_viewer/qspice_widgets/qspice-helper.cpp.o /usr/bin/c++ -DBUILD_TYPE=Release -DQSPICE_WIDGET_COMPILATION -DQTONLY -DQT_CORE_LIB -DQT_GUI_LIB -DQT_MULTIMEDIA_LIB -DQT_NETWORK_LIB -DQT_NO_DEBUG -DQT_SVG_LIB -DQT_WIDGETS_LIB -DQT_XML_LIB -DUSE_SPICE_AUDIO=1 -DWITH_LIBCACARD=0 -DWITH_SPICE_SUPPORT=1 -DWITH_VNC_SUPPORT=1 -I. -I../ -I../src -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/glib-2.0/gobject -I/usr/include/glib-2.0/gio -I/usr/include/spice-1 -I/usr/include/spice-client-glib-2.0 -I/usr/include/libvirt -I/usr/include/qtermwidget5 -I/usr/include/rfb -I/usr/include/krdc -isystem /usr/include/qt -isystem /usr/include/qt/QtWidgets -isystem /usr/include/qt/QtGui -isystem /usr/include/qt/QtCore -isystem /usr/lib/qt/mkspecs/linux-g++ -isystem /usr/include/qt/QtXml -isystem /usr/include/qt/QtSvg -isystem /usr/include/qt/QtMultimedia -isystem /usr/include/qt/QtNetwork -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -fexceptions -Wp,-D_FORTIFY_SOURCE=2,-D_GLIBCXX_ASSERTIONS -Wformat -Werror=format-security -fstack-clash-protection -fcf-protection -std=c++11 -std=c++11 -O3 -DNDEBUG -fPIC -MD -MT CMakeFiles/qt5-remote-viewer.dir/src/vm_viewer/qspice_widgets/qspice-helper.cpp.o -MF CMakeFiles/qt5-remote-viewer.dir/src/vm_viewer/qspice_widgets/qspice-helper.cpp.o.d -o CMakeFiles/qt5-remote-viewer.dir/src/vm_viewer/qspice_widgets/qspice-helper.cpp.o -c ../src/vm_viewer/qspice_widgets/qspice-helper.cpp In file included from /usr/include/glib-2.0/glib/gatomic.h:31, from /usr/include/glib-2.0/glib/gthread.h:32, from /usr/include/glib-2.0/glib/gasyncqueue.h:32, from /usr/include/glib-2.0/glib.h:32, from /usr/include/spice-client-glib-2.0/spice-client.h:21, from ../src/vm_viewer/qspice_widgets/qspice-helper.h:27, from ../src/vm_viewer/qspice_widgets/qspice-helper.cpp:18: /usr/include/c++/11.1.0/type_traits:56:3: error: template with C linkage 56 | template<typename _Tp, _Tp __v> | ^~~~~~~~ In file included from ../src/vm_viewer/qspice_widgets/qspice-helper.cpp:18: ../src/vm_viewer/qspice_widgets/qspice-helper.h:26:1: note: ‘extern "C"’ linkage started here 26 | extern "C" { | ^~~~~~~~~~ In file included from /usr/include/glib-2.0/glib/gatomic.h:31, from /usr/include/glib-2.0/glib/gthread.h:32, from /usr/include/glib-2.0/glib/gasyncqueue.h:32, from /usr/include/glib-2.0/glib.h:32, from /usr/include/spice-client-glib-2.0/spice-client.h:21, from ../src/vm_viewer/qspice_widgets/qspice-helper.h:27, from ../src/vm_viewer/qspice_widgets/qspice-helper.cpp:18: /usr/include/c++/11.1.0/type_traits:71:3: error: template with C linkage 71 | template<typename _Tp, _Tp __v> | ^~~~~~~~ In file included from ../src/vm_viewer/qspice_widgets/qspice-helper.cpp:18: ../src/vm_viewer/qspice_widgets/qspice-helper.h:26:1: note: ‘extern "C"’ linkage started here 26 | extern "C" { | ^~~~~~~~~~ In file included from /usr/include/glib-2.0/glib/gatomic.h:31, from /usr/include/glib-2.0/glib/gthread.h:32, from /usr/include/glib-2.0/glib/gasyncqueue.h:32, from /usr/include/glib-2.0/glib.h:32, from /usr/include/spice-client-glib-2.0/spice-client.h:21, from ../src/vm_viewer/qspice_widgets/qspice-helper.h:27, from ../src/vm_viewer/qspice_widgets/qspice-helper.cpp:18: /usr/include/c++/11.1.0/type_traits:80:3: error: template with C linkage 80 | template<bool __v> | ^~~~~~~~ In file included from ../src/vm_viewer/qspice_widgets/qspice-helper.cpp:18: ../src/vm_viewer/qspice_widgets/qspice-helper.h:26:1: note: ‘extern "C"’ linkage started here 26 | extern "C" { | ^~~~~~~~~~ In file included from /usr/include/glib-2.0/glib/gatomic.h:31, from /usr/include/glib-2.0/glib/gthread.h:32, from /usr/include/glib-2.0/glib/gasyncqueue.h:32, from /usr/include/glib-2.0/glib.h:32, from /usr/include/spice-client-glib-2.0/spice-client.h:21, from ../src/vm_viewer/qspice_widgets/qspice-helper.h:27, from ../src/vm_viewer/qspice_widgets/qspice-helper.cpp:18: /usr/include/c++/11.1.0/type_traits:91:3: error: template with C linkage 91 | template<bool, typename, typename> | ^~~~~~~~ In file included from ../src/vm_viewer/qspice_widgets/qspice-helper.cpp:18: ../src/vm_viewer/qspice_widgets/qspice-helper.h:26:1: note: ‘extern "C"’ linkage started here 26 | extern "C" { | ^~~~~~~~~~

....

My Arch Linux has just been updated this morning but the error still occurs.

Any help whould be appreciated.

Cheers Pat

Jrbo commented on 2021-01-02 12:52 (UTC)

New update has been released 11 days ago. What I did was, I git clone the AUR link; accessed the PKGBUILD file and at the pkgver variable, I changed it to 0.72.97 (the current version of the upstream repo). Compiled and installed successfully.

This might be the temporary solution for now until this package is updated.

CupricReki commented on 2020-12-22 08:55 (UTC) (edited on 2020-12-22 08:57 (UTC) by CupricReki)

Successfully compiled with https://github.com/fadenb/qt-virt-manager as referenced by kapoyav. I don't know much about PKGBUILD but I was able to copy the git repo into the src directory and run: makepkg -si --skipinteg

kapoyav commented on 2020-12-17 16:28 (UTC) (edited on 2020-12-17 16:29 (UTC) by kapoyav)

fix 'DotCursorState' error https://github.com/fadenb/qt-virt-manager/commit/4640f5f64534ed7c8a1ecc6851f1c7503988de6d

ImNtReal commented on 2020-11-17 14:57 (UTC)

The build error is an upstream error, and I simply haven't had time to figure out how to patch it, yet. Please, don't flag the package out of date unless upstream actually releases a new version.

If anyone comes up with a patch to fix the current compile issue, I'll be happy to include it.

allexj commented on 2020-11-01 08:26 (UTC) (edited on 2020-11-01 08:28 (UTC) by allexj)

[32%] Building CXX object CMakeFiles / qt5-virt-manager.dir / src / virt_objects / open_file_menu.cpp.o make [2]: *** [CMakeFiles / qt5-virt-manager.dir / build.make: 2444: CMakeFiles / qt5-virt-manager.dir / src / main.cpp.o] Error 1 make [2]: *** Wait for unfinished processes .... make [2]: *** [CMakeFiles / qt5-virt-manager.dir / build.make: 2457: CMakeFiles / qt5-virt-manager.dir / src / mainwindow.cpp.o] Error 1 /var/tmp/pamac-build-allexj/qt-virt-manager/src/qt-virt-manager-0.70.91/src/dock_head_widgets/dock_head_widget.cpp: In member function 'virtual void DockHeadWidget :: wheelEvent (QWheelEvent * ) ': /var/tmp/pamac-build-allexj/qt-virt-manager/src/qt-virt-manager-0.70.91/src/dock_head_widgets/dock_head_widget.cpp:68:24: warning: 'int QWheelEvent :: delta ( ) const 'is deprecated: Use angleDelta () [-Wdeprecated-declarations] 68 | if (ev-> delta ()> 0) { | ^ In file included from / usr / include / qt / QtGui / QWheelEvent: 1, from /var/tmp/pamac-build-allexj/qt-virt-manager/src/qt-virt-manager-0.70.91/src/dock_head_widgets/dock_head_widget.h:9, from /var/tmp/pamac-build-allexj/qt-virt-manager/src/qt-virt-manager-0.70.91/src/dock_head_widgets/dock_head_widget.cpp:1: /usr/include/qt/QtGui/qevent.h:219:16: note: declared here 219 | inline int delta () const {return qt4D; } | ^ ~~~~ /var/tmp/pamac-build-allexj/qt-virt-manager/src/qt-virt-manager-0.70.91/src/dock_head_widgets/dock_head_widget.cpp:70:31: warning: 'int QWheelEvent :: delta ( ) const 'is deprecated: Use angleDelta () [-Wdeprecated-declarations] 70 | } else if (ev-> delta () <0) { | ^ In file included from / usr / include / qt / QtGui / QWheelEvent: 1, from /var/tmp/pamac-build-allexj/qt-virt-manager/src/qt-virt-manager-0.70.91/src/dock_head_widgets/dock_head_widget.h:9, from /var/tmp/pamac-build-allexj/qt-virt-manager/src/qt-virt-manager-0.70.91/src/dock_head_widgets/dock_head_widget.cpp:1: /usr/include/qt/QtGui/qevent.h:219:16: note: declared here 219 | inline int delta () const {return qt4D; } | ^ ~~~~ make [1]: *** [CMakeFiles / Makefile2: 124: CMakeFiles / qt5-virt-manager.dir / all] Error 2 make: *** [Makefile: 149: all] Error 2 ==> ERROR: An error occurred in build (). The operation is about to be stopped ...

sentientmachin3 commented on 2020-10-30 21:59 (UTC)

I am getting another error: src/vm_viewer/krdc_vnc_qtonly/vncview.h:64:24: error: ‘DotCursorState’ has not been declared

ImNtReal commented on 2020-09-08 20:10 (UTC)

@kinoe, it's probably a Qt version compatibility bug. I'll try to look at it when I can, but it doesn't seem to be fixed in git, yet, either, so probably needs to go upstream.

kinoe commented on 2020-09-04 16:42 (UTC)

ninja build failed: FAILED: CMakeFiles/qt5-remote-viewer.dir/src/vm_viewer/main.cpp.o

knaick commented on 2019-12-19 21:51 (UTC)

@ImNtReal can you add the 'qt5-tools' as a dependency of this package ??

bartus commented on 2018-08-06 07:02 (UTC) (edited on 2019-09-22 07:14 (UTC) by bartus)

qt5-tools is a missing dependency.

git am < <(curl https://pastebin.com/raw/fe3dYpU6)

cmsigler commented on 2018-07-28 19:35 (UTC)

Hi,

This package built fine but krdc was uninstalled afterwards because it was a make dependency. However, when I tried to run the binary I got:

"qt5-virt-manager: error while loading shared libraries: libkrdccore.so.5: cannot open shared object file: No such file or directory"

Sure enough, ldd lists libkrdccore.so.5 => /usr/lib/libkrdccore.so.5. Installing krdc and its dependencies fixed this for runtime.

HTH.

Clemmitt Sigler

malkauns commented on 2018-07-20 17:27 (UTC)

Yep, this failed the first time. Saw references to krdc so installed it. Now it successfully builds and installs.

ilya-fedin commented on 2018-06-10 05:42 (UTC) (edited on 2018-06-10 05:43 (UTC) by ilya-fedin)

Hello! Can you add krdc as a build dependency? Without it build fails.

commented on 2018-01-13 21:50 (UTC)

Upstream already fixed the bug with qtermwidget.h. Please update.

Source: https://github.com/F1ash/qt-virt-manager/issues/27

Thaodan commented on 2018-01-10 18:51 (UTC)

I don't know. I'm the original maintainer and I added the prefix because Qt4 was still in use. But the old version is dropped by him since 2016. Also the credit towards me is removed.

ImNtReal commented on 2018-01-10 17:41 (UTC)

Is there a reason this package is called virt-manager-qt5 instead of qt-virt-manager?

msarti commented on 2017-11-12 08:54 (UTC) (edited on 2017-11-12 09:10 (UTC) by msarti)

Same error, it does not compile against qtermwidget 0.8.0-1 /tmp/yaourt-tmp-msarti/aur-virt-manager-qt5/src/qt-virt-manager/src/vm_viewer/qterminal/termwidget.h:4:10: fatal error: qtermwidget.h: No such file or directory #include <qtermwidget.h> it seems to be an opened issue of the project.

Kunda commented on 2017-10-18 11:32 (UTC)

Current git version is 0.45.75 @madsciencecoder ping

AJSlye commented on 2017-04-05 08:43 (UTC) (edited on 2017-04-05 08:43 (UTC) by AJSlye)

New version 0.42.67. Compiles against qtermwidget from Arch repo, no need for git version.

dhs92 commented on 2017-03-30 00:39 (UTC)

[ 36%] Building CXX object CMakeFiles/qt5-virt-manager.dir/src/main.cpp.o In file included from /tmp/yaourt-tmp-alex/aur-virt-manager-qt5/src/qt-virt-manager/src/vm_viewer/qterminal/termwidgetholder.h:5:0, from /tmp/yaourt-tmp-alex/aur-virt-manager-qt5/src/qt-virt-manager/src/vm_viewer/qterminal/term_mainwindow.h:7, from /tmp/yaourt-tmp-alex/aur-virt-manager-qt5/src/qt-virt-manager/src/vm_viewer/lxc/lxc_viewer.h:5, from /tmp/yaourt-tmp-alex/aur-virt-manager-qt5/src/qt-virt-manager/src/mainwindow.h:22, from /tmp/yaourt-tmp-alex/aur-virt-manager-qt5/src/qt-virt-manager/src/main.cpp:1: /tmp/yaourt-tmp-alex/aur-virt-manager-qt5/src/qt-virt-manager/src/vm_viewer/qterminal/termwidget.h:4:25: fatal error: qtermwidget.h: No such file or directory #include <qtermwidget.h> ^ compilation terminated. make[2]: *** [CMakeFiles/qt5-virt-manager.dir/build.make:2341: CMakeFiles/qt5-virt-manager.dir/src/main.cpp.o] Error 1 make[1]: *** [CMakeFiles/Makefile2:105: CMakeFiles/qt5-virt-manager.dir/all] Error 2 make: *** [Makefile:128: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build . Receiving this error when building using Yaourt.

forlorn commented on 2017-03-02 00:21 (UTC)

qtermwidget-git has been removed from AUR, please refer to community/qtermwidget. I bumped my local build snapshot to 0.39.60 and it builds just fine.

madsciencecoder commented on 2016-09-26 01:05 (UTC)

@chash pkg-config is part of the base-devel group which is assumed to be installed for anyone using the AUR. See https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites. Quote: "Note: Packages in the AUR assume that the base-devel group is installed, i.e. they do not list the group's members as dependencies explicitly."

chash commented on 2016-09-20 20:06 (UTC)

Please add pkg-config to make dependencies, without this package building interrupts with following error: -- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) -- Could NOT find PkgConfig (missing: PKG_CONFIG_EXECUTABLE) CMake Error at /usr/share/cmake-3.6/Modules/FindPackageHandleStandardArgs.cmake:148 (message): Could NOT find GLib2 (missing: GLib2_INCLUDE_DIR) Call Stack (most recent call first): /usr/share/cmake-3.6/Modules/FindPackageHandleStandardArgs.cmake:388 (_FPHSA_FAILURE_MESSAGE) cmake/FindGLib2.cmake:33 (find_package_handle_standard_args) CMakeLists.txt:859 (find_package)

laurelindorien commented on 2016-07-22 14:58 (UTC)

Latest qt5-virt-manager seems to require libvncserver too as dependency. Without this the compilation kept erroring out with cmake set to NOTFOUND LIBVNCCLIENT_INCLUDE_DIR.

brando56894 commented on 2016-04-10 21:36 (UTC)

x11-ssh-askpass is also needed for SSH connections.

MaJia321 commented on 2016-03-21 06:31 (UTC)

Please add qt5-multimedia to makedepens THX

brando56894 commented on 2016-03-03 19:05 (UTC)

did you install qtermwidget-git?

Fallback commented on 2016-02-20 01:31 (UTC)

Release 0.22.43 didn't compile [ 62%] Building CXX object CMakeFiles/qt4-virt-manager.dir/src/vm_viewer/vm_state_widget.cpp.o [ 62%] Building CXX object CMakeFiles/qt4-virt-manager.dir/src/vm_viewer/transformation_mode_menu.cpp.o [ 62%] Building CXX object CMakeFiles/qt4-virt-manager.dir/src/vm_viewer/click_label.cpp.o [ 62%] Building CXX object CMakeFiles/qt4-virt-manager.dir/src/vm_viewer/lxc/lxc_viewer.cpp.o /tmp/yaourt-tmp-ctrl/aur-virt-manager-qt5/src/qt-virt-manager/src/vm_viewer/lxc/lxc_viewer.cpp: In Elementfunktion »void LXC_Viewer::setTerminalParameters()«: /tmp/yaourt-tmp-ctrl/aur-virt-manager-qt5/src/qt-virt-manager/src/vm_viewer/lxc/lxc_viewer.cpp:141:32: Fehler: »class TermWidgetImpl« has no member named »screenLinesCount« int l = t->impl()->screenLinesCount(); ^ /tmp/yaourt-tmp-ctrl/aur-virt-manager-qt5/src/qt-virt-manager/src/vm_viewer/lxc/lxc_viewer.cpp:146:20: Fehler: »class TermWidgetImpl« has no member named »startTerminalTeletype« t->impl()->startTerminalTeletype(); ^ CMakeFiles/qt4-virt-manager.dir/build.make:8590: die Regel für Ziel „CMakeFiles/qt4-virt-manager.dir/src/vm_viewer/lxc/lxc_viewer.cpp.o“ scheiterte make[2]: *** [CMakeFiles/qt4-virt-manager.dir/src/vm_viewer/lxc/lxc_viewer.cpp.o] Fehler 1 CMakeFiles/Makefile2:67: die Regel für Ziel „CMakeFiles/qt4-virt-manager.dir/all“ scheiterte make[1]: *** [CMakeFiles/qt4-virt-manager.dir/all] Fehler 2 Makefile:127: die Regel für Ziel „all“ scheiterte make: *** [all] Fehler 2

brando56894 commented on 2016-02-03 00:42 (UTC)

Actually that doesn't really fix it, but I figured out what does, you need to install these packages from the AUR: scrub and qtermwidget-git and spice-protocol from the repository Also I needed to add () around the conflicts and replaces arrays conflicts=(${pkgname}4) replaces=(${pkgname}4) and increment the package version to match https://github.com/F1ash/qt-virt-manager/releases pkgver=0.22.42

brando56894 commented on 2016-02-02 01:37 (UTC)

fixed it! This one specifically builds the QT5 variant. ## Modified by Brando56894 <brando56894 at gmail> ## Maintainer: Thaodan <theodorstormgrade@gmail.com> pkgname='virt-manager-qt' _pkgname='qt-virt-manager' pkgbase='virt-manager-qt' url='https://github.com/F1ash/qt-virt-manager' makedepends=('cmake') depends=('libvirt' 'scrub' 'spice-gtk3' 'qtermwidget' ) arch=('i686' 'x86_64') license=('GPL2') pkgrel=1 pkgver=0.22.42 source=("git+https://github.com/F1ash/qt-virt-manager.git#tag=$pkgver") makedepends+=('qt5-base' 'qt5-svg' 'qtermwidget') pkgdesc="Qt Virtual Machine Manager provides a graphical tool for administering virtual machines for QEMU/KVM, Xen, and LXC and other Virtual Entities. Uses libvirt as the backend management API." prepare() { mkdir -p "$srcdir"/$_pkgname/cmake } build() { export CXXFLAGS="$CXXFLAGS -std=c++11" cd "$srcdir" mkdir -p "$srcdir"/build-qt5 cd "$srcdir"/build-qt5 cmake -DBUILD_QT_VERSION=5 -DCMAKE_INSTALL_PREFIX=/usr -DCMAKE_BUILD_TYPE=Release ../$_pkgname make } package_virt-manager-qt5() { depends+=('qt5-base' 'qt5-svg' 'qtermwidget') pkgname='virt-manager-qt5' conflicts=(${pkgname}4) replaces=(${pkgname}4) pkgdesc+=" qt5" cd "$srcdir"/build-qt5 make install DESTDIR=$pkgdir } if [ $pkgname = $pkgbase ] ; then true && pkgname=( ${pkgbase}5 ) else true && pkgname+=( ${pkgbase}5 ) fi md5sums=('SKIP')

eri commented on 2015-11-30 22:11 (UTC)

it does not builds aur-virt-manager-qt4/src/qt-virt-manager/src/vm_viewer/lxc/lxc_viewer.cpp:116:20: error: «class TermWidgetImpl» has no member named «startTerminalTeletype»

maz-1 commented on 2015-11-04 05:22 (UTC)

Please add 'spice-gtk3' as dependency

Thaodan commented on 2015-05-13 09:32 (UTC)

updated, however still broken

Thaodan commented on 2015-05-13 09:26 (UTC)

please don't write comments like version XXX is on when there's a new version, especially after you marked it out of date, this is annoying. I'm not blind I see my notification email.

XenGi commented on 2015-05-13 08:46 (UTC)

Still fails for me with the newest version (0.10.21). I filed a bug upstream. https://github.com/F1ash/qt-virt-manager/issues/7

excalibur1234 commented on 2015-03-25 12:15 (UTC)

thx. i can confirm that the build fails at 65%. i will try again when the next version gets released.

Thaodan commented on 2015-03-25 01:29 (UTC)

updated pkg, the cmake files are no longer needed,however it doesn't build for me

excalibur1234 commented on 2015-03-25 00:19 (UTC)

i cannot build this package, because libvirt-config.cmake could not be downloaded. also, there was a new release (version 0.8.15) over 2 weeks ago. can you please fix this (or create a virt-manager-qt5-git package)?