Package Details: qtwebflix-git 0.1.r184.g3741139-1

Git Clone URL: https://aur.archlinux.org/qtwebflix-git.git (read-only, click to copy)
Package Base: qtwebflix-git
Description: Standalone HD Netflix Browser using qt5-webengine (also supports Amazon prime, HBO Go, Hulu, Crunchy Roll)
Upstream URL: https://github.com/gort818/qtwebflix
Keywords: 1080p amazon drm hbo hd qt5-webengine
Licenses: GPL3
Submitter: omni
Maintainer: omni
Last Packager: omni
Votes: 34
Popularity: 0.007738
First Submitted: 2017-10-02 13:44 (UTC)
Last Updated: 2022-01-08 08:30 (UTC)

Pinned Comments

Plexcon commented on 2018-08-16 09:18 (UTC)

Also supports adding other streaming services go to ~/.config/Qtwebflix/Providers.conf and add your service

[providers] netflix=http://netflix.com prime=https://www.primevideo.com/region/eu/storefront/home/ref=atv_nb_logo

omni commented on 2017-10-02 13:52 (UTC) (edited on 2018-03-30 06:56 (UTC) by omni)

Enjoy a standalone HD netflix player! f11 for fullscreen and crtl + q to quit

Latest Comments

1 2 3 4 5 6 Next › Last »

Fred1 commented on 2024-03-24 11:28 (UTC) (edited on 2024-03-28 18:42 (UTC) by Fred1)

QtWebFlix stopped functioning a few days ago for Netflix. After clicking content a ui3013 error appears.

Advice from Netflix is turn off your exentions. This is a bit like having a problem with your car, getting advice to take the bike. But, I saw that the 1080 Netflix browser extensions will let you face the same error, so Netflix has a point. If it does not work, turn it off.

Anyways, luckily solutions are nearby. Sadly not directly for QtWebFlix, but I found this page (https://github.com/vladikoff/netflix-1080p-firefox/issues/70) on which user Nimras186 (commented 2 days ago). I can confirm that the problem is solved with this extension: https://github.com/jangxx/netflix-1080p (Stream is 1080 with this extension on Chromium, check by Shift + Ctrl + Alt + D in the not full screen modus)

Update: Since yesterday the ui3013 error is gone and QtWebFlix is working normal. Don't know what's changed. I think Netflix changed someting.

Menelkir commented on 2023-12-16 21:49 (UTC)

Chromium-widevine was orphaned, but there's vivaldi-widevine which does the same thing and still adopted (it doesn't depend on vivaldi), isn't a good idea to change it?

Fred1 commented on 2022-09-24 20:58 (UTC)

Great app! Working good just now (maybe comparable to Netflix Windows app for 1080p). A great step for Linux I think. Thanks! Still enormously hoping for UHD/4k Netflix on Linux. 100% linux then (for PC and laptop).

Nigholith commented on 2022-08-13 13:18 (UTC)

Doesn't work with Amazon Prime Video, only playing in 720p

zorbat5 commented on 2022-01-22 19:37 (UTC)

Works really well! Thanks for your work!

artodeto commented on 2022-01-22 18:50 (UTC)

Hey there, I had an issue installing it. There was a generic error message where g++ was involved but no error message was shown.

After a while, I've just installed base-devel and the installation was working fine. On the other hand, base-devel is required when interacting with aur, as written here [0].

So, you can decide if it makes sense to add the gcc as dependency or not.

I am fine since I hope that my message will be here to help someone in the near future.

Thanks for your work!

[0] https://wiki.archlinux.org/title/Arch_User_Repository#Getting_started

gort818 commented on 2022-01-08 01:28 (UTC)

Yeah sorry about that fixed some stuff and 1080p Netflix seems to be working again!

Menelkir commented on 2022-01-07 08:39 (UTC) (edited on 2022-01-07 08:42 (UTC) by Menelkir)

The .gitmodules patch isn't necessary anymore. Upstream fixed the issue, I've tested and build fine without the patch.