Package Details: quarto-cli 1.4.555-1

Git Clone URL: https://aur.archlinux.org/quarto-cli.git (read-only, click to copy)
Package Base: quarto-cli
Description: Quarto is an open-source scientific and technical publishing system built on [Pandoc](https://pandoc.org).
Upstream URL: https://quarto.org/
Licenses: MIT
Conflicts: quarto-cli-bin, quarto-cli-bin-pre-release, quarto-cli-git, quarto-cli-pre-release
Provides: quarto
Submitter: trap000d
Maintainer: trap000d
Last Packager: trap000d
Votes: 6
Popularity: 0.66
First Submitted: 2022-03-06 08:39 (UTC)
Last Updated: 2024-06-03 21:51 (UTC)

Latest Comments

trap000d commented on 2024-06-06 07:53 (UTC)

Hi @cbrnr,

Indeed, quarto-cli looks quite stable and predictable. So I'd be happy to move it to extra (though I'm not aware of details of this process).

cbrnr commented on 2024-06-06 07:15 (UTC)

Now that 1.4 has been out for quite a while, I wanted to ask about the plan to migrate this package to [extra] – still any major blockers? It seems like they now use a fairly recent Deno version (for quarto 1.5 they use 1.41, not entirely sure about 1.4).

trap000d commented on 2024-01-23 19:54 (UTC)

Hi @damir,

Correct, 'stable' quarto-cli can be built only against pretty old deno version (<1.29). In the future if/when Quarto developers will announce new stable release (1.4.xyz) it should become buildable again.

You have several options to override it: 1) Binary packages quarto-cli-bin and quarto-cli-bin-pre-release have all components bundled

2) source packages quarto-cli-pre-release and quarto-cli-git are built with the most recent deno.

3) Install old deno 1.28.x from repo archives (not the best idea, though)

damir commented on 2024-01-23 15:55 (UTC) (edited on 2024-01-23 15:56 (UTC) by damir)

cannot build against an existing deno:

==> Finished making: deno-git 1.9.2.r10614.g137f1a0c6836-1 (Tue 23 Jan 2024 16:49:37)
==> Cleaning up...


loading packages...
resolving dependencies...
looking for conflicting packages...
:: deno-git and deno are in conflict. Remove deno? [y/N] y

Packages (2) deno-1.39.4-1 [removal]  deno-git-1.9.2.r10614.g137f1a0c6836-1

Total Installed Size:  90.20 MiB
Net Upgrade Size:       3.87 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                                                                                          [########################################################################] 100%
(1/1) checking package integrity                                                                                        [########################################################################] 100%
(1/1) loading package files                                                                                             [########################################################################] 100%
(1/1) checking for file conflicts                                                                                       [########################################################################] 100%
(2/2) checking available disk space                                                                                     [########################################################################] 100%
:: Processing package changes...
(1/1) removing deno                                                                                                     [########################################################################] 100%
(1/1) installing deno-git                                                                                               [########################################################################] 100%
:: Running post-transaction hooks...
(1/2) Arming ConditionNeedsUpdate...
(2/2) Log Orphan Packages
The following packages are installed but not required (anymore):
dart-sass
esbuild
lua-lpeg
soci
yarn
You can mark them as explicitly installed with 'pacman -D --asexplicit <pkg>' or remove them all using 'pacman -Qtdq | pacman -Rns -'
==> Making package: quarto-cli 1.3.450-1 (Tue 23 Jan 2024 16:52:27)
==> Checking runtime dependencies...
==> Missing dependencies:
  -> deno>=1.28
  -> deno<1.29
==> Checking buildtime dependencies...
==> ERROR: Could not resolve all dependencies.
 -> error making: quarto-cli-exit status 8
 -> Failed to install the following packages. Manual intervention is required:
quarto-cli - exit status 8

alerque commented on 2023-12-05 09:40 (UTC)

I'd like to get this migrated to [extra] someday and am evaluating where it is at now. The build is pretty messy, but obviously a lot of that is the result of a messy upstream build process. I think we'll have to get it cleaned up a bit tighter before I migrate though. For example rather than removing junk in package() after the fact, I think we'll need to patch the build to not produce the junk in the first place. Before I get two far down that road though can you comment on the current situation with deno? Are version bumps to that package going to be a problem for this one down the road?

trap000d commented on 2022-08-05 21:33 (UTC) (edited on 2022-08-05 21:41 (UTC) by trap000d)

Hi @titaniumbones,

https://github.com/quarto-dev/quarto-cli/issues/1174

https://github.com/quarto-dev/quarto-cli/pull/1518

There is no solution for this yet, until quarto devs manage to move to latest Deno. Either downgrade deno to 22.3...

...or patch quarto sources. Here is my experimental PKGBUILD for that:

https://github.com/trap000d/aur/tree/master/quarto-cli

Alternatively, remove quarto-cli, remove deno version check in PKGBUILD, then build rstudio-desktop without quarto.

titaniumbones commented on 2022-08-05 14:45 (UTC) (edited on 2022-08-05 14:55 (UTC) by titaniumbones)

Getting a dependency error when trying to install; dependency deno<1.23.0 leads yay to install deno-bin from AUR (version 1.20), but it appears that deno-bin doesn't actually fulfill the dependency:

==> Making package: quarto-cli 1.0.37-1 (Fri 05 Aug 2022 10:40:11 AM EDT) ==> Checking runtime dependencies... ==> Missing dependencies: -> deno<1.23.0 ==> Checking buildtime dependencies... ==> ERROR: Could not resolve all dependencies. -> error making: quarto-cli

Editing PKGBUILD to change the dependency to just "deno" and running makepkg manually gives a deno dependency issue concerning lodash, resulting i na build abort:

Creating Quarto Symlink Found 3 paths to try.

Trying /usr/local/bin/quarto Didn't create symlink at /usr/local/bin/quarto Trying ~/.local/bin/quarto Symlink created at /home/matt/.local/bin/quarto Success Download https://deno.land/x/cliffy@v0.24.2/command/mod.ts ... [many successful downloads] ... error: Import 'https://cdn.skypack.dev/-/lodash@v4.17.21-K6GEbP02mWFnLA45zAmi/dist=es2019,mode=imports/unoptimized/_setCacheAdd.js' failed: 500 Internal Server Error at https://cdn.skypack.dev/-/lodash@v4.17.21-K6GEbP02mWFnLA45zAmi/dist=es2019,mode=imports/unoptimized/_SetCache.js:2:26 ==> ERROR: A failure occurred in build(). Aborting...

haven commented on 2022-04-26 21:47 (UTC)

https://github.com/quarto-dev/quarto-cli/discussions/709 Looks like there is an issue with ...bin/tools/pandoc/ and ...bin/pandoc