Package Details: quassel-core-small 0.14.0-1

Git Clone URL: (read-only, click to copy)
Package Base: quassel-core-small
Description: Next-generation distributed IRC client - core only, minimal dependencies
Upstream URL:
Licenses: GPL
Conflicts: quassel-core
Provides: quassel-core
Submitter: buzo
Maintainer: buzo
Last Packager: buzo
Votes: 18
Popularity: 0.42
First Submitted: 2018-12-20 16:45 (UTC)
Last Updated: 2022-01-18 17:57 (UTC)

Pinned Comments

Latest Comments

buzo commented on 2022-01-20 08:52 (UTC) (edited on 2022-01-20 08:53 (UTC) by buzo)

Sorry, yes – I should have chosen the rc versions differently. The workaraund is pacman -S quassel-core-small or pacman -U quassel-core-small-0.14.0-1-x86_64.pkg.tar.zst.

xombiemp commented on 2022-01-19 03:03 (UTC)

I'm getting: quassel-core-small: local (0.14.0.rc2-1) is newer than AUR (0.14.0-1)

Looks like an issue with the way the version is being parsed and compared. Can this be fixed somehow, or is there a work around?

buzo commented on 2021-04-10 17:24 (UTC) (edited on 2021-04-10 22:48 (UTC) by buzo)

The update to 0.14-rc1 finally fixes the build.

buzo commented on 2020-04-11 10:36 (UTC)

This package does not build since Arch switched to qt 5.14.0, see upsteam bug #1544. They have fixed this on Github, but won't release a new version soon apparently. As a workaround, I have made the AUR package quassel-core-small-git, which seems to work fine.

xombiemp commented on 2019-09-11 15:45 (UTC)

@buzo Clean building qt5-base-headless and quassel-core-small after full system update fixed the issue. Thanks!

buzo commented on 2019-09-11 08:13 (UTC)

xombiemp: What is the output of pacman -Qs qt5? New qt5 packages have been moved from testing to extra today, so maybe you need to rebuild qt5-base-headless and quassel-core-small.

xombiemp commented on 2019-09-11 03:04 (UTC) (edited on 2019-09-11 03:05 (UTC) by xombiemp)

After the latest update Quassel won't start for me. I'm seeing:

Sep 10 19:46:49 arch-nas systemd[1]: Started Quassel Core.
Sep 10 19:46:49 arch-nas quasselcore[8898]: 2019-09-10 19:46:49 [Info ] SQLite storage backend is ready. Schema version: 31
Sep 10 19:46:49 arch-nas quasselcore[8898]: 2019-09-10 19:46:49 [Info ] Database authenticator is ready.
Sep 10 19:46:49 arch-nas quasselcore[8898]: 2019-09-10 19:46:49 [Info ] Listening for GUI clients on IPv6 :: port 4242 using protocol version 10
Sep 10 19:46:49 arch-nas quasselcore[8898]: 2019-09-10 19:46:49 [Info ] Listening for GUI clients on IPv4 port 4242 using protocol version 10
Sep 10 19:46:49 arch-nas quasselcore[8898]: 2019-09-10 19:46:49 [Info ] Restoring previous core state...
Sep 10 19:46:49 arch-nas systemd[1]: quassel.service: Main process exited, code=killed, status=6/ABRT
Sep 10 19:46:49 arch-nas systemd[1]: quassel.service: Failed with result 'signal'.

It fails after Restoring previous core state... Anyone seen this before?

buzo commented on 2019-04-15 22:03 (UTC) (edited on 2019-04-15 22:04 (UTC) by buzo)

The library /usr/lib/ got a version bump to *.64, so any package which needs it won't work any more and needs to be rebuilt against the new version.

The owner of qt5-base-headless could maybe bump pkgrel to force the rebuild, but that's all.

xombiemp commented on 2019-04-15 18:49 (UTC)

@buzo Thanks, that worked. What do you mean icu has been updated in an incompatible way? Should we suggest a change for that package?

buzo commented on 2019-04-15 07:48 (UTC)

xombiemp: You need to rebuild qt5-base-headless first, since its dependency icu has been updated in an incompatible way.

xombiemp commented on 2019-04-13 14:18 (UTC)

I'm getting this error when trying to update to the latest version:

buzo commented on 2018-12-21 09:05 (UTC)

The comments below this one belong to the old (merged) AUR package quassel-light.

This new package uses qt5-base-headless instead of qt5-base for reduced dependencies, but builds only the Quassel core, since there is quassel-client-small in Community now.

buzo commented on 2018-08-05 12:07 (UTC)

One more build failure: Line 83 should read «rm -rf …» instead of «rm -r …». Otherwise I get a «rm: cannot remove '/home/…/quassel-light/pkg/quassel-core-light/usr/share': No such file or directory».

buzo commented on 2018-08-05 12:04 (UTC)

Oh, and lines 61 and 66 are missing a «\», too. This leads to multiple build errors.

buzo commented on 2018-08-05 11:59 (UTC)

Does not build. Line 58 of PKGBUILD is missing a «\».

buzo commented on 2018-03-16 09:19 (UTC)

This package needs to conflict with and provide at least quassel-core, and maybe other quassel packages, too. Otherwise switching from the regular package to this one and vice versa does not work correctly.

cyrevolt commented on 2016-05-02 09:07 (UTC) (edited on 2016-05-02 09:08 (UTC) by cyrevolt)

You need qt5-script in order to build. It is deprecated according to though, so I assume the Quassel developers will migrate at some point. :) ``` -- The following REQUIRED packages have not been found: * Qt5Script , provides scripting support for Qt5 ```

Wabuo commented on 2016-01-25 05:10 (UTC)

I put some comands in to the prepare() funktion for debugging. Here is what i got: pwd in _pkgbase /tmp/makepkg/quassel-light/src/quassel-0.12.2 tree in ../../ | grep patch ├── fix_qt5.5_build.patch -> /tmp/yaourt-tmp-user/aur-quassel-core-light/fix_qt5.5_build.patch ├── fix_ssl_check.patch -> /tmp/yaourt-tmp-user/aur-quassel-core-light/fix_ssl_check.patch │   │   ├── quassel.pot.patch So for me the symlinks to the patch files are placed in .../src is that normal?

Wabuo commented on 2016-01-25 04:36 (UTC)

Well mine has ... Will lock in to it.

trollixx commented on 2016-01-25 04:03 (UTC)

I am not sure what the issue is, but the patch is there: yaourt has no issues with downloading it.

Wabuo commented on 2016-01-25 03:58 (UTC)

Wont build quits wit: patch: **** Can't open patch file ../../fix_ssl_check.patch : No such file or directory

trollixx commented on 2015-11-30 02:01 (UTC)

qt5-script is a dependency already, see [1] and [2]. 1. 2.

dgerbaudo commented on 2015-11-09 12:49 (UTC)

I tried it again. -Qca-qt5 is optional (for encryption) -The only one required, like you said is: qt5-script. If quassel-core-light and quassel-monolithic-light depend on qt5-script, I think it would be best to add it to depends in PKGBUILD. It doesn't compile without it. -I don't remember why I've installed qt5-tools. It's not required.

trollixx commented on 2015-11-07 06:28 (UTC) (edited on 2015-11-08 00:13 (UTC) by trollixx)

qca-qt5: It is an optional dependency, and this quassel-*-light aims to keep number of dependencies as low as possible. Not sure whether we to always depend on QCA. qt5-script: quassel-core-light and quassel-monolithic-light do depend on qt5-script, so it should be installed, usually an AUR managemnt tool (like yaourt) takes care about installation of required packages. qt5-tools: No idea why is it needed, it should build properly anyway. @dgerbaudo?

dgerbaudo commented on 2015-11-06 12:49 (UTC)

Clean list of missing dependencies: -qt5-tools -qca-qt5 -qt5-script

lopardo commented on 2015-10-30 12:52 (UTC)

It's currently not working for me: -- The following OPTIONAL packages have not been found: * Qca-qt5 -- The following RECOMMENDED packages have not been found: * QCA2-QT5 , Qt Cryptographic Architecture , <> Required for encryption support -- The following REQUIRED packages have not been found: * Qt5Script , provides scripting support for Qt5 CMake Error at /usr/share/cmake-3.3/Modules/FeatureSummary.cmake:556 (message): feature_summary() Error: REQUIRED package(s) are missing, aborting CMake run. Call Stack (most recent call first): CMakeLists.txt:608 (feature_summary)

trollixx commented on 2015-07-30 03:27 (UTC)

@sLite, done, thanks!

sLite commented on 2015-07-27 07:38 (UTC)

Build currently fails with Qt 5.5 -> "ambiguous overload for ‘operator<<’" Could you please include the patch attached to this ticket to your quassel packages: I've tried it and it fixes the error.

virtual-dev commented on 2015-07-16 11:37 (UTC)

Thanks for your work, this version was to repository!

trollixx commented on 2015-06-08 04:07 (UTC)

@bjorn, I've added the missing patch, thanks for reporting!

bjorn commented on 2015-06-07 08:39 (UTC)

The PKGBUILD is trying to apply "fix_ssl_check.patch", but this patch is missing from the package. It compiled fine after just removing the line that tried to apply the patch, but then when launching quasselclient the message "Your client does not support SSL encryption" pops up.

DiscipleOfDante commented on 2015-01-30 16:35 (UTC)

Oh okay thanks. I need this for my LXQt desktop, at least until Qutim works. Luckily it builds with makepkg. Thanks for maintaining this sensible package of this great software.

trollixx commented on 2015-01-30 07:24 (UTC)

Yes, it's a bug (or missing feature) in Yaourt. Please see It looks like the issue has been fixed recently, but there are no new Yaourt release yet.

DiscipleOfDante commented on 2015-01-30 04:59 (UTC)

I can not install this. It seems quassel-monolithic-light is in conflict with quassel-client-light. Here is my output from yaourt on the attempt to install the built packages. loading packages... resolving dependencies... looking for conflicting packages... error: unresolvable package conflicts detected error: failed to prepare transaction (conflicting dependencies) :: quassel-client-light and quassel-monolithic-light are in conflict ==> WARNING: Your packages are saved in /tmp/yaourt-tmp-discipleofdante

MindfulMonk commented on 2014-11-17 19:32 (UTC)

Here is the PKGBUILD for 0.11 with QT5

mshade commented on 2014-05-15 15:02 (UTC)

Updated to 10.0 - sorry for the delay on this one! I missed the out of date notification and stopped using Quassel myself. Anyone care to take over maintenance?

Nowaker commented on 2013-11-08 00:06 (UTC)

This package should provide quassel-core, just as the [community] package does.

mshade commented on 2013-05-21 20:46 (UTC)

Glad it's appreciated! Some folks didn't like the idea of a separate PKGBUILD for just the client. I thought it would be useful, rather than having to edit the other quassel-light on each machine I wanted to use it on.

bjorn commented on 2013-05-21 20:39 (UTC)

Well, I think it's great that you maintain a package with just the light-weight client. Thanks for the update!

mshade commented on 2013-05-21 20:12 (UTC)

Updated to 0.9.0

mshade commented on 2013-05-21 20:10 (UTC)

Hi bjorn, thanks for that -- I looked and didn't find it when I saw the initial 0.9.0 announce. I'm debating whether to track the version in [community] (my initial plan) or track the stable release with this package. Since there's a quassel-light package as well, already on 0.9.0 I think this is perhaps not much of a concern. Will update shortly.

bjorn commented on 2013-05-21 19:09 (UTC)

The tarball seems to be available at since 17th of April already.

mshade commented on 2013-05-04 01:40 (UTC)

Will update the package to 0.9 when a tarball becomes available.

bjorn commented on 2013-03-03 11:25 (UTC)

As for the libdbusmenu-qt dependency, this is indeed thrown in when available: -- Found DBusMenuQt: /usr/lib64/ -- Enabling support for exporting the tray menu via D-Bus

rperier commented on 2013-03-02 20:57 (UTC)

Please update the package as suggested by . All packages depending on qt need to depend on qt4. thanks

pztrn commented on 2013-03-02 20:42 (UTC)

Please, change qt to qt4 (there is no more "qt" package)

bjorn commented on 2013-03-02 20:32 (UTC)

Apparently you get that error only when you have qt5-base installed. I need that package because I use qtcreator and tiled-qt, which now both depend on Qt 5.

mshade commented on 2013-03-02 20:24 (UTC)

This package builds fine for me on a fresh install (tested with new VM). I do see that I should add icu as a dependency perhaps, but build does not fail.

bjorn commented on 2013-03-02 19:12 (UTC)

Make Error: The following variables are used in this project, but they are set to NOTFOUND. Please set them or make sure they are set and tested correctly in the CMake files: QT_QT_INCLUDE_DIR (ADVANCED)

mshade commented on 2013-03-02 18:46 (UTC)

Oof, not sure how I missed that :) Standby...

bjorn commented on 2013-03-02 07:37 (UTC)

mshade, see the latest announcement:

mshade commented on 2013-03-01 22:04 (UTC)

bjorn - have you another version of Qt installed as 'qt'? :) Current 'qt' from extra is qt4 indeed. Or did you mean I should add an explicit version requirement?

bjorn commented on 2013-03-01 21:53 (UTC)

mshade, I'll try to remember to try it, when you fix the dependency to be qt4. :-)

mshade commented on 2012-12-11 20:04 (UTC)

bjorn, interesting. that may be an optional dependency, as I do not have it and used this same PKGBUILD. Can you try rebuilding since you have uninstalled libdbusmenu-qt?

bjorn commented on 2012-12-11 20:00 (UTC)

Seems to miss the dependency libdbusmenu-qt. Won't run without it for me: quasselclient: error while loading shared libraries: cannot open shared object file: No such file or directory (I had the library installed when I built this package)

mshade commented on 2012-12-09 15:25 (UTC)

Love it! Thanks.

vesath commented on 2010-04-21 08:49 (UTC)

Upgrade to 0.6.1 (thanks for the prompt notification). Works for me, but feedback is welcome.