Package Details: quaternion 0.0.9.5-3

Git Clone URL: https://aur.archlinux.org/quaternion.git (read-only, click to copy)
Package Base: quaternion
Description: Qt5-based IM client for the Matrix protocol
Upstream URL: https://matrix.org/docs/projects/client/quaternion.html
Licenses: GPL3
Conflicts: quaternion-git
Provides: quaternion
Submitter: PureTryOut
Maintainer: aa13q
Last Packager: aa13q
Votes: 22
Popularity: 0.96
First Submitted: 2016-09-12 17:12
Last Updated: 2020-11-20 18:52

Latest Comments

« First ‹ Previous 1 2

akstrfn commented on 2019-01-27 14:48

Does not look like those are required by upstream. Can you try updated package?

hcra commented on 2019-01-26 21:52

Please add qt5-quickcontrols and qt5-quickcontrols2 to dependencies. Without these packages quaternion don't display any messages.

JCaesar commented on 2018-10-22 11:00

Seems to be missing qt5-quickcontrols as a runtime dependency. I got log output like:

Rendering QML with QQuickView
qrc:/qml/Timeline.qml:2:1: module "QtQuick.Controls" is not installed
qrc:/qml/Timeline.qml:3:1: module "QtQuick.Controls.Styles" is not installed
qrc:/qml/Timeline.qml:2:1: module "QtQuick.Controls" is not installed
qrc:/qml/Timeline.qml:3:1: module "QtQuick.Controls.Styles" is not installed

axionl commented on 2018-10-22 05:12

Missing the qt5-tools qt5ct as depends?

vanyasem commented on 2018-05-06 12:28

If possible, please, post patches to the current PKGBUILD instead of reimplementing everything from scratch in the future. Thank you for your suggestions

E5ten commented on 2018-05-05 10:49

Oh sorry now I realize the person who made the new PKGBUILD is not the maintainer so the .SRCINFO is still correct.

E5ten commented on 2018-05-05 10:46

I made an alternate PKGBUILD I hope you'll consider, I modified it to use a little less hardcoding, and also changed it so that it compiles quaternion using a shared lib that goes in /usr/lib instead of statically linking, I tested and this functions just as well. https://hastebin.com/ogikuhuqex.bash also, I think you need to regenerate your .SRCINFO because the AUR page says the package version is still 0.0.5-3.

0x47 commented on 2018-05-04 23:28

I updated and cleaned up this PKGBUILD (and removed typo 128x1128). In case anyone is interested:

EDIT: Sorry, the formatting is all messed up in the comment, so I created this: https://pastebin.com/Zi5N7QqK

MazeChaZer commented on 2017-10-12 09:28

I can't directly install this package because the .SRCINFO is out of date. pkgrel should be 2, not 1. You can update the .SRCINFO with

$ makepkg --printsrcinfo > .SRCINFO

crisbal commented on 2017-08-08 18:38

Add `cmake` as a build dependency.

I was trying to install this package without having `cmake` installed and the build was failing. Please add `cmake` as a dependency.