Package Details: racket-git 6.6.0.5.37543.0064482-1

Git Clone URL: https://aur.archlinux.org/racket-git.git (read-only)
Package Base: racket-git
Description: Minimal Racket installation, without useless DrRacket, from git
Upstream URL: http://racket-lang.org/
Licenses: LGPL
Conflicts: racket
Provides: racket
Submitter: None
Maintainer: haawda
Last Packager: haawda
Votes: 1
Popularity: 0.002715
First Submitted: 2010-12-10 15:10
Last Updated: 2016-09-26 18:58

Dependencies (3)

Required by (4)

Sources (1)

Latest Comments

carlmax commented on 2014-01-04 03:15

For the 5.3.6 version, please apply this patch on PKGBUILD:

--- PKGBUILD.orig 2010-12-10 23:12:06.000000000 +0800
+++ PKGBUILD 2014-01-04 19:11:46.239900431 +0800
@@ -35,7 +35,7 @@
rm -rf ${_gitname}-build
git clone ${_gitname} ${_gitname}-build

- cd ${srcdir}/${_gitname}-build/src
+ cd ${srcdir}/${_gitname}-build/racket/src

./configure --prefix=/usr
make
@@ -44,9 +44,9 @@

package() {
echo ${PWD}
- cd ${srcdir}/${_gitname}-build/src
+ cd ${srcdir}/${_gitname}-build/racket/src
echo ${PWD}
make DESTDIR="${pkgdir}" install
- install -D -m644 ../collects/icons/plt.xpm "${pkgdir}/usr/share/pixmaps/drracket.xpm"
+ install -D -m644 ../../pkgs/icons/plt.xpm "${pkgdir}/usr/share/pixmaps/drracket.xpm"
# install -D -m644 "${srcdir}/drracket.desktop" "${pkgdir}/usr/share/applications/drracket.desktop"
}

gcr commented on 2011-02-15 20:07

Note that racket 5.1 also requires gtkglext as a dependency for OpenGL to work.