Package Details: regolith-styles 1.6-14

Git Clone URL: https://aur.archlinux.org/regolith-de.git (read-only, click to copy)
Package Base: regolith-de
Description: Regolith's themes for i3, gdm, gtk, rofi, plymouth, etc.
Upstream URL: https://github.com/regolith-linux/regolith-desktop
Licenses: custom: GPLv3
Conflicts: ayu-theme, dracula-gtk-theme, gtk-theme-plano, gtk-theme-plano-git, gtk-theme-solarc-git, moka-icon-theme-git, nordic-theme-git, paper-icon-theme, qogir-icon-theme
Provides: ayu-theme, dracula-gtk-theme, gtk-theme-plano, gtk-theme-solarc, paper-icon-theme, regolith-look, regolith-styles
Submitter: gardotd426
Maintainer: gardotd426
Last Packager: gardotd426
Votes: 5
Popularity: 0.000267
First Submitted: 2021-09-29 15:05 (UTC)
Last Updated: 2023-01-17 09:08 (UTC)

Required by (2)

Sources (53)

Latest Comments

1 2 Next › Last »

gardotd426 commented on 2023-01-17 09:10 (UTC)

@adrs try building again. The sha256sums were already fixed, but I had forgotten to actually push the changes to the AUR.

There's not going to be an update in your package manager, because I'm not going to do a pkgrel bump over a single sha256sum update, but yeah you're good to go now.

adrs commented on 2023-01-14 12:20 (UTC)

Hi, can not update package in Manjaro/i3wm. Error during update from 1.6-13 to 1.6-14. rofitheme.patch ... FAILED ERROR: One or more files did not pass the validity check! Failed to build regolith-de

eclairevoyant commented on 2022-10-21 02:26 (UTC) (edited on 2022-10-21 02:28 (UTC) by eclairevoyant)

members of base-devel (fakeroot, binutils, patch, gcc) should be removed from makedepends. From the Arch wiki:

Note: The group base-devel is assumed to be already installed when building with makepkg. Members of this group should not be included in makedepends array.

python can also be removed, it's redundant when python-appdirs is there - there's no way to have that package present without having python present. Again, from wiki:

In some cases this is not necessary and may or may not be listed, for example glibc cannot be uninstalled as every system needs some C library, or python for a package that already depends on another python- module, as the second module must per definition depend on python and cannot ever stop pulling it in as a dependency.

gardotd426 commented on 2022-07-01 10:53 (UTC)

NOTE ON REGOLITH 2.0: Yes, I know Regolith 2.0 has been released. I've been working on converting the PKGBUILD over to 2.0, but 2.0 basically completely changes the way Regolith works from the ground up on a fundamental level, and many of the packages in 1.6 are gone, there are many new packages that replace them, and most of them are custom-built by Ken (the Regolith creator) himself. I'm going to have to rewrite a couple patches and completely rewrite the PKGBUILD. I'm about 40% done as of July 01 2022. I'll get it done as soon as I can.

gardotd426 commented on 2021-10-01 06:56 (UTC)

@jcstryker You cannot include makedepends for subpackages in a package base. Go ahead and try it yourself.

Anyway, it has to go in the makedepends for the pkgbase. I had it there, but I think I did a git stash before my last push and forgot to re-add it back. It's there now.

jcstryker commented on 2021-10-01 02:11 (UTC)

remontoire/meson.build:1:0: ERROR: Could not execute Vala compiler "valac"

I think you need to include vala in the makedeps for remontoire