Package Details: rmlint-git 2.2.0.r33-1

Git Clone URL: https://aur.archlinux.org/rmlint-git.git (read-only, click to copy)
Package Base: rmlint-git
Description: Tool to remove duplicates and other lint, being much faster than fdupes
Upstream URL: https://github.com/sahib/rmlint
Keywords: cleaner duplicate fast fdupes file finder system
Licenses: GPL3
Conflicts: rmlint
Provides: rmlint
Submitter: SahibBommelig
Maintainer: None
Last Packager: SahibBommelig
Votes: 30
Popularity: 0.000000
First Submitted: 2011-03-27 13:10 (UTC)
Last Updated: 2015-10-13 17:09 (UTC)

Latest Comments

JohnRobson commented on 2016-06-21 21:04 (UTC)

@SahibBommelig, I have both python 2 & 3 installed.

SahibBommelig commented on 2016-06-21 20:26 (UTC)

@JohnRobson: I'm unable to reproduce that. Are you using the testing repos? Is both python2 and python{3,} installed? My gut feeling is that this is likely no problem of the PKGBUILD or rmlint.

JohnRobson commented on 2016-06-19 18:02 (UTC)

==> Starting build()... scons: *** SCons version 2.5.0 does not run under Python version 3.5.1. Python 3 is not yet supported. ==> ERROR: A failure occurred in build(). Aborting... ==> ERROR: Makepkg was unable to build rmlint-git.

karol_007 commented on 2015-10-13 20:07 (UTC)

FYI it's in the repos now: https://lists.archlinux.org/pipermail/aur-general/2015-October/031625.html

SahibBommelig commented on 2015-09-26 23:15 (UTC)

@Brottweiler: This hopefully works again now.

Brottweiler commented on 2015-09-26 21:59 (UTC)

If I build this right now, and install it, and use cower to update (cower -du) then it always downloads rmlint-git again cause it thinks it's been updated.

SahibBommelig commented on 2015-05-10 21:40 (UTC)

Indeed, Im not using [testing]. As long as it works in a normal (i.e. non-[testing]) setup this probably not a bug on my side.

roentgen commented on 2015-05-10 15:21 (UTC)

Looking at the python-sphinx dependencies added in the last few hours as seen at https://projects.archlinux.org/svntogit/community.git/log/trunk?h=packages/python-sphinx it's either you're not using [testing] or the package in [testing] just got fixed.

SahibBommelig commented on 2015-05-10 14:31 (UTC)

Thanks. I tried to build rmlint-git inside a docker container with a fresh up-to-date arch install (with installed base-devel) - which worked well. Im not sure if that's a problem of rmlint-git or if it indicates a broken sphinx installation. It seems to yield that traceback even before it comes to reading my sphinx config. (Im not even using sphinx-rtd). Do other people have the same issue?

roentgen commented on 2015-05-10 14:05 (UTC)

Here is the log: https://paste.kde.org/pvnhwvsdj/gfm9fm/raw

SahibBommelig commented on 2015-05-10 13:05 (UTC)

@roentgen: Can you please pastebin the full log? Those packages should not be needed to just compile rmlint. Don't have an arch machine at hand now though.

roentgen commented on 2015-05-10 12:23 (UTC)

Some additional packages are needed for building (makedepends) pkg_resources.DistributionNotFound: The 'sphinx-rtd-theme<0.2,>=0.1' distribution was not found and is required by Sphinx pkg_resources.DistributionNotFound: The 'alabaster<0.8,>=0.7' distribution was not found and is required by Sphinx pkg_resources.DistributionNotFound: The 'babel>=1.3' distribution was not found and is required by Sphinx pkg_resources.DistributionNotFound: The 'snowballstemmer>=1.1' distribution was not found and is required by Sphinx community/python-sphinx_rtd_theme community/python-sphinx-alabaster-theme community/python-babel community/python-snowballstemmer

jdarnold commented on 2014-12-19 00:09 (UTC)

Looks good - thanks for the speedy response.

SahibBommelig commented on 2014-12-18 21:51 (UTC)

Okay, updated. Testing would be appreciated.

SahibBommelig commented on 2014-12-18 21:31 (UTC)

Hi jdarnold, sorry for the delay and thanks for your PKGBUILD. Will merge it with mine. Just give me a few minutes. :)

jdarnold commented on 2014-12-18 21:28 (UTC)

I created a new PKGBUILD that uses the scons method: http://pastebin.com/DbLApp8M

Brottweiler commented on 2014-12-18 20:40 (UTC)

the git repo just merged the develop branch into master with a lot of changes, this now fails to build. ==> GIT checkout done. make: *** No targets specified and no makefile found. Stop. ==> ERROR: A failure occurred in build(). Aborting...

Brottweiler commented on 2014-06-26 12:24 (UTC)

There are conditions where rmlint segfaults when beeing used, often when it has to do with a lot of files. By compiling with clang instead, it works. So consider adding "export CC=clang" to the PKGBUILD.

SahibBommelig commented on 2013-10-17 17:10 (UTC)

@AndreasBWagner: Thanks, updated.

lowfatcomputing commented on 2013-10-17 13:43 (UTC)

@SahibBommelig, That's because you're using the outdated VCS PKGBUILD format. Here's a PKGBUILD that uses the newer format: http://pastebin.com/WsLNvDzZ

SahibBommelig commented on 2013-09-28 22:09 (UTC)

@AndreasBWagner: git+https:// did not work. I changed it simply to https.

lowfatcomputing commented on 2013-09-27 13:36 (UTC)

You should change git:// to git+https:// so people can install this when the git protocol is blocked. Thanks!

SahibBommelig commented on 2013-04-10 22:01 (UTC)

Thanks SanskritFritz, done.t

SanskritFritz commented on 2013-04-10 21:40 (UTC)

Updated PKGBUILD: http://sprunge.us/gAWJ

menta commented on 2011-04-18 12:14 (UTC)

Please add "provides=('rmlint')" and "conflicts=('rmlint')" to the PKGBUILD. You may also change the "pkgver" field to reflect the date when the PKGBUILD was changed last time.

SahibBommelig commented on 2011-03-27 16:55 (UTC)

Indeed, arch=(any) is wrong, sorry. Changed it to i686/x86_64.. I should read more documentation. Also removed the comment (although I wonder what should be bad here ;-))

commented on 2011-03-27 16:48 (UTC)

arch=(any) is definitely wrong here! And why such a comment for glibc as dependency??