Package Details: ruby-rails 6.1.4.7-1

Git Clone URL: https://aur.archlinux.org/ruby-rails.git (read-only, click to copy)
Package Base: ruby-rails
Description: Full-stack web application framework.
Upstream URL: http://www.rubyonrails.org
Keywords: gem ruby
Licenses: MIT
Submitter: kidoz
Maintainer: Segaja
Last Packager: mehalter
Votes: 90
Popularity: 0.000303
First Submitted: 2010-05-30 22:48 (UTC)
Last Updated: 2022-03-08 21:58 (UTC)

Latest Comments

Segaja commented on 2022-05-09 16:59 (UTC)

@clarfonthey, I know that these packages are ood and I'm already working on a split package for this in the official [community] repo, but this is a lot of work. Especially the testing part of this.

I'm sorry it takes so long, but as I said I'm already working on it.

clarfonthey commented on 2022-05-07 19:40 (UTC) (edited on 2022-05-07 20:07 (UTC) by clarfonthey)

I marked this package and multiple of its dependencies as out of date, since Rails 7 is now released.

Personally, I think that this package should be made into a split package that provides each of its various dependencies (ruby-activerecord, etc.) since they all require downloading the Rails code to build, and ultimately, they all will need to be installed together anyway. Users will still have the option to partially install the packages once their built, but there really isn't much of a need to download the same source multiple times to build each package.

There's also ruby-activesupport, which is in community, which I would also consider as something that should be part of this package. I've been particularly having trouble upgrading the AUR packages for Rails without updating that one.

kyurejl commented on 2022-04-06 17:56 (UTC)

error: packages failed to build: ruby-railties-6.1.4.1-2 ruby-actionview-6.1.4.1-4 ruby-activerecord-6.1.4.1-2 ruby-actionmailer-6.1.4.1-1 ruby-sprockets-rails-3.4.1-1 ruby-actioncable-6.1.4.1-1 ruby-rails-6.1.4.7-1 ruby-activemodel-6.1.4.1-2 ruby-actionpack-6.1.4.1-4

Segaja commented on 2022-03-10 18:38 (UTC)

@linuxninja, you can install ruby-activemodel by installing it the first time without check() calls, as ruby-rails is only a checkdepends for that package.

Afterwards you can install ruby-rails.

At the end you can then reinstall ruby-activemodel normally to get the checks run once.

@mehalter, you might want to check the dependency list for this package sure to use depends, makedeepnds, checkdepends properly. I doubt this package needs all these dependencies at runtime.

linuxninja commented on 2022-03-10 03:59 (UTC)

Looks like we have an AUR circular dependency:

ruby-rails has a dependency on ruby-activemodel ruby-activemodel has a dependency on ruby-rails

Neither can be installed as each depends on the other.

Segaja commented on 2021-11-28 17:07 (UTC)

This package is missing the dependency to https://aur.archlinux.org/packages/ruby-actioncable/ according to the https://rubygems.org/gems/rails dependencies list.

Once my orphaned request on ruby-actioncable gets through i will update this to 6.1.4.1

Segaja commented on 2021-08-22 20:09 (UTC)

@mehalter no worries. I know updating ruby packages can take time.

If any of my packages give you trouble please let me know and I'm sure we can figure something out. I'm also available on IRC if needed.

mehalter commented on 2021-08-22 19:44 (UTC)

@Segaja sorry for the late reply and update! I have been running into some issues with dependency resolution while building the new PKGBUILD and want to make sure that it builds correctly. I will get a release out today!

Segaja commented on 2021-08-20 19:33 (UTC)

Can we please get an update of this package? Without this package up-to-date other packages can't be updated.

mehalter commented on 2019-12-16 19:44 (UTC)

@PedroHLC this is an active issue with the ruby-sprockets package and the ruby-i8n package which are dependencies of ruby-sprockets-rails and ruby-activesupport respectively. the ruby-concurrent-ruby package has been removed from the AUR and is now named ruby-concurrent in the community repos. There's nothing I can do on my end to fix these issues sadly, but definitely keep pinging the maintainers of the ruby-sprockets and ruby-i8n packages to try and get them to fix their stuff. Sadly without that I can fix anything here :(

PedroHLC commented on 2019-12-16 15:48 (UTC)

:: unable to satisfy dependency 'ruby-concurrent-ruby' required by ruby-sprockets :: unable to satisfy dependency 'ruby-sprockets' required by ruby-sprockets-rail

currently missing this deps

a-wing commented on 2019-01-26 05:28 (UTC) (edited on 2019-01-26 05:28 (UTC) by a-wing)

For ruby 2.6.0

Merge RubyGems 3.0.1. The --ri and --rdoc options have been removed. Please use the --document > and --no-document options instead.

https://www.ruby-lang.org/en/news/2018/12/25/ruby-2-6-0-released/

Nefas commented on 2016-06-25 16:53 (UTC)

There are missing dependencies : - mini_portile 0.6 (mini_portile dependency installed with rails is too new) - rails-dom-testing >= 1.0.5 ~> 1.0 Rails won't work without those packages: every command end with a missing gem error I know it's easy to install them with `gem install` but this dependencies should be in ruby-rails dependencies.

a1ro commented on 2016-06-07 13:34 (UTC)

To resolve basic gem dependencies for Rails, you could also type the following: gem install mini_portile -v 0.6.2 gem install rails-dom-testing -v 1.0.7 After this, 'rails --version' and 'rails new project_name' both work fine on my side.

anatolik commented on 2016-05-07 14:02 (UTC)

Try 'ruby-rails' from Quarry repository.

winnie_o0 commented on 2016-05-07 11:17 (UTC)

Dependencies missing/are wrong: - Mini_portfile version is too new. There's an AUR-Package "ruby-mini_portile0.6" to solve that. - rails-dom-testing is missing. Without fixing those, "rails new $projectname" will not succeed.

ewtoombs commented on 2016-03-08 03:45 (UTC)

This package requires the html-sanitizer gem (currently unavailable from the aur) to work. The whole thing is currently broken as a result.

yan12125 commented on 2015-11-14 20:08 (UTC)

Hello @mgrabovsky, can you add --no-ri --no-rdoc due to [1] and [2]? [1] https://github.com/rails/rails/issues/11814 [2] https://github.com/rdoc/rdoc/issues/361

rumpelsepp commented on 2013-03-14 17:25 (UTC)

3.2.12. is out. http://weblog.rubyonrails.org/2013/2/11/SEC-ANN-Rails-3-2-12-3-1-11-and-2-3-17-have-been-released/

xyproto commented on 2013-01-11 10:32 (UTC)

Thanks!

kidoz commented on 2013-01-09 17:59 (UTC)

@xyproto Update

xyproto commented on 2013-01-09 13:44 (UTC)

2.3.15 is out according to this article: http://arstechnica.com/security/2013/01/extremely-crtical-ruby-on-rails-bug-threatens-more-than-200000-sites/

solsticedhiver commented on 2012-03-16 19:03 (UTC)

Please remove that horrible 'Is' at the beggining of the pkgdesc

cgirard commented on 2012-02-29 20:04 (UTC)

That was quick. Thx.

kidoz commented on 2012-02-29 20:01 (UTC)

Fix

cgirard commented on 2012-02-29 19:51 (UTC)

actionpack has runtime dependency: sprockets ~> 2.1.2 You provide 2.3.0 which is too new.

kidoz commented on 2012-01-22 12:22 (UTC)

@eagletmt Done.

eagletmt commented on 2012-01-17 05:21 (UTC)

Please provide with pkgver like this: provides=("ruby-actionmailer=${_actionmailer_pkgver}" ...)

slopjong commented on 2012-01-07 13:45 (UTC)

Installation failed because of: "No such file or directory - /tmp/yaourt-tmp/aur-rails/pkg/usr/bin" I'm using rubygems 1.3.7, the lowest version that redmine requires.

td123 commented on 2011-08-17 02:46 (UTC)

http://www.ruby-forum.com/topic/2373312 3.0.10 is out

kidoz commented on 2010-10-28 10:38 (UTC)

Created for 3.0.1 - ruby-rails-aio, self-contained for quick and easy installation.

kidoz commented on 2010-09-03 04:42 (UTC)

Created for 3.0.0 - ruby-rails, with dependencies. Created for 2.3.8 - ruby-rails2xx, with dependencies. Created for 3.0.0 - ruby-rails-aio, self-contained for quick and easy installation Created for 2.3.8 - ruby-rails2xx-aio, self-contained for quick and easy installation.

kidoz commented on 2010-09-03 04:37 (UTC)

For simple and fast install.

kidoz commented on 2010-09-03 04:01 (UTC)

Created for 2.3.8 - ruby-rails2xx-aio, self-contained for quick and easy installation.

kidoz commented on 2010-09-02 21:45 (UTC)

Created for 2.3.8 - ruby-rails2xx, also corrected all the dependencies. All advise to use ruby-rails2xx. The dependence of the ruby-sqlite3 do?