Package Details: sabnzbd 3.2.1-1

Git Clone URL: https://aur.archlinux.org/sabnzbd.git (read-only, click to copy)
Package Base: sabnzbd
Description: A web-interface based binary newsgrabber with NZB file support
Upstream URL: http://www.sabnzbd.org
Keywords: network usenet
Licenses: GPL
Submitter: kvasthval
Maintainer: Revelation60 (fryfrog)
Last Packager: fryfrog
Votes: 260
Popularity: 0.24
First Submitted: 2007-11-09 16:21
Last Updated: 2021-03-31 14:01

Pinned Comments

fryfrog commented on 2020-08-01 15:19

The sabnzbd 3.0.0 release is python3, yay! I've also moved the install from /opt to /usr/lib/sabnzbd and /var/lib/sabnzbd. The .install file should move things around as needed, but please post if it doesn't.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

fryfrog commented on 2020-08-20 05:24

@martinm1000: I'd do some general searching / troubleshooting, maybe check github issues or /r/sabnzbd. Could be an issue w/ the 3.x update or your own setup or who knows what.

martinm1000 commented on 2020-08-20 03:44

I'm having errors with 3.0.1 (ENGINE Error in HTTPServer.tick, RuntimeError: dictionary changed size during iteration) displayed in the web UI, but it appears to still work ok.

fryfrog commented on 2020-08-19 16:07

@greencopper: Can you give some useful details? What version did you upgrade from and to? The sabnzbd.ini file in /var/lib/sabnzbd is included in the backup= directive. The .install file copies from /opt and renames the left over file in /opt. And says when it does that. Can you show an ls -alh of /opt/sabnzbd and /var/lib/sabnzbd and can you show the output of your upgrade?

greencopper commented on 2020-08-19 11:05

Aargh, what just happened with the latest update!? All settings are gone, even the backup file is wiped!

fryfrog commented on 2020-08-17 23:00

I'm terrible at https stuff, I find it easier to just to it once on an nginx reverse proxy and not bother w/ it anywhere else.

Orionis commented on 2020-08-17 22:57

No, I sort of found my issue. It took my sabnazbd.ini file, renamed it to sabnzbd.ini.pacsave and then used a clean unconfigured setup in /var/lib instead. Once I replaced that with the "old" configuration, it started working. Sort of. I think I need to regenerate my SSL certificate: "SSL: TLSV1_ALERT_UNKNOWN_CA" plus a certificate error in the browser. No clue how to though.

fryfrog commented on 2020-08-17 22:37

The error @tixetsal is talking about is from something in sabnzbd that they need to fix. Is that the error you're seeing? If so, it shouldn't be causing problems.

Orionis commented on 2020-08-17 22:25

I get the same error. The process is running, but I get no web page. I manually installed pyopenssl since I was running python2-pyopenssl before and used SSL. I forgot to stop sabnzbd before the upgrade and got a warning about it to run usermod manually, which I did. I noticed it used my existing sabnzbd.ini which is version 19. I am no Linux sysadmin like @tixetsal so I have very little idea what to do now.

fryfrog commented on 2020-08-14 02:38

@tixetsal: Is it working, even with the error?

tixetsal commented on 2020-08-14 02:30

Seems like I am experiencing this bug, after running back through my config and setup multiple times to confirm: https://github.com/sabnzbd/sabnzbd/issues/1572

This started after another, related package was updated, so I suspect others are getting this in the console but not yet noticing. ?

ETA: It is working, despite the error...

Thanks as always, fryfrog. Appreciate the time and effort you put into your packages.