Package Details: savage2 2.1.0.8-1

Git Clone URL: https://aur.archlinux.org/savage2.git (read-only)
Package Base: savage2
Description: Savage 2: A Tortured Soul is an fantasy themed online multiplayer team-based FPS/RTS/RPG hybrid. Completely free as of December 2008.
Upstream URL: http://savage2.com/
Licenses: custom: "Savage 2"
Submitter: Tjuh
Maintainer: Slash
Last Packager: Slash
Votes: 65
Popularity: 0.001406
First Submitted: 2008-07-14 15:10
Last Updated: 2015-06-08 17:51

Pinned Comments

Slash commented on 2016-03-21 03:54

The Savage2 installer files are missing from the official s2games.com server.

You'll need to manually download the appropriate .run file from one of the "Off Site HTTP Downloads" mirrors manually before attempting to build this package:

http://savage2.com/en/download.php

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

Fandekasp commented on 2012-08-20 09:46

Btw Slash (thinking about it as I saw the upgrade today), there is something wrong with your sh script.

Please modify l.21 of savage2.sh to:
export LD_LIBRARY_PATH="$(pwd):$(pwd)/libs:$(pwd)/game:$LD_LIBRARY_PATH"


I had a big headache figuring out why I couldn't run savage2 with bumblebee and optirun because of that line (OpenGL versions are differents depending on the graphic card driver).
Thanks !

Fandekasp commented on 2012-08-20 09:45

Btw Slash (thinking about it as I saw the upgrade today), there is something wrong with your sh script.

Please modify l.21 of savage2.sh to:
export LD_LIBRARY_PATH="$(pwd):$(pwd)/libs:$(pwd)/game:$LD_LIBRARY_PATH"


I had a big headache figuring out why I couldn't run savage2 with bumblebee and optirun because of that line (OpenGL versions are differents depending on the graphic card driver).
Thanks !

Fandekasp commented on 2012-08-20 09:45

Btw Slash (thinking about it as I saw the upgrade today), there is something wrong with your sh script.

Please modify l.21 of savage2.sh to:
export LD_LIBRARY_PATH="$(pwd):$(pwd)/libs:$(pwd)/game:$LD_LIBRARY_PATH"


I had a big headache figuring out why I couldn't run savage2 with bumblebee and optirun because of that line (OpenGL versions are differents depending on the graphic card driver).
Thanks !

Anonymous comment on 2012-08-11 08:26

Maybe you could update it to the new installers as well please?
http://savage2.s2games.com/downloads/Savage2-2.1.0.7-linux-installer.run
http://savage2.s2games.com/downloads/Savage2-2.1.0.7-linux-x64-installer.run

Fandekasp commented on 2012-08-11 07:18

md5sum is out-of-date, can you update it ? Thanks


==> Validating source files with md5sums...
Savage2-2.1.0.5-linux-x64-installer.run ... FAILED
savage2.launcher ... Passed
savage2.desktop ... Passed
s2editor.desktop ... Passed
s2mviewer.desktop ... Passed
==> ERROR: One or more files did not pass the validity check!

vasily commented on 2012-03-18 08:36

I'm running 64-bit Arch with Gallium Radeon drivers and I get an (popular) error - "Savage2 - Fatal Error: OpenGL 2.0 not available.".
It is fixed by renaming /opt/savage2/libs/libstdc++.so.6 to something else, so the system library is used.

http://kdekorte.blogspot.com/2011/08/savage2-and-heros-of-newerth-on-fedora.html

May consider putting the workaround in the PKGBUILD.

taimon commented on 2012-03-16 20:17

I think some of the libs in /opt/savage2/libs should be removed, because they take preference over the system libs.
I needed to mv -t ../libs.bak libfreetype.so.6 libstdc++.so.6 libgcc_s.so.1 libspeex* libcurl.so.4, otherwise I only got a fatal error. I'm not sure if all are necessary.

Thanks for packaging!

Anonymous comment on 2012-03-04 11:56

Works great with pacman -U
Thank you Slash ;)

Slash commented on 2012-03-03 21:04

Updated again. If it doesn't install, try without yaourt please.

Anonymous comment on 2012-03-02 23:01

Hi please fix you error for install
yaourt savage2
arch i386 gnome

==> Checking source files using md5sums...
Savage2-2.1.0.5-linux-installer.run ... passed
savage2.launcher ... passed
savage2.desktop ... passed
s2editor.desktop ... passed
s2mviewer.desktop ... passed
==> Extracting source files ...
==> I place fakeroot environment ...
==> Start build()...
There has been an error.
Error copying file
rm: can not be removed `/tmp/yaourt-tmp-valsin/aur-savage2/pkg/opt/savage2/rollbackBackupDirectory/*': There is no such file or directory
==> ERROR: Error occurred in build().
Ongoing disturbance...
==> ERROR: Makepkg was unable to build savage2.
==> Restart building savage2 ? [y/N]
==> --------------------------------
==> n

I need your help please. Thx for answer...