Package Details: sfgui-git 0.2.3.r33.g6f4a009-1

Git Clone URL: https://aur.archlinux.org/sfgui-git.git (read-only)
Package Base: sfgui-git
Description: SFGUI (Simple and Fast Graphical User Interface), a C++ GUI library for SFML.
Upstream URL: http://sfgui.sfml-dev.org/
Licenses: zlib
Conflicts: sfgui
Provides: sfgui
Replaces: sfgui
Submitter: linkmauve
Maintainer: oi_wtf
Last Packager: oi_wtf
Votes: 6
Popularity: 0.441836
First Submitted: 2012-08-31 06:12
Last Updated: 2015-06-21 20:02

Dependencies (3)

Required by (0)

Sources (2)

Latest Comments

mnemotic commented on 2013-11-30 08:49

Looking at http://sfgui.sfml-dev.de/download/, it seems that this project is now officially hosted on GitHub. Could you update gitroot to point at https://github.com/TankOs/SFGUI.git?

gyscos commented on 2012-11-03 07:13

Indeed, after testing, I can confirm 2.0rc1 is too old (still uses sf::Keyboard::Back, among other things).
I tried the sfml-git package from the aur, and this times it seems to work fine ; I was just a little confused by the "unable to find sfml>=2.0".
Sorry I bothered you... ><

linkmauve commented on 2012-11-02 20:56

I wonder which would be the best way to solve that issue, I can put >1.99 as the required version, or >=2.0a1, but I’m pretty sure it won’t work with such an old version of SFML.

gyscos commented on 2012-11-02 17:07

I have sfml-2.0rc1-3 from the community repository, but apparently 2.0rc1-3 < 2.0, and the dependencies is therefore not resolved.
SFML 2.0 isn't released yet, so I guess the dependency was actually referring to any RC version of sfml-2... Could the pkgbuild be updated to reflect that ?
Thanks !