Package Details: slic3r-git a-20

Git Clone URL: https://aur.archlinux.org/slic3r-git.git (read-only, click to copy)
Package Base: slic3r-git
Description: Slic3r is an STL-to-GCODE translator for RepRap 3D printers, aiming to be a modern and fast alternative to Skeinforge.
Upstream URL: http://slic3r.org/
Licenses: GPL
Conflicts: slic3r, slic3r-xs, slic3r-xs-git
Provides: slic3r, slic3r-xs, slic3r-xs-git
Submitter: swiftgeek
Maintainer: swiftgeek (nickoe)
Last Packager: swiftgeek
Votes: 21
Popularity: 0.006672
First Submitted: 2012-06-23 10:45
Last Updated: 2019-09-13 15:28

Dependencies (27)

Required by (2)

Sources (3)

Pinned Comments

swiftgeek commented on 2016-04-19 00:37

If something breaks on PKGBUILD side, please bother me directly on freenode (usually available at #slic3r) XS compilation requires more than 512MiB of installed RAM, adding same amount of swap makes it build (tested on armv7h, Allwinner A13)

Perl update guide: https://lists.archlinux.org/pipermail/arch-dev-public/2015-June/027236.html

or since 5.26:

pacman -Qqo '/usr/lib/perl5/5.26' where 5.26 is OLD version of perl

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

swiftgeek commented on 2014-06-20 22:55

Here is my train of thoughts:
https://gist.github.com/swiftgeek/4c673a28060109bcdd69
Soon™ patch or merge with master depending on compatibility of this solution with older perl (remember it has to work with 5.14 too!)
Works with 5.20 and master, now i'm going to sleep cursing haskell version-dependency hell :]
EDIT: passes all tests fine but segfaults at startup o.O

Ayehow commented on 2014-06-17 22:28

prove is not in PATH, please modify check() to call /usr/bin/core_perl/prove .

Even after fixing that, all test fail on "Can't locate XXX.pm in @INC". I have zero perl knowledge - is this a real module or some kind of forgotten placeholder?
Edit: after skipping tests and installing, the slic3r.pl fails with the same error.

Ayehow commented on 2014-06-17 22:19

prove is not in PATH, please modify check() to call /usr/bin/core_perl/prove .

Even after fixing that, all test fail on "Can't locate XXX.pm in @INC". I have zero perl knowledge - is this a real module or some kind of forgotten placeholder?

swiftgeek commented on 2014-06-13 18:41

That's not compilation, but optional tests (great if all good, but most of the time tests itself are broken) -.-

But produced binaries will fail on generating gcode anyway (now only)
same thing has to be changed in slic3r codebase as in latest perl-math-clipper
If You have any skills with perl - You can easily patch it
(don't expect maintainer to fix upstream codebase)

o1ivier commented on 2014-06-13 17:50

I am not able to compile. The check fails, I do not understand why...All dependances (and perl packages) has been reinstalled since 5.20 log: http://pastebin.com/UfBjeC66

swiftgeek commented on 2014-06-10 20:55

perl-boost-geometry-utils is not needed anymore, also it wont work on perl 5.20
Finally optdepends are visible in aur ;)

swiftgeek commented on 2014-06-05 15:59

But perl-boost-geometry-utils is still not ready for perl 5.20 (upstream issue, similar to perl-math-clipper last update)

swiftgeek commented on 2014-06-05 14:48

About perl upgrade:
pacman -Qsqm "^perl-" | tr '\n' ' '
Recompile until everything from list is fine ^^

swiftgeek commented on 2014-01-09 13:55

Changing default branch from master to stable as master doesn't pass tests lately (and most probably it will stay this way)

swiftgeek commented on 2013-12-23 16:15

Rewrite to overkill git dl (vaguely following VCS guidelines) in progress. Will allow for optional manual/predefined select of branch/tag/commit , so eg. if You want to just have latest fixes for last release - You can just configure it to stable branch and use changeling script + cron to force update during next (so after cron job is executed) `yaourt -Syua` or similar