Package Details: sogo2 2.3.23-1

Git Clone URL: https://aur.archlinux.org/sogo2.git (read-only, click to copy)
Package Base: sogo2
Description: groupware server built around OpenGroupware.org (OGo) and the SOPE application server
Upstream URL: http://www.sogo.nu/
Licenses: GPL
Conflicts: sogo, sogo-openchange, sogo2-openchange
Provides: sogo-activsync, sogo2-activesync
Replaces: sogo-activesync, sogo2-activesync
Submitter: DJ_L
Maintainer: deons
Last Packager: deons
Votes: 14
Popularity: 0.000000
First Submitted: 2016-04-26 03:48 (UTC)
Last Updated: 2018-01-21 02:12 (UTC)

Dependencies (18)

Required by (0)

Sources (4)

Latest Comments

DJ_L commented on 2016-08-06 06:14 (UTC)

GNUStep-Make has been fixed, bumped release to remove unneeded GNUSTEP_SYSTEM_ADMIN_TOOLS parameter.

DJ_L commented on 2016-07-23 21:51 (UTC)

Okay, so gnustep-make-2.6.8-1 is broken. So was gnustep-make-2.6.7-1, but it happened to work with this package. The quick fix is: # sed 's@/usr/sbin@/usr/bin@' -i.bak /usr/GNUstep/GNUstep.conf I've created a bug (with patch) for the package at https://bugs.archlinux.org/task/50135

nightah commented on 2016-06-13 07:38 (UTC)

Yeah no problems, I'm in no rush just giving a heads up :).

DJ_L commented on 2016-06-13 06:39 (UTC)

Sorry, been really busy with LFS. No major breakage reported with latest version of 2.x yet (2.3.12). It is most likely just bump version, update sums, and build. It has been that simple for the past couple of updates for both 2.x and 3.x. Give me a day or two more to get to it.

DJ_L commented on 2016-05-19 03:33 (UTC)

Updated to SOGo-2.3.11.

DJ_L commented on 2016-04-23 18:29 (UTC) (edited on 2016-04-23 18:31 (UTC) by DJ_L)

I'm recommending removal of sogo-openchange and OpenChange at this point. With ActiveSync support built into sogo, the inability of OpenChange devs to find a working solution with Samba devs, and EWS needed only for a 6 year old version of Outlook, OpenChange has outlived its usefulness. I'd like to suggest also that this package be renamed sogo2 (same for sope2) so that I don't just rip sogo2 out from under existing users when update comes. As to mober, you will need to allow plain text binds in Samba for it to work at the moment. Add "ldap server require strong auth = no" to the global section of your smb.conf file to work around it for now. In the future, you will need to configure TLS support in Samba (FYI, StartCom at https://www.startssl.com/ has free SAN certificates now), and change your LDAP configuration lines in sogo.conf to the format "ldap://127.0.0.1/????!StartTLS" or "ldpas://..." to fix it correctly. This does not fix Dovecot, however, and I've not figured out StartTLS for Dovecot yet (ldaps should work, but wanted to avoid opening 636 in the Arch wiki articles).

mober commented on 2016-04-18 15:57 (UTC) (edited on 2016-04-18 20:02 (UTC) by mober)

MAPIStoreContext.m:53:23: fatal error: dlinklist.h: No such file or directory Happens with samba 4.4.2-1 and openchange 2.3-6 ### EDIT ### Compiled after downgrading samba to 4.3.6-1. Problem then was, that samba did not start anymore. After re-upgrading samba to 4.4.2-1 samba works again, but sogo seems incompatible with that version (no login to sogo possible, see error below - possibly config issue) sogod : [ERROR] <0x0x5644e6f40ff0[LDAPSource]> Could not bind to the LDAP server ldap://127.0.0.1:389 (389) using the bind DN: cn=ldap,cn=Users,dc=domain,dc=example,dc=com sogod : [ERROR] <0x0x5644e6f40ff0[LDAPSource]> <NSException: 0x5644e6f9e340> NAME:LDAPException REASON:operation bind failed: Strong(er) authentication required (0x8) INFO:{"error_code" = 8; login = "cn=ldap,cn=Users,dc=domain,dc=example,dc=com"; }

DJ_L commented on 2015-11-20 06:58 (UTC)

You'll need to use the git version of openchange for now, or use samba 4.2 and previous version of sogo.

h0rizon commented on 2015-11-13 23:19 (UTC)

Getting the following build errors: http://pastebin.com/JRg0D7Ji

ruthger commented on 2015-09-18 07:29 (UTC)

Version 2.3.2 has been released

DJ_L commented on 2015-09-03 17:19 (UTC)

The archive is located here: https://raw.githubusercontent.com/aur-archive/libwbxml/master/PKGBUILD

DJ_L commented on 2015-09-03 06:17 (UTC)

Should be available in the archive (unless it's in extra now). If not, I'm not in a position to do anything this evening, but I'll adopt it tomorrow night (CDT). Thanks for the heads up.

lunahex commented on 2015-09-03 04:44 (UTC)

libwbxml seems to have gone poof!

DJ_L commented on 2015-07-18 17:29 (UTC)

Note: sogo-openchange and sogo-activesync are merged with the sogo package. When building, use 'makepkg --pkg sogo' if you don't need the others. Failing to provide a package argument is harmless, but it will fail when building the openchange module if openchange in not installed. This 'failure' will still give you a working sogo package ready to install.

DJ_L commented on 2015-06-02 07:12 (UTC)

Also, any interest in a split package as opposed to three sogo packages? Figure with aur4 coming, now is the time to clean up packaging if at all possible.

DJ_L commented on 2015-06-02 07:07 (UTC)

SOGo-2.3.0 is released. Openchange plugin needs OC-2.3, which needs samba-4.2.2. kwirkie, any chance of adding the default apache config file and backup line below? kvtb, yes, it would install the apache config file unconditionally. It would be unused on your system, but covers more use cases. I'm not very familiar with nginx, but if they have an include directive, I'd also like to see a default vhost config file for nginx as well as it covers the generic use case for more users. I'd probably never use it, though with sogo-activesync and it's additional processes, I'd suspect that nginx preforms much better in this role. I'll have to give it a shot.

patelvrajn commented on 2015-05-24 20:49 (UTC)

No longer works with sogo-openchange until it has been updated.

patelvrajn commented on 2015-05-24 20:48 (UTC)

Dependency sogo-2.2.17 no longer exists. Sogo is updated to sogo-2.2.17a-1.

kvtb commented on 2015-04-16 17:40 (UTC)

DJ_L, I'm not using apache, I use nginx. Would your suggestion imply that the apache config file would be installed on my system. Is is possible to *only* install such a file if apache is actually installed?

kvtb commented on 2015-04-16 17:36 (UTC)

Thanks for this package. Small question: in the PKGBUILD, would it be possible to use the pkgver variable in the depends and in the sources to avoid duplication of the sogo version? like depends=(sogo=${pkgver} 'libwbxml') ? Thanks

DJ_L commented on 2015-03-25 06:01 (UTC)

As usual. Development continues. 2.2.17 is out. Looks like a lot of AS fixes. Did you get a chance to review my suggested changes regarding the default Apache config file? Additionally, I've added the logratate configuration too: backup=(etc/sogo/sogo.conf etc/httpd/conf/extra/SOGo.conf) ... install -D -m 0644 ${srcdir}/SOGo-${pkgver}/Apache/SOGo.conf ${pkgdir}/etc/httpd/conf/extra/SOGo.conf ... install -D -m 0644 ${srcdir}/SOGo-${pkgver}/Scripts/logrotate ${pkgdir}/etc/logrotate.d/SOGo HTH

kwirkie commented on 2015-03-06 22:15 (UTC)

Ack...sorry for the delay. Thought I'd already uploaded this. Thanks for heads up DJ_L :-)

DJ_L commented on 2015-01-23 06:02 (UTC)

2.2.14 is out. These guys don't slow down!

DJ_L commented on 2015-01-13 01:31 (UTC)

2.2.13, still straight version and md5 change.

DJ_L commented on 2014-12-18 04:10 (UTC)

AFAIK, straight version update pkgver=2.2.11a depends=('sope=2.2.11' md5sums=('30995a8bb5251a02302fe7161aa14566' Plus suggestion below.

DJ_L commented on 2014-12-16 21:01 (UTC)

It's just using the regular search path. IIUC, it gets loaded via mod_wsgi so you'd have set LD_PRELOAD or LD_LIBRARY_PATH in the apache init script (or fix the library search path some other way (ie: create the so.X.Y link in /usr/lib and run ldconfig)).

tritron commented on 2014-12-16 01:34 (UTC)

Well I accidentally flagged it out of date. Well libSOGo.so.2 in /usr/lib is causing problem it is linked to ../GNUstep/Frameworks/SOGo.framework/Versions/Current/sogo/libSOGo.so.2 it seems to be in /usr/lib/sogo and /usr/lib but it cant be loadeded for some reason. I cp -a ../GNUstep/Frameworks/SOGo.framework/Versions/Current/sogo/lib* /usr/lib/ and that get ocsmanafer started I wonder why is ocsmanager looking for libSOGo.so. in /usr/lib instead /usr/lib/sogo ? I get this error alsp Dec 15 17:32:33 samba [27851]: [ERROR] [so-product-registry] failed to load product Appointments required by SOGoBackend

DJ_L commented on 2014-12-15 20:47 (UTC)

I don't see a new version on sogo.nu. ? As to the error, I don't see this either. I've got it running live. Did the sope and sogo package upgrades install correctly? Need a bit more info to figure out what is wrong. What is the result of ldd on libSOGo.so.2?

tritron commented on 2014-12-15 18:38 (UTC)

I am getting Unable to open /usr/lib/mapistore_backends/libMAPIStoreSOGo.so: libSOGo.so.2: cannot open shared object file: No such file or direc Dec 13 10:52:05 zafire paster[4068]: Unable to open /usr/lib/mapistore_backends/libMAPIStoreSOGo.so.1.0.0: libSOGo.so.2: cannot open shared object file: No such file or Dec 13 10:52:05 zafire paster[4068]: Unable to open /usr/lib/mapistore_backends/libMAPIStoreSOGo.so.1: libSOGo.so.2: cannot open shared object file: No such file I think you need to install libs in /usr/lib/sogo after moving to sogo folder I get this params.c:pm_process() - Processing configuration file "/etc/samba/smb.conf" Dec 15 11:24:55 zafire paster[5250]: [mapistore_init:87]: Storage backend initialization failed

DJ_L commented on 2014-11-23 19:28 (UTC)

kwirkie, how much trouble would it be to add the default apache configuration to the package? Basically it amounts to: ... -backup=(etc/sogo/sogo.conf) +backup=(etc/sogo/sogo.conf etc/httpd/conf/extra/SOGo.conf) ... package() { ... +install -D -m 0600 "${srcdir}"/SOGo-${pkgver}/Apache/SOGo.conf "${pkgdir}"/etc/httpd/conf/extra/SOGo.conf } ... Thanks.

kwirkie commented on 2014-10-11 11:58 (UTC)

ochi - The packges did include the tmpfiles.d file for creating the directory, but you need to run this manually when first installing, as was only created on boot. However, with the latest package, the service file to use the systemd service "RuntimeDirectory" (http://www.freedesktop.org/software/systemd/man/systemd.exec.html#RuntimeDirectory=) option, so people shouldn't have any issues now. ☺

ochi commented on 2014-10-08 19:37 (UTC)

When trying to start a freshly installed sogo 2.2.7, it tells me that the pid file /var/run/sogo/sogo.pid doesn't exist: > systemctl status -l sogo ... sogod[5551] File NSData.m: 1440. In -[NSData writeToFile:options:error:] Open (/var/run/sogo/sogo.pid) failed - No such file or directory sogod [5551]: [ERROR] <0x0x7f86594a9fb0[NSUserDefaults]> unable to open pid file: /var/run/sogo/sogo.pid Indeed this file doesn't exist. Creating a directory /var/run/sogo and chowning it to sogo:sogo seems to work, but shouldn't the package or service deal with this somehow?

francoism commented on 2014-03-25 14:54 (UTC)

v2.2.2 released. :)

DJ_L commented on 2013-12-15 06:06 (UTC)

FYI, working flawlessly now. Thanks!

kwirkie commented on 2013-11-30 12:27 (UTC)

Updated with path to resolve Mailer issue. Patch taken from pointers from http://www.sogo.nu/bugs/view.php?id=2523

DJ_L commented on 2013-11-28 07:03 (UTC)

Yes, seeing the same problem with all since 2.0.7....2.1.0, 2.1.1, 2.1.1a. There was a promising commit just prior to 2.1.1a release, but not fixed completely. I'm holding at 2.0.7 now as this makes sogo unusable for me ATM, but will continue digging as I have the time to do so.

kwirkie commented on 2013-11-27 08:14 (UTC)

Updated. I'm having issues with Mailer element functioning again, as per my previous post. Thanks DJ_L for the ideas, but they unfortunately don't resolve the issue…☹

DJ_L commented on 2013-11-03 08:37 (UTC)

Shooting from the hip here as I'm not anywhere near to the point where I can test, but I suspect that the paths are incorrect as stuff was moved around in the source tree. Something like: sed 's@Mailer/SOGoMailBodyPart.h@SoObjects/Mailer/SOGoMailBodyPart.h@' \ -i `grep -Rl "<Mailer/SOGoMailBodyPart.h>"` will probably "fix" the first one if I'm correct. If that works, the real "fix" is to correct the include directories, but I don't know squat about gnustep. I don't see anything obvious on the second message (of course, I don't even know if the first is correct yet). I don't know if "../path/file.h" is valid for #import, but it appears only once in the format <MailPartViewers/UIxMailRenderContext.h> in UI/MailerUI/UIxMailView.m. If '#import "../MailPartViewers/UIxMailRenderContext.h"' is valid syntax, then maybe there. This (ugly, but functional workaround might fix the second): sed -e 's@<MailPartViewers@"../MailPartViewers@' \ -e 's@Context.h>@Context.h"@' \ -i UI/MailerUI/UIxMailView.m I included those changes in the PKGBUILD locally (just before configure) and it builds without error, but again, I'm a couple of days away from testing, and neither are the right way to fix the problem (if that is even the problem). Hopefully that helps rather than hurts.

kwirkie commented on 2013-06-24 18:27 (UTC)

Updated. I'm having issues with Mailer element functioning. Is anyone else on Arch Linux having this issue? http://www.sogo.nu/bugs/view.php?id=2327

zebulon commented on 2013-06-24 13:57 (UTC)

Hi, this needs to be recompiled because of the /usr/sbin removal.

kwirkie commented on 2013-04-11 20:53 (UTC)

FYI with this update I've removed the init scripts. Note that /etc/sogo.conf now takes precedence with this update. Please read http://www.sogo.nu/files/docs/SOGo%20Installation%20Guide.pdf for upgrading instructions.

kwirkie commented on 2013-04-11 20:51 (UTC)

ImNtReal. Sorry, I must have missed your comment... It's important to ensure that the right version of sope is installed, so I'm hesitant to make it >= requirement. I'd recommend updating sope with pacman's "-d" option, as this will ignore dependencies. This avoids having to uninstall/reinstall. pacman -Ud sope-2.0.5-1-x86_64.pkg.tar

ImNtReal commented on 2013-01-28 14:50 (UTC)

Would it be possible to change the sope requirement to >= instead of =, so I don't have to either uninstall/reinstall, or manually modify it to update? Thanks.

kwirkie commented on 2012-11-16 13:47 (UTC)

For those on version 2.0.2, heads up that pacman considers the addition of "a" to the version number to be a downgrade...

kwirkie commented on 2012-10-21 21:32 (UTC)

Added systemd service file and tmpfiles.d conf.

kwirkie commented on 2012-07-16 22:15 (UTC)

Just built 2.0.0rc4 with the latest glibc (2.6.0-2) but had to use the following patch to "configure" due to lib dir reshuffle: http://pastebin.com/xP73uPg5

kwirkie commented on 2012-04-13 22:06 (UTC)

typo: find . -type f -exec sed -i -e 's/sel_eq/sel_isEqual/g' {} +

kwirkie commented on 2012-04-13 22:00 (UTC)

Just built version 2.0.0rc1. Had to apply patch from <http://www.sogo.nu/bugs/view.php?id=1664> (fix_64_Bit_exceptions.diff), and also a quick a dirty fix "find . -type f -exec sed -i -e 's/'s/sel_eq/sel_isEqual/g' {} +" in the SOGO source dir, to fix compatibility with GNUstep 1.24.0 and GCC 4.7.0. I did these by had, but they should probably be added into the PKGBUILD... Hopefully these will all be sorted by the actual v2 release. P.S. malinas, have a look at the online demo <http://www.sogo.nu/tour/online_demo.html>. I personally think that if all your after in mail, contacts and calender, that SOGo is the best groupware out there at the moment. There's a few bugs and features to iron out, but hopefully these will be sorted by the time version 2.0 is released.

malinas commented on 2012-03-10 01:32 (UTC)

Well.. do you like it... do you have *or others* comparisons with various groupware sw?

kwirkie commented on 2012-01-21 21:22 (UTC)

Heads up to anyone using this package, that I needed to rebuild 'gnustep-base'(1.23.0-1) with 'buildflags' disabled in order for sope and sogo to function. I also built sope and sogo with buildflags disabled, but can't confirm it was required.