Package Details: spigot 1.14.2+b101-1

Git Clone URL: https://aur.archlinux.org/spigot.git (read-only)
Package Base: spigot
Description: High performance Minecraft server implementation
Upstream URL: https://www.spigotmc.org/
Keywords: craftbukkit games minecraft minecraft-server
Licenses: LGPL
Conflicts: bukkit, craftbukkit, spigot-patcher
Provides: bukkit=1.14.2, craftbukkit=1.14.2, minecraft-server=1.14.2
Submitter: Schala
Maintainer: edh
Last Packager: edh
Votes: 25
Popularity: 0.237853
First Submitted: 2013-10-09 23:27
Last Updated: 2019-05-29 10:14

Dependencies (11)

Required by (8)

Sources (6)

Latest Comments

1 2 3 4 5 6 ... Next › Last »

mee42 commented on 2019-04-28 17:08

@edh can you update to 1.14 please?

edh commented on 2019-01-14 18:38

@Baconator Could you please elaborate as to what you are proposing?

Baconator commented on 2019-01-14 18:33

Don't think jre6 complies to the rule "java-runtime-headless>=8"

edh commented on 2018-12-13 20:12

@ASzc Updated.

ASzc commented on 2018-12-13 16:53

Upstream news post says build 84 of BuildTools is now required:

https://www.spigotmc.org/threads/buildtools-update-required-1-13-2.351162/

ASzc commented on 2018-12-13 16:47

Getting an error:

**** Your BuildTools is out of date and will not build the requested version. Please grab a new copy from https://www.spigotmc.org/go/buildtools-dl

http://ix.io/1vVL

edh commented on 2018-10-18 14:37

@tealeaf Ok, you convinced me. I will update the package soon. However, note that Arch ships the latest software but not unstable or beta releases by default. IMHO this version lies somewhere in between beta and stable hence my reluctance to update.

tealeaf commented on 2018-10-18 11:56

From my perspective I would say that this is the time to update -- I can't see that this status will ever change. There could always be bugs, and now there has been time for really serious ones to emerge.

I completely supported the delay in that initial testing period, but given that there are now no serious known conversion bugs, I think it's time to move on.

With respect to older plugins, that's a problem that occurs every time the server software is updated. Whilst 1.13 was a huge update, in this sense it's not really that different to other plugin incompatibilities.

It strikes me that as this is the current version, and especially given Arch's tendency towards the bleeding edge, at this point it feels that the onus should be on people seeking stability to hold back their installs, rather than requiring people who want to update to make the extra effort.

Just my opinion!

edh commented on 2018-10-18 11:28

@sflor I am not really sure whether now is the right time to update. To me the statement

Caution (1.13.x - Current): There are no known serious world conversion bugs. Some aspects of older worlds may not function correctly, but all player data remains intact. Native 1.13 plugins should be used, but older plugins will function as well as they are ever likely to. Caution is still advised as there may be undiscovered data loss bugs.

does not really sound reassuring. However, I am more than happy to receive more input from users whether an update is desired.

For now, I would advise you to just bump the pkgver and _build variable manually.

sflor commented on 2018-10-17 21:52

Are you going to update to 1.13 now that they've removed any critical warning?