Package Details: stegosaurus-lv2-git r18.543a95d-1

Git Clone URL: https://aur.archlinux.org/stegosaurus-lv2-git.git (read-only, click to copy)
Package Base: stegosaurus-lv2-git
Description: lv2 drum synthersizer without sampling (patched fork)
Upstream URL: https://github.com/mxmilkiib/stegosaurus
Licenses: GPL
Submitter: milk
Maintainer: milk
Last Packager: milk
Votes: 0
Popularity: 0.000000
First Submitted: 2018-06-30 00:03
Last Updated: 2020-05-11 22:07

Latest Comments

MrAureliusR commented on 2020-11-30 21:46

I am seeing the same linking errors. As this package is part of the lv2 plugins metapackage, this should either be fixed or removed from that package, as it errors out and prevents the other plugins from being added.

codebling commented on 2020-10-01 05:40

I'm seeing multiple linking errors

[16/18] Compiling stegosaurus.ttl.in
[17/18] Linking build/stegosaurus.lv2/stegosaurus.so
[18/18] Linking build/stegosaurus.lv2/stegosaurus_ui.so
/usr/bin/ld: stegosaurus_synth.c.3.o:(.bss+0x0): multiple definition of `stegosaurus_self'; stegosaurus.c.3.o:(.bss+0x0): first defined here
collect2: error: ld returned 1 exit status
/usr/bin/ld: deliriumUI/deliriumUI.c.4.o:(.bss+0x0): multiple definition of `controller'; stegosaurus_ui.c.4.o:(.bss+0x0): first defined here
/usr/bin/ld: deliriumUI/deliriumUI.c.4.o:(.bss+0x8): multiple definition of `write_function'; stegosaurus_ui.c.4.o:(.bss+0x8): first defined here
/usr/bin/ld: deliriumUI/button.c.4.o:(.bss+0x0): multiple definition of `controller'; stegosaurus_ui.c.4.o:(.bss+0x0): first defined here
/usr/bin/ld: deliriumUI/button.c.4.o:(.bss+0x8): multiple definition of `write_function'; stegosaurus_ui.c.4.o:(.bss+0x8): first defined here
/usr/bin/ld: deliriumUI/knob.c.4.o:(.bss+0x0): multiple definition of `controller'; stegosaurus_ui.c.4.o:(.bss+0x0): first defined here
/usr/bin/ld: deliriumUI/knob.c.4.o:(.bss+0x8): multiple definition of `write_function'; stegosaurus_ui.c.4.o:(.bss+0x8): first defined here
/usr/bin/ld: deliriumUI/microknob.c.4.o:(.bss+0x0): multiple definition of `controller'; stegosaurus_ui.c.4.o:(.bss+0x0): first defined here
/usr/bin/ld: deliriumUI/microknob.c.4.o:(.bss+0x8): multiple definition of `write_function'; stegosaurus_ui.c.4.o:(.bss+0x8): first defined here
/usr/bin/ld: deliriumUI/fader.c.4.o:(.bss+0x0): multiple definition of `controller'; stegosaurus_ui.c.4.o:(.bss+0x0): first defined here
/usr/bin/ld: deliriumUI/fader.c.4.o:(.bss+0x8): multiple definition of `write_function'; stegosaurus_ui.c.4.o:(.bss+0x8): first defined here
/usr/bin/ld: deliriumUI/switch.c.4.o:(.bss+0x0): multiple definition of `controller'; stegosaurus_ui.c.4.o:(.bss+0x0): first defined here
/usr/bin/ld: deliriumUI/switch.c.4.o:(.bss+0x8): multiple definition of `write_function'; stegosaurus_ui.c.4.o:(.bss+0x8): first defined here
/usr/bin/ld: deliriumUI/adsr.c.4.o:(.bss+0x0): multiple definition of `controller'; stegosaurus_ui.c.4.o:(.bss+0x0): first defined here
/usr/bin/ld: deliriumUI/adsr.c.4.o:(.bss+0x8): multiple definition of `write_function'; stegosaurus_ui.c.4.o:(.bss+0x8): first defined here
collect2: error: ld returned 1 exit status

milk commented on 2019-11-23 00:26

```
test
```

SpotlightKid commented on 2019-10-11 12:14

Why does this package conflict with itself? Suggestion: remove 'stegosaurus-lv2-git' from provides and conflicts array. Also maybe add 'lv2-plugins' to groups array.