Package Details: subsonic 6.1.5-1

Git Clone URL: https://aur.archlinux.org/subsonic.git (read-only)
Package Base: subsonic
Description: A free, web-based media streamer and jukebox.
Upstream URL: http://subsonic.org/
Licenses: custom
Conflicts: subsonic
Submitter: robertfoster
Maintainer: robertfoster
Last Packager: robertfoster
Votes: 70
Popularity: 0.000008
First Submitted: 2010-03-26 16:48
Last Updated: 2018-12-10 16:36

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

Anonymous comment on 2011-10-15 23:41

I'm not sure if it was the last update or the one before, but sometime somewhat recently Subsonic refuses to index any accented characters (ó, ö, æ, á, ü etc). I have gone to the Subsonic forum and have made sure to set everything to export LOCALE=en_US.utf8 as suggested, but no change. Even having it rebuild the index didn't work. The files show fine in the terminal (The disk is XFS) and the files play fine in mplayer. Not sure if I'm missing something. I know that they used to be there and play fine.
Any ideas? Apologies if this should be posted elsewhere.

trishika commented on 2011-10-06 08:28

The packager don't have to choose the jre implementation unless there is incompatibility ... So the 'java-runtime' meta-package is here for that ! please change jre to java-runtime.

Anonymous comment on 2011-09-19 19:54

Why not make this depend on openjdk6 instead of jre? From subsonic installation's page one might assume (see the different linux installation instructions at http://www.subsonic.org/pages/installation.jsp) that openjdk6 works fine. And openjdk6 is the recommended java implementation in Arch...

Anonymous comment on 2011-08-17 14:29

The new /var/subsonic/subsonic.sh has the JAVA_HOME variable set and so subsonic wasn't starting for me after the upgrade from 4.4 to 4.5. Well, more specifically, the new subsonic.sh was JAVA_HOME variable pointed to /opt/java , but that wasn't correct for my system. I had to change it to /opt/java/jre to get the process to start.

trishika commented on 2011-08-12 05:48

can you change jre to java-runtime ?

Anonymous comment on 2011-08-11 14:10

PKGBUILD for 4.5-1

# Maintainer: M0Rf30 <morf3089@gmail.com>
pkgname=subsonic
pkgver=4.5
pkgrel=1
pkgdesc="Subsonic is a free, web-based media streamer and jukebox."
arch=('i686' 'x86_64')
url="http://subsonic.org/"
license=('GPL')
depends=('jre')
conflicts=('subsonic-beta')
source=(http://prdownloads.sourceforge.net/subsonic/${pkgname}-${pkgver}-standalone.tar.gz
'subsonic'
'subsonic.rc')
backup=('var/subsonic/subsonic.sh')
md5sums=('14335df737219ffb39ba00ee562c92f3'
'43b8000cf7d5beb83bb9d0ca37535b0f'
'fe298af83a38e4e3a794f3be18ca6af6')
install=$pkgname.install

build() {
cd ${srcdir}
mkdir -p $pkgdir/var/subsonic
mkdir -p $pkgdir/usr/bin
mkdir -p $pkgdir/etc/rc.d
cp * $pkgdir/var/subsonic
rm $pkgdir/var/subsonic/{subsonic,subsonic.rc,subsonic.bat,${pkgname}-${pkgver}-standalone.tar.gz}
cp $srcdir/subsonic $pkgdir/usr/bin
cp $srcdir/subsonic.rc $pkgdir/etc/rc.d/subsonic
}

Anonymous comment on 2011-06-13 22:59

is there a way to get this to run as a non-root user?

Anonymous comment on 2011-05-28 01:01

Thanks for this, works fine.
It seemed content with ffmpeg, but I had to symlink lame.
ln -sf /usr/bin/lame /var/subsonic/transcode/lame

Worked great.

risk commented on 2011-05-24 19:16

also, it seems that lame and ffmpeg should be present in $SUBSONIC_HOME/transcode
maybe you could add those symlinks to the package ?

risk commented on 2011-05-24 18:35

missing deps, ffmpeg and lame.