Package Details: torrent-mount 1.0.8-2

Git Clone URL: https://aur.archlinux.org/torrent-mount.git (read-only)
Package Base: torrent-mount
Description: Mount a torrent (or magnet link) as a filesystem in real time using torrent-stream and fuse. AKA MAD SCIENCE!
Upstream URL: https://github.com/mafintosh/torrent-mount
Licenses: MIT
Submitter: petRUShka
Maintainer: petRUShka
Last Packager: petRUShka
Votes: 5
Popularity: 0.000011
First Submitted: 2014-06-28 09:35
Last Updated: 2015-07-01 14:33

Latest Comments

dreieck commented on 2018-11-29 19:54

The PKGBUILD downloads stuff in package()! This is a very bad idea.

Please make sure that, if possible in any way, everything needed to build this package is downloaded via the source-array, and if this is not possible, use as a last resort the prepare()-function.

So that package can be built without the need of an internet connection (makepg -e).

Thanks!

==> Starting package()...
[..................] | fetchMetadata: sill resolveWithNewModule torrent-mount@1.0.8 checking installable status
[...]

bartus commented on 2018-04-14 12:23

@petRUShka: add npm in makedepends array.

shizeeg commented on 2018-04-04 05:17

an update & fix to the PKGBUILD.

https://gist.github.com/shizeeg/5a1b4507191849c9ba24220968afa326

Consider to merge please. Thanks in advance.

renyuneyun commented on 2018-01-17 23:25

The packaing process doesn't produce a valid package now -- /usr/lib/node_modules/torrent_mount is just a symlink (to an invalid directory) now.

Trying add

  rm "${pkgdir}/usr/lib/node_modules/torrent-mount"
  cp -r "${srcdir}/torrent-mount-${pkgver}" "${pkgdir}/usr/lib/node_modules/torrent-mount"

to PKGBUILD fixes this problem, but the program doesn't execute correctly:

module.js:557
    throw err;
    ^

Error: Cannot find module 'fuse4js'
    at Function.Module._resolveFilename (module.js:555:15)
    at Function.Module._load (module.js:482:25)
    at Module.require (module.js:604:17)
    at require (internal/module.js:11:18)
    at Object.<anonymous> (/usr/lib/node_modules/torrent-mount/index.js:1:74)
    at Module._compile (module.js:660:30)
    at Object.Module._extensions..js (module.js:671:10)
    at Module.load (module.js:573:32)
    at tryModuleLoad (module.js:513:12)
    at Function.Module._load (module.js:505:3)

I have no idea how to fix this because I'm not familiar with node.js.

petRUShka commented on 2014-09-21 08:30

Done. Thanks for advice!

patashnik commented on 2014-09-14 16:47

Need add to PKGBUILD

export PYTHON=python2.7

airon90 commented on 2014-09-10 14:57

There are some errors. Maybe it needs a more dependency