Package Details: urxvt-vtwheel 0.3-3

Git Clone URL: https://aur.archlinux.org/urxvt-vtwheel.git (read-only, click to copy)
Package Base: urxvt-vtwheel
Description: Scroll wheel support for urxvt
Upstream URL: https://aur.archlinux.org/
Keywords: rxvt urxvt vtwheel
Licenses: unknown
Submitter: pyropeter
Maintainer: eatmyvenom
Last Packager: TheGoliath
Votes: 58
Popularity: 0.000037
First Submitted: 2011-07-16 15:35 (UTC)
Last Updated: 2020-05-04 14:27 (UTC)

Latest Comments

pyropeter commented on 2013-12-10 14:56 (UTC)

uploaded version 0.3 * includes trygveaas patch sorry it took so long... :-(

ypoluektovich commented on 2013-07-29 09:52 (UTC)

I can confirm that trygveaa's patch works. Pyropeter, please update. Flagging.

trygveaa commented on 2013-06-26 16:05 (UTC)

Uh, ignore the patch in my last comment, that messes up stuff. Use this patch instead: 38a39 > return 1; 40a42 > return 1;

trygveaa commented on 2013-06-22 15:08 (UTC)

Patch to fix the scrolling bug explained by emmanuelux: 43c43 < return (); --- > return 1;

pyropeter commented on 2012-08-29 20:39 (UTC)

@C5OK5Y: I tried to solve that bug in the past, but did not succeed. At some point I just gave up, because the bug really isn't that annoying. I will happily accept any patches.

smp commented on 2012-08-29 19:04 (UTC)

This extension is great! The only problem is the bug emmanuelux mentioned. Could you pleeease try to solve it ;-)? Changing urxvt.secondaryScroll doesn't seem to do anything.

Earnest commented on 2012-03-18 12:42 (UTC)

I've found out the problem was caused due to the "-X" (or --no-init) option for less. Removing that option has returned vtwheel to it's former glory, however I now have the problem of the screen getting cleared. Hopefully I'll break the habit and simply use the keyboard. :P

pyropeter commented on 2012-03-16 18:39 (UTC)

@kaustiq: I just -Syu'ed (i.a. installed xorg-server 1.20.0-1). vtwheel still works fine for me. Have you checked if urxvt really uses the vtwheel extension? Maybe your ~/.Xdefaults file was modified while switching to subtle? (urxvt outputs error messages about missing extensions when it is run in another terminal)

Earnest commented on 2012-03-16 17:50 (UTC)

Recently this extension seems to not respond. I've been using vtwheel for quite some time and recently changed my Window Manager (Subtle). However there was also the recent xorg-server update to 1.12 which I believe to be the culprit (I tried downgrading without success so I couldn't test it). I've also double checked the keycodes in the script and the buttons via xev but I'm without perl knowledge. Is anyone else (hopefully with more brainpower) having similar issues since 1.12? Or, is anyone able to guide me towards a solution? (Using URxvtd and URxvtc (it also fails on URxvt))

pyropeter commented on 2012-03-01 23:41 (UTC)

I can reproduce that, but I have no idea how to fix it. I didn't look into the urxvt source code, though. This bug is annoying, but not annoying enough to make me try really hard to fix it.

commented on 2012-02-14 11:12 (UTC)

hello, i have a strange behavior with vtwheel plugin : for instance if i type in urxvt 1) ls (or others commands to generate scrollback) 2) man db 3) mousewheel up i get 4 or 5 lines up on the screen that should no be displayed strangly it is better with URxvt.secondaryScroll: false but not ok i have read the script and i dont see why there is a problem

pyropeter commented on 2011-08-04 09:37 (UTC)

uploaded version 0.2: * Bugfix: Text selection on secondary buffer failed.

pyropeter commented on 2011-07-16 15:39 (UTC)

uploaded version 0.1