Package Details: v8 5.4.374.1-3

Git Clone URL: (read-only)
Package Base: v8
Description: Fast and modern Javascript engine used in Google Chrome.
Upstream URL:
Keywords: dev engine javascript
Licenses: BSD
Conflicts: v8-3.14, v8-3.15, v8-3.20, v8-5.2
Submitter: anatolik
Maintainer: marcs
Last Packager: marcs
Votes: 7
Popularity: 1.283616
First Submitted: 2015-07-01 16:14
Last Updated: 2016-08-24 12:48

Latest Comments

marcs commented on 2016-08-24 11:47

@MagiCarbon try with v8-5.2 has all the libs now.

MagiCarbon commented on 2016-08-24 04:06

sorry, i was wrong. i've asked the author of php-v8js, he said it does support the latest v8. sorry for all confusion.

and the error below occurred because this package lost '', not the v8 version.

configure: error: could not determine libv8 version

marcs commented on 2016-08-23 20:36

Gyp is deprecated now for building v8, I switched to GN. So I guess compilation should work next time you try.

@MagiCarbon (and others)
Because seems that some people need v8 5.2 for phpjs (But Why ? ;) ) I've added a new package called v8-5.2 which still uses Gyp and it should generate all the libs necessary for phpjs.

r0qs commented on 2016-08-23 15:00

Hi, I'm getting this error during compile:

==> Starting build()...
-> Running gyp...
Updating projects from gyp files...
-> Start building...
ninja: Entering directory `out/Release'
ninja: error: '../../third_party/WebKit/Source/platform/inspector_protocol/DispatcherBase.cpp', needed by 'obj/third_party/WebKit/Source/platform/inspector_protocol/inspector_protocol.DispatcherBase.o', missing and no known rule to make it
==> ERROR: A failure occurred in build().

Anyone knows how to solve?

marcs commented on 2016-08-11 06:41

You can simply clone the package and set pkgver=5.2.361.49.

If that version works with php-v8js you should upload a package with the name:

MagiCarbon commented on 2016-08-11 00:56

thanks for your working.

LOL, php-v8js couldn't recognize this version.

configure: error: could not determine libv8 version

could you plz update the package to the latest chrome-pick(5.2.361.49)?

it maybe a better choice.

marcs commented on 2016-08-10 12:37

In the new version the static library files (like libv8_libplatform.a) are installed in this path: /usr/share/v8/

Let me know if it is necessary to move them to /usr/lib for a package dependency or something like that.

marcs commented on 2016-08-10 09:17

I'll update the package to the latest cherry-pick (5.4.374.1), but first I need to solve some problems with the libraries.

MagiCarbon commented on 2016-08-10 02:04


it says:

# Install libv8_libplatform.a (V8 >= 5.2.51)
echo -e "create /usr/lib/libv8_libplatform.a\naddlib > > out/native/\nsave\nend" | sudo ar -M

therefore, this package should be upgraded to the last release.

stonecold111 commented on 2016-07-06 14:36

I'm unable to install V8JS with this package.

I'm missing a file called libv8_libplatform.a, which isn't in /usr/lib/v8/ to begin with:

sudo pecl install v8js
checking for V8 version...
checking for libv8_libplatform.a... not found
configure: error: Please provide libv8_libplatform.a next to the, see for details
ERROR: `/tmp/pear/temp/v8js/configure --with-php-config=/usr/bin/php-config --with-v8js' failed

Files in /usr/lib/v8:

All comments