Package Details: v8 5.6.178-1

Git Clone URL: https://aur.archlinux.org/v8.git (read-only)
Package Base: v8
Description: Fast and modern Javascript engine used in Google Chrome.
Upstream URL: https://code.google.com/p/v8/
Keywords: dev engine javascript
Licenses: BSD
Conflicts: v8-3.14, v8-3.15, v8-3.20, v8-5.2
Submitter: anatolik
Maintainer: marcs
Last Packager: marcs
Votes: 8
Popularity: 0.686088
First Submitted: 2015-07-01 16:14
Last Updated: 2016-11-01 11:59

Required by (2)

Sources (5)

Latest Comments

marcs commented on 2016-11-01 12:02

Applied dflemstr's patch and added wget as makedep.
Thanks for the patch, feedback is welcome.

dflemstr commented on 2016-10-31 07:00

I have a bunch of patches to this library that do the following:

- Use system ICU instead of bundled ICU
- Enable more optimizations
- Fix pkg-config files to actually be usable

Full changes here: https://gist.github.com/dflemstr/01137016843183420a1c55395e6d1596

Cambi0n commented on 2016-10-14 19:07

wget is a dependency.

It is needed by gclient sync in depot_tools.

void.dargon commented on 2016-09-11 21:01

is it just me or is the not being build libv8_platform.so?
it seems to be missing.

marcs commented on 2016-09-09 08:40

Latest cherry-pick. Fixed missing libv8.so, Switched to host clang.

marcs commented on 2016-09-06 13:50

@dflemstr

Yeah, the docs for GN and V8 are still lacking a bit.

Now I'm using v8-5.2 but I'll have to switch to the latest V8 version very, very soon. So I'll have to work my way through GN. Also testing a build is kinda time consuming I would like to have a 36 cores Xeon beast ;)

dflemstr commented on 2016-09-04 16:15

Hmm... When I build this, it doesn't actually produce a libv8.so file any more, so this line fails:

install -Dm755 out.gn/x64.release/libv8.so $pkgdir/usr/lib/v8/libv8.so

Also, it would be nice to get static libraries being built again but I understand that that's tricky when using GN?

marcs commented on 2016-08-24 11:47

@MagiCarbon try with v8-5.2 has all the libs now.

MagiCarbon commented on 2016-08-24 04:06

sorry, i was wrong. i've asked the author of php-v8js, he said it does support the latest v8. sorry for all confusion.

and the error below occurred because this package lost 'libv8.so', not the v8 version.

configure: error: could not determine libv8 version

marcs commented on 2016-08-23 20:36

@r0qs
Gyp is deprecated now for building v8, I switched to GN. So I guess compilation should work next time you try.

@MagiCarbon (and others)
Because seems that some people need v8 5.2 for phpjs (But Why ? http://i.imgur.com/TnQRX6v.gif ;) ) I've added a new package called v8-5.2 which still uses Gyp and it should generate all the libs necessary for phpjs.

All comments