Package Details: viper4linux-git r55.ec2dcf6-2

Git Clone URL: https://aur.archlinux.org/viper4linux-git.git (read-only)
Package Base: viper4linux-git
Description: Implementation of the libviper library for modern Linux desktops.
Upstream URL: https://github.com/L3vi47h4N/Viper4Linux
Keywords: audio dsp equalizer viperfx
Licenses: GPL
Conflicts: viper4linux
Provides: viper4linux
Submitter: Formed
Maintainer: Formed (yochananmarqos)
Last Packager: yochananmarqos
Votes: 2
Popularity: 0.878149
First Submitted: 2018-09-15 16:51
Last Updated: 2019-06-03 16:03

Dependencies (2)

Required by (2)

Sources (1)

Pinned Comments

yochananmarqos commented on 2019-06-10 22:24

The new dynamic system is merged HOWEVER old audio.conf files do not work with it. You will need to add the new variables to your file. I'd advise the following (stolen/slightly modified from @ThePBone) set the first line to true to enable.

dynsys_enable=false
dynsys_bassgain=2100
dynsys_xcoeff1=140
dynsys_xcoeff2=6200
dynsys_ycoeff1=40
dynsys_ycoeff2=60
dynsys_sidegain1=10
dynsys_sidegain2=80

Latest Comments

1 2 3 Next › Last »

lucenera commented on 2019-06-11 06:52

Now I explain the movie: I updated the previously installed version. The result was a dependency error, in fact, even if not specified, gst-plugin-viper4linux must be reinstalled for the name difference or the name of the dependency must be changed in viper4linux PKGBUILD. Once this is done, I get this error on startup: WARNING: erroneous pipeline: could not set property "dynsys-enable" in element "viperfx0" to "dynsys-ycoeff1 =" I receive it even if I install viper4linux from scratch, then with the new audio.conf file, which already contains the new options set. dynsys_enable is set on 'true'

yochananmarqos commented on 2019-06-10 22:25

@lucerna: See the pinned comment.

yochananmarqos commented on 2019-06-10 22:24

The new dynamic system is merged HOWEVER old audio.conf files do not work with it. You will need to add the new variables to your file. I'd advise the following (stolen/slightly modified from @ThePBone) set the first line to true to enable.

dynsys_enable=false
dynsys_bassgain=2100
dynsys_xcoeff1=140
dynsys_xcoeff2=6200
dynsys_ycoeff1=40
dynsys_ycoeff2=60
dynsys_sidegain1=10
dynsys_sidegain2=80

lucenera commented on 2019-06-10 21:24

WARNING: erroneous pipeline: could not set property "dynsys-enable" in element "viperfx0" to "dynsys-ycoeff1="

yochananmarqos commented on 2019-06-08 13:50

@Baerbeisser: gst-plugin-viper4linux-git provides gst-plugin-viper4linux.

Baerbeisser commented on 2019-06-08 13:33

'viper4linux-git' has the missing dependency 'gst-plugin-viper4linux', but the package's name in the AUR is 'gst-plugin-viper4linux-git'. So, in short, the dependency is missing a '-git'.

@yochananmarqos: Ok. But pikaur still complains about missing dependency 'gst-plugin-viper4linux' of package 'viper4linux-git'. Which is why i currently cannot update from the AUR.

yochananmarqos commented on 2019-06-07 16:01

@lucenera: Pacman can't install AUR packages.

yay -S --asdeps gst-plugin-viper4linux

lucenera commented on 2019-06-07 15:44

gst-plugin-viper4linux already installed and viper working, but if I try to update it gives me that error.

lucenera commented on 2019-06-07 15:43

~/build/viper4linux/viper4linux-git/ makepkg -si ==> Making package: viper4linux-git r55.ec2dcf6-2 (Fri Jun 7 17:40:53 2019) ==> Checking runtime dependencies... ==> Installing missing dependencies... error: target not found: gst-plugin-viper4linux ==> ERROR: 'pacman' failed to install missing dependencies.

yochananmarqos commented on 2019-04-29 22:28

@lucenera: The developer says there currently isn't a clean way to get the volume status of the original sink without without more dependencies.