Package Details: watchman 4.9.0-1

Git Clone URL: https://aur.archlinux.org/watchman.git (read-only)
Package Base: watchman
Description: An inotify-based file watching and job triggering command line utility
Upstream URL: https://facebook.github.io/watchman/
Licenses: Apache
Submitter: mithaler
Maintainer: FredBezies
Last Packager: flacks
Votes: 56
Popularity: 0.324564
First Submitted: 2013-06-19 17:23
Last Updated: 2017-08-23 18:32

Dependencies (2)

Required by (3)

Sources (2)

Latest Comments

1 2 3 Next › Last »

sandy commented on 2019-07-21 20:25

I found out that, It's problem with Manjaro XFCE edition. It's working fine on GNome Edition.

louis058 commented on 2019-05-30 08:20

I'm getting

/bin/sh: warning: here-document at line 0 delimited by end-of-file (wanted `COMPILE_LANGUAGE:CUDA>:SHELL:-Xcompiler')
/bin/sh: warning: here-document at line 0 delimited by end-of-file (wanted `NOT:')
  CXX      tests/integration/cppclient_t-cppclient.o
/bin/sh: COMPILE_LANGUAGE:CUDA>>:-pthread>: No such file or directory
make[1]: *** [Makefile:2765: tests/integration/cppclient_t-cppclient.o] Error 1

when building this.

I'm using nouveau, and I don't have CUDA installed (nor can I, I believe, since I don't have the proprietary driver). I can't seem to figure out whether watchman actually requires CUDA, but from what information I've been able to find, isn't CUDA optional for watchman?

blueyed commented on 2019-04-28 02:31

Would be nice if it would not compile the tests, for faster installation.

clofresh commented on 2018-10-27 17:15

You can speed up the build by using all your cpus: make -j $(nproc)

farwayer commented on 2017-08-23 17:50

4.9.0 was released

shadizzle commented on 2017-08-02 14:48

@vith Good to know, thank you.

vith commented on 2017-08-02 14:05

@shadizzle it is assumed that the base-devel group is installed

https://wiki.archlinux.org/index.php/Arch_User_Repository#Prerequisites

shadizzle commented on 2017-08-02 04:04

I was experiencing build issues that were resolved by installing the `automake` and `autoconf` packages from core. I'm new to the AUR and arch package management, but it seems that these should be explicit dependencies.

farwayer commented on 2017-07-09 14:41

@flacks do you plan to fix build issue?

jlesquembre commented on 2017-06-21 08:04

@mcirillo , no idea, sorry.

I replaced archlinux with a different linux on my computers, so I'm going to disown the package. You can be the new maintainer if you want.