Package Details: wsjtx-superbuild-git r35.491536f-4

Git Clone URL: https://aur.archlinux.org/wsjtx-superbuild-git.git (read-only, click to copy)
Package Base: wsjtx-superbuild-git
Description: Software for Amateur Radio Weak-Signal Communication (JT9 and JT65) - Superbuild/git version, hamlib not required
Upstream URL: http://physics.princeton.edu/pulsar/k1jt/wsjtx.html
Keywords: Amateur FT8 Ham JT65 Radio WSJT-X
Licenses: GPL-3
Conflicts: wsjtx
Provides: wsjtx
Submitter: KI9N
Maintainer: KI9N
Last Packager: KI9N
Votes: 3
Popularity: 0.136371
First Submitted: 2018-06-15 22:00
Last Updated: 2020-03-22 14:33

Latest Comments

masterplayer31 commented on 2020-03-22 03:49

Works now! Thank you!

KI9N commented on 2020-03-22 03:09

Should be FIXED for now, let me know @masterplayer31

KI9N commented on 2020-03-22 02:44

See: https://groups.io/g/WSJTX/topic/71254545?p=Created,,,20,2,0,0::recentpostdate%2Fsticky,,,20,2,20,71254545

There is an issue with QT5 5.14+ that causes this issue. You can downgrade qt5-base, qt5-multimedia, qt5-serialport, and qt5-tools to ver 5.13.2. Or wait for the WSJT-X team to fix. You could also try to apply the patch shown on the link above.

masterplayer31 commented on 2020-03-22 01:09

Will not build

[ 72%] Built target wsjt_qt_autogen make[4]: Leaving directory '/var/tmp/pamac-build-bobby/wsjtx-superbuild-git/src/wsjtx-superbuild/build/wsjtx-prefix/src/wsjtx-build' make[3]: [Makefile:152: all] Error 2 make[3]: Leaving directory '/var/tmp/pamac-build-bobby/wsjtx-superbuild-git/src/wsjtx-superbuild/build/wsjtx-prefix/src/wsjtx-build' make[2]: [CMakeFiles/wsjtx-build.dir/build.make:61: wsjtx-prefix/src/wsjtx-stamp/wsjtx-build] Error 2 make[2]: Leaving directory '/var/tmp/pamac-build-bobby/wsjtx-superbuild-git/src/wsjtx-superbuild/build' make[1]: [CMakeFiles/Makefile2:388: CMakeFiles/wsjtx-build.dir/all] Error 2 make[1]: Leaving directory '/var/tmp/pamac-build-bobby/wsjtx-superbuild-git/src/wsjtx-superbuild/build' make: [Makefile:84: all] Error 2 ==> ERROR: A failure occurred in build(). Aborting...

KI9N commented on 2019-01-12 02:18

NOW WORKING -- added a patch to use Sourceforge git instead of Bitbucket (not working) and added 'asciidoctor' dependency.

KI9N commented on 2018-06-15 23:28

The Superbuild version automatically builds the necessary 'hamlib' libraries from source so it is not required as a dependency.