Package Details: xivlauncher 1:1.0.8-2

Git Clone URL: https://aur.archlinux.org/xivlauncher.git (read-only, click to copy)
Package Base: xivlauncher
Description: Custom Launcher for Final Fantasy XIV Online (Crossplatform rewrite)
Upstream URL: https://github.com/goatcorp/XIVLauncher.Core
Licenses: GPL
Submitter: Cent
Maintainer: Cent
Last Packager: Cent
Votes: 12
Popularity: 3.76
First Submitted: 2022-04-19 00:13 (UTC)
Last Updated: 2024-03-19 17:32 (UTC)

Pinned Comments

Cent commented on 2022-10-25 14:33 (UTC) (edited on 2022-10-25 14:34 (UTC) by Cent)

In case anyone wants to contribute: https://github.com/Centzilius/aur-xivlauncher
Place where you can ask for help: https://discord.gg/3NMcUV5 (goatcorp discord)

Latest Comments

Nebelherr23 commented on 2024-03-19 11:15 (UTC)

Quick info: xivlauncher had a required update on 24-03-19, current tag is 1.0.8

rankynbass commented on 2024-03-17 17:25 (UTC) (edited on 2024-03-17 17:26 (UTC) by rankynbass)

There's a bug in pacman right now, which is causing the binary to be stripped even with the !strip option. You can fix it by changing the PKGBUILD options.

options=('!strip') should be options=('!strip' '!debug')

Bug report: https://gitlab.archlinux.org/archlinux/packaging/packages/pacman/-/issues/19

Arei commented on 2023-10-16 16:54 (UTC)

@Cent Oh, I'm glad the issue is more specific than I thought. I wasn't sure, but it might be related to a .NET based game I'm fiddling with currently (Vintage Story). I'll try to run some tests at the end of the week to try to pin the actual issue.

I sent the failed run logs you asked for the the PKGBUILD email address meanwhile.

Also I'll remember to try installing packages in a clean chroot beforehand. I'm still quite new to Arch. :)

Thank you for your work!

Cent commented on 2023-10-16 11:17 (UTC)

@Arei I was not able to reproduce your issue with the current version of the PKGBUILD in a clean chroot. Could you please provide the logs of the failed run? (Either by mail at the address listed in the PKGBUILD, by using a pastebin like service or by opening an issue on GitHub at the repo listed in the pinned comment).

Thanks!

Arei commented on 2023-10-15 09:22 (UTC) (edited on 2023-10-15 09:31 (UTC) by Arei)

For anyone confronted to the .NET MSB4236 error when trying to install/update this package, it looks like it is caused by the Arch dotnet package migration to .NET SDK 7.

I have no idea how to fix the PKGBUILD directly, but I was able to update XIVLauncher using the following workaround :

Install the .NET SDK 6 packages :

sudo pacman -S dotnet-sdk-6.0 dotnet-targeting-pack-6.0

Override the MSBuildSDKsPath env variable to point to the .NET SDK 6 path when installing the package :

MSBuildSDKsPath=/usr/share/dotnet/sdk/6.0.122/Sdks makepkg -si

Lexden commented on 2023-10-03 18:49 (UTC)

Thank you for maintaining this! I switched over from the flatpak version and did not even need to reinstall the game.

Cent commented on 2022-10-25 14:33 (UTC) (edited on 2022-10-25 14:34 (UTC) by Cent)

In case anyone wants to contribute: https://github.com/Centzilius/aur-xivlauncher
Place where you can ask for help: https://discord.gg/3NMcUV5 (goatcorp discord)