Package Details: xtrx-linux-pcie-drv-git r17.5ae3a3e-1

Git Clone URL: https://aur.archlinux.org/xtrx-linux-pcie-drv-git.git (read-only)
Package Base: xtrx-linux-pcie-drv-git
Description: XTRX PCI driver for linux
Upstream URL: https://github.com/xtrx-sdr/xtrx_linux_pcie_drv
Licenses: GPL
Conflicts: xtrx-linux-pcie-drv
Provides: xtrx-linux-pcie-drv
Submitter: lainpants
Maintainer: lainpants
Last Packager: lainpants
Votes: 0
Popularity: 0.000000
First Submitted: 2019-04-24 02:25
Last Updated: 2019-07-09 11:36

Dependencies (3)

Required by (0)

Sources (1)

Latest Comments

lainpants commented on 2019-07-09 11:37

Thanks! The patch is now applied.

GNUtoo commented on 2019-07-06 22:51

Hi,

here's a patch:

0001-Make-the-package-architecture-dependent-to-enable-sh.patch:

From 497f63ee9b598dde134d4d7b11c08697ff52bc91 Mon Sep 17 00:00:00 2001
From: Denis 'GNUtoo' Carikli GNUtoo@cyberdimension.org
Date: Sat, 6 Jul 2019 03:23:10 +0200
Subject: [PATCH] Make the package architecture dependent to enable shipping
 it.

While this works in AUR, because users are building the PKGBUILD, distributions wanting to use this PKGBUILD as-is and ship packages produced with it will have an issue as the package built will be installable on any architecture, but the binaries in the packages are not architecture independant.

Signed-off-by: Denis 'GNUtoo' Carikli GNUtoo@cyberdimension.org

PKGBUILD | 2 +- 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/PKGBUILD b/PKGBUILD index 75b5f91..774833a 100644 --- a/PKGBUILD +++ b/PKGBUILD @@ -5,7 +5,7 @@ pkgrel=1 pkgdesc="XTRX PCI driver for linux" provides=("${pkgname%-git}") conflicts=("${pkgname%-git}") -arch=('any') +arch=('armv7h' 'i686' 'x86_64') url='https://github.com/xtrx-sdr/xtrx_linux_pcie_drv' md5sums=('SKIP') license=('GPL') -- 2.22.0