Package Details: zecwallet-lite 1.7.13-2

Git Clone URL: https://aur.archlinux.org/zecwallet-lite.git (read-only, click to copy)
Package Base: zecwallet-lite
Description: Z-Addr first, Sapling compatible lightwallet client for Zcash
Upstream URL: https://github.com/adityapk00/zecwallet-lite
Keywords: cryptocurrency lightclient liteclient wallet zcash
Licenses: MIT
Provides: zcash-wallet
Submitter: GI_Jack
Maintainer: GI_Jack
Last Packager: GI_Jack
Votes: 1
Popularity: 0.000000
First Submitted: 2020-08-02 22:46 (UTC)
Last Updated: 2022-07-17 20:57 (UTC)

Latest Comments

1 2 Next › Last »

bepaald commented on 2022-12-21 13:12 (UTC)

Building this (in a clean chroot) results in an error:

Error: error:0308010C:digital envelope routines::unsupported

Searching around suggests this is to do with nodejs switching to openssl3, and presents some workarounds. I've also updated the PKGBUILD to the current release (1.8.8), but results were exactly the same.

Can anyone confirm this package doesn't build anymore, or is it on my end? Thanks!

bepaald commented on 2022-07-01 06:38 (UTC)

The problem I reported below (https://aur.archlinux.org/packages/zecwallet-lite#comment-870931) was on my end somehow. Just deleting the electron-builder directory in the .cache fixed it. After installing libxcrypt-compat, the package then built fine.

Technetium1 commented on 2022-07-01 03:47 (UTC)

Build in a clean chroot fails because libxcrypt-compat is missing in makedepends.

BlitDev commented on 2022-06-27 05:53 (UTC) (edited on 2022-06-28 05:57 (UTC) by BlitDev)

Build in clean chroot fails:

⨯ cannot execute  cause=exit status 127
errorOut=/home/main-builder/.cache/electron-builder/fpm/fpm-1.9.3-2.3.1-linux-x86_64/lib/ruby/bin.real/ruby: error while loading shared libraries: libcrypt.so.1: cannot open shared object file: No such file or directory

Here's the full build log: https://builds.garudalinux.org/repos/chaotic-aur/logs/zecwallet-lite.log

BlitDev commented on 2022-06-26 15:29 (UTC) (edited on 2022-06-26 15:30 (UTC) by BlitDev)

Error while run:

[89023:0626/222732.907376:FATAL:setuid_sandbox_host.cc(158)] The SUID sandbox helper binary was found, but is not configured correctly. Rather than run without sandboxing I'm aborting now. You need to make sure that /opt/zecwallet-lite/chrome-sandbox is owned by root and has mode 4755.

If execute chmod 4755 in /opt/zecwallet-lite/ the error is being corrected.

bepaald commented on 2022-06-23 07:40 (UTC)

Hi! Thanks for maintaining this package. The latest update (1.7.13-1) fails to build for me (at a point where I'd thought it had actually finished building) with the following error:

  • electron-builder  version=22.11.7 os=5.18.5-arch1-1
  • loaded configuration  file=package.json ("build" field)
  • writing effective config  file=dist/builder-effective-config.yaml
  • packaging       platform=linux arch=x64 electron=13.1.4 appOutDir=dist/linux-unpacked
  • building        target=AppImage arch=x64 file=dist/Zecwallet Lite-1.7.13.AppImage
  ⨯ open /home/bepaald/.cache/electron-builder/appimage/appimage-12.0.1/runtime-x64: no such file or directory
github.com/develar/app-builder/pkg/package-format/appimage.AppImage
        /Volumes/data/Documents/app-builder/pkg/package-format/appimage/appImage.go:110
github.com/develar/app-builder/pkg/package-format/appimage.ConfigureCommand.func1
        /Volumes/data/Documents/app-builder/pkg/package-format/appimage/appImage.go:59
github.com/alecthomas/kingpin.(*actionMixin).applyActions
        /Volumes/data/go/pkg/mod/github.com/alecthomas/kingpin@v2.2.6+incompatible/actions.go:28
github.com/alecthomas/kingpin.(*Application).applyActions
        /Volumes/data/go/pkg/mod/github.com/alecthomas/kingpin@v2.2.6+incompatible/app.go:557
github.com/alecthomas/kingpin.(*Application).execute
        /Volumes/data/go/pkg/mod/github.com/alecthomas/kingpin@v2.2.6+incompatible/app.go:390
github.com/alecthomas/kingpin.(*Application).Parse
        /Volumes/data/go/pkg/mod/github.com/alecthomas/kingpin@v2.2.6+incompatible/app.go:222
main.main
        /Volumes/data/Documents/app-builder/main.go:90
runtime.main
        /usr/local/Cellar/go/1.16/libexec/src/runtime/proc.go:225
runtime.goexit
        /usr/local/Cellar/go/1.16/libexec/src/runtime/asm_amd64.s:1371  
  ⨯ /tmp/pakku-bepaald/zecwallet-lite/src/zecwallet-lite-1.7.13/node_modules/app-builder-bin/linux/x64/app-builder exited with code ERR_ELECTRON_BUILDER_CANNOT_EXECUTE  failedTask=build stackTrace=Error: /tmp/pakku-bepaald/zecwallet-lite/src/zecwallet-lite-1.7.13/node_modules/app-builder-bin/linux/x64/app-builder exited with code ERR_ELECTRON_BUILDER_CANNOT_EXECUTE
    at ChildProcess.<anonymous> (/tmp/pakku-bepaald/zecwallet-lite/src/zecwallet-lite-1.7.13/node_modules/builder-util/src/util.ts:249:14)
    at Object.onceWrapper (node:events:642:26)
    at ChildProcess.emit (node:events:527:28)
    at maybeClose (node:internal/child_process:1090:16)
    at Process.ChildProcess._handle.onexit (node:internal/child_process:302:5)
error Command failed with exit code 1.

Any ideas? Thanks!

komersreal commented on 2022-03-02 09:14 (UTC) (edited on 2022-03-03 23:02 (UTC) by komersreal)

==> Starting prepare()...
node: symbol lookup error: node: undefined symbol: _ZN6icu_698ByteSink15GetAppendBufferEiiPciPi
==> ERROR: A failure occurred in prepare().
    Aborting...
==> ERROR: Makepkg was unable to build zecwallet-lite.

The zecwallet-lite package is not installed after updating icu70 to version 70.

Help me update the current version of zecwallet-lite so that it installs.

Solution:

reinstall nodejs:

pacman -S nodejs

and install libxcrypt-compat

pacman -S libxcrypt-compat

and then install zecwallet-lite:

yay -S zecwallet-lite

wallacoloo commented on 2022-02-19 01:15 (UTC)

build fails with: "error while loading shared libraries: libcrypt.so.1"

fixed by installing libxcrypt-compat (AUR packaged). maybe it should be added to the dependencies list in this PKGBUILD.

1994 commented on 2022-02-16 08:27 (UTC)

Here is a patch to make the build work on aarch64.

  • Patch package.json to stop building the deb, since that tries to use x86_64 version of fpm (and we don't need it)
  • If arch is aarch64 then uses the linux-arm64-unpacked directory instead of linux-unpacked

https://pastebin.com/W3tXTBUj

jancici commented on 2021-11-09 19:45 (UTC) (edited on 2021-11-09 20:11 (UTC) by jancici)

Hi I am trying to install this wallet but getting following error:

[1/4] Resolving packages...
[2/4] Fetching packages...
error electron-builder@22.11.7: The engine "node" is incompatible with this module. Expected version ">=14.0.0". Got "12.22.7"
error Found incompatible module.
info Visit https://yarnpkg.com/en/docs/cli/install for documentation about this command.
==> ERROR: A failure occurred in prepare().
    Aborting...
error: failed to build 'zecwallet-lite-1.7.4-1': 
error: packages failed to build: zecwallet-lite-1.7.4-1

I have also electron13 installed because it is needed by element-desktop. Could be a problem?