Package Base Details: amdgpu-pro-installer

Git Clone URL: https://aur.archlinux.org/amdgpu-pro-installer.git (read-only)
Submitter: LEW21
Maintainer: Ashark
Last Packager: Ashark
Votes: 80
Popularity: 2.131009
First Submitted: 2016-03-28 22:44
Last Updated: 2019-08-17 08:46

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Ashark commented on 2019-10-05 17:06

@aDogCalledSpot Can you provide exact actions, so I could reproduce?

aDogCalledSpot commented on 2019-10-05 16:50

I get the following error message multiple times when trying to install on Arch with kernel 5.3.1

==> ERROR: install file (amdgpu-pro-core-meta.install) does not exist or is not a regular file.

Kepos commented on 2019-08-28 15:23

@Ashark Did not get what you are trying to point me to, sorry. But, I got it running on myself lately. Checked Kernel first, as I knew the driver only works with higher then 4.15-Kernel, but I have 5.2.9 installed. Then I tried to install vulkaninfo (https://aur.archlinux.org/packages/gpu-viewer/) which brought up a conflict between 'mesa-demo' and 'glxinfo'. De-installed 'glxinfo' and so I got vulkaninfo and additionally now the requested vulkan driver up and running.

Ashark commented on 2019-08-25 17:34

@Kepos Sorry, I cannot understand what is your problem. Probably, you have missed to read vulkan article on archwiki.

Kepos commented on 2019-08-25 16:40

The installation worked without any issue with Arcolinux Deepin edition. Unfortunately, I can't find Vulkan support and also Steam's Proton doesn't work correctly without. Mesa + Vulkan was pre-installed, then I installed the above snap. Amdgpu-pro has built-in Vulkan support. Did I miss something?

Ashark commented on 2019-08-17 17:55

@tigr72 force remove it: pacman -Rdd libdrm-amdgpu

tigr72 commented on 2019-08-17 16:14

dependencies could not be satisfied: installing amd gpu-core-meta (19.30_855429-1) breaks the 'amd gpu-core-meta=19.30_838629-1' dependency required by lib32-libdrm-amdgpu installing amd gpu-core-meta (19.30_855429-1) breaks the 'amd gpu-core-meta=19.30_838629-1' dependency required by libdrm-amdgpu

Ashark commented on 2019-08-16 02:14

@lod you are right. They have released 19.30-855429 for all supported distributions and gpus. Here is a link to release notes page: https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux

Ashark commented on 2019-07-11 15:36

@tfla this is ok. They renamed a hip package, so did I.

tfla commented on 2019-07-10 11:30

I needed to pacman -R opencl-amdgpu-pro-hip before updating to 19.30_838629-1, also I get this warning for every package after the first:

warning: amdgpu-core-meta-19.30_838629-1 is up to date -- reinstalling
warning: amdgpu-pro-core-meta-19.30_838629-1 is up to date -- reinstalling
warning: amdgpu-pro-libgl-19.30_838629-1 is up to date -- reinstalling
warning: amf-amdgpu-pro-19.30_838629-1 is up to date -- reinstalling
warning: hip-amdgpu-pro-19.30_838629-1 is up to date -- reinstalling
warning: lib32-amdgpu-pro-libgl-19.30_838629-1 is up to date -- reinstalling
warning: lib32-libdrm-amdgpu-19.30_838629-1 is up to date -- reinstalling
warning: lib32-opencl-amdgpu-pro-orca-19.30_838629-1 is up to date -- reinstalling
warning: lib32-vulkan-amdgpu-pro-19.30_838629-1 is up to date -- reinstalling
warning: libdrm-amdgpu-19.30_838629-1 is up to date -- reinstalling
warning: opencl-amdgpu-pro-comgr-19.30_838629-1 is up to date -- reinstalling
warning: opencl-amdgpu-pro-dev-19.30_838629-1 is up to date -- reinstalling
warning: opencl-amdgpu-pro-orca-19.30_838629-1 is up to date -- reinstalling
warning: opencl-amdgpu-pro-pal-19.30_838629-1 is up to date -- reinstalling
warning: roct-amdgpu-pro-19.30_838629-1 is up to date -- reinstalling
warning: roct-amdgpu-pro-dev-19.30_838629-1 is up to date -- reinstalling
warning: vulkan-amdgpu-pro-19.30_838629-1 is up to date -- reinstalling